Sign in with
Sign up | Sign in
Your question
Closed

How do i fix this Starcraft 2 lag!

Last response: in Video Games
Share
September 12, 2010 9:15:35 PM

I have a Intel Core i5 650 @ 3.20 GHz and ATI Radeon HD 5830 Series. And whenever i play Starcraft 2 i lag on anything above Low/Medium. I know i should be able to run ultra like nothing.. Any help?

More about : fix starcraft lag

September 12, 2010 11:18:50 PM

That's weird. I would run PassMark to benchmark my system and compare the results to others with your CPU+GPU combo. That would indicate whether you are having a hardware or software problem.

But you're right, you should be on ultra. I have an i5-661 with an HD5770 and I have no problems playing Starcraft 2 on ultra.
Score
0
September 12, 2010 11:32:37 PM

3D Graphics Mark
This Computer 1752.7

Graphics 3D - Simple
This Computer 1884.0

Graphics 3D - Medium
This Computer 492.6

Graphics 3D - Complex
This Computer 39.7

Graphics 3D - DirectX 10
This Computer 43.4
Score
0
Related resources
September 12, 2010 11:34:29 PM

Also
PassMark Rating
This Computer 758.6

CPU Mark
This Computer 1438.0

2D Graphics Mark
This Computer 204.5

3D Graphics Mark
This Computer 1752.7

Memory Mark
This Computer 479.1

Disk Mark
This Computer 530.0

CD Mark

Score
0
September 13, 2010 8:41:35 AM

Weird indeed.. Have you tried a graphics driver update?
Score
0
September 13, 2010 11:28:44 PM

I've reinstalled them numerous times and even upgraded to windows 7 x64
Score
0
September 14, 2010 7:14:15 AM

How much RAM?
Score
0
September 14, 2010 7:06:35 PM

make sure systemis well cooled and cables are neat a plenty of ram that should help
Score
0
September 15, 2010 6:35:20 AM

I got 4gbs of ram and my computer is usually at 40-50 C
Score
0
September 15, 2010 11:34:48 AM

Have a look at your Power Options settings in Windows and make sure that you are not on the Power Saving profile. This profile prevents the CPU and GPU from setting their clock speeds to maximum when you run a demanding application.
Score
0
September 15, 2010 5:04:09 PM

perhaps it's not your comp but your ISP/ router ?

I had issues as well until I turned my settings way low, then again my comp is not as good as yours.
Score
0
September 16, 2010 1:57:45 AM

i checked and my power saving is on high performance.
Score
0
September 16, 2010 8:35:16 AM

jgiron said:
perhaps it's not your comp but your ISP/ router ?

I had issues as well until I turned my settings way low, then again my comp is not as good as yours.



Router or ISP speed should have no effect on the game's performance, besides lag in online gaming of course.

Quite honestly, I'm stumped. Are you sure that both your CPU and CPU spin up to maximum clock speeds when you launch the game?
Score
0
September 16, 2010 4:39:24 PM

lakersfan1 said:
I have a Intel Core i5 650 @ 3.20 GHz and ATI Radeon HD 5830 Series. And whenever i play Starcraft 2 i lag on anything above Low/Medium. I know i should be able to run ultra like nothing.. Any help?


Update drivers?
Download 10.9 to your videocard :p  (amd newest driver)
Score
0
September 17, 2010 1:16:52 AM

Herr_Koos said:
Router or ISP speed should have no effect on the game's performance, besides lag in online gaming of course.

Quite honestly, I'm stumped. Are you sure that both your CPU and CPU spin up to maximum clock speeds when you launch the game?

Not sure, but i know under cataylst control center i cant change the fan speed or anything
Score
0
September 17, 2010 7:02:31 AM

Fan speed is not the issue here, the question is whether the card ever gets out of idle mode when you start playing. Does CCC give you graphs of your GPU clocks? If so you can leave it open, run the game for a few minutes, and then verify that your GPU was indeed running at full speed while the game was running.
Score
0
September 17, 2010 10:45:07 PM

Herr_Koos said:
Fan speed is not the issue here, the question is whether the card ever gets out of idle mode when you start playing. Does CCC give you graphs of your GPU clocks? If so you can leave it open, run the game for a few minutes, and then verify that your GPU was indeed running at full speed while the game was running.

ATM it runs on 800MHz for GPU (875MHz Is max) and 1000MHz for Memory (1200MHz is max)
Score
0
January 23, 2012 10:29:34 PM

This topic has been closed by Mousemonkey
Score
0
!