Sign in with
Sign up | Sign in
Your question

Mafia 2 strange graphic

Last response: in Video Games
Share
September 14, 2010 6:59:05 PM

Hello,
I've got to Mafia 2 today and I have very strange graphics problem. Eg. the snow is white, but reflects turquoise and purple :o  Thing is, when I make screenshot so I can show you (print screen -> ctrl + v in photoshop and want to save it), the strange colors aren't there. It's happening only in Mafia 2, I tried Sniper: Shadow Warrior and it was totally without any problems. (I'm sorry that the screenies are so big)
I've taken a photo of screen with my mobile phone


and a screenshot saved in photoshop


I'm running all settings at max, 2560x1900 resolution, Catalyst 10.7 drivers and PhysX off, version .513 installed.
My specs:

MB Gigabyte GA-X48-DS5 (rev 1.1)
CPU Intel Core2 Quad Q9550, @3,2Ghz
GPU Sapphire ATI Radeon HD 5970 4GB DDR5
Corsair Dominator DHX 8GB 1066Mhz CL5 DDR2 RAM
PS Fortron EVEREST 1010WPLUS
HDD OCZ 2.5" SSD Core Series 64GB

EDIT: I'm updating to Catalyst 10.8, but that won't prolly help.
EDIT2: Yop, it didn't help a thing :/ 

More about : mafia strange graphic

September 15, 2010 5:16:15 PM

Not sure if there are any settings for bloom or hdr? Sometimes, I know bloom can cause some severe brightness issues like what you are experiencing.

Try turning off any bloom or hdr effects and see if that helps. I know with Oblivion, when I have bloom turned on, things get really bright.
September 16, 2010 8:56:24 PM

First try resetting settings to default.
Try reinstalling dirvers and the game
If none works then you might have a defective video card which I doubt.
Related resources
September 16, 2010 9:54:49 PM

I tried to reinstall game, several versions of drivers, but nothing helped. I've tried games which use better effects than mafia, all fine. This strange thing is happening in certain time of the day in game, sometimes it fades and the game looks completely normal.
I can see this glary shiz also in the nVidia ad movie and even the 1st text screen. Really helpless here :/ 
May 23, 2012 3:49:30 PM

same problem...
May 23, 2012 5:57:23 PM

turn off bloom altogether... reduce hdr to medium... im pretty sure nvidia only lets you have 1 or the other so if you have bloom on regardless of how high its set, hdr is switched off.
May 23, 2012 10:41:45 PM

it's also possible your monitor cannot show the game gamma properly, ie you should adjust your brightness
!