Gta 4 direct x11

Hello,

I have problems running GTA4 on my PC, i only get 1~7 FPS

My Setup:

Asus GTX470
Asus M2N Motherboard
AMD Athlon 62x2 6000+ ~3.0Ghz (dual Core)
4 Gb Ram, 800Mhz

I think this is a weird weird problem, with my 8800GTS i was running the game perfectly.

I hope you guys have any Ideas
9 answers Last reply
More about direct
  1. this games is highly processor dependent gentlemen. I believe that is a not so recently made dual core processor and mobo. I have a asus m2n mobo and its about 4 yrs old.

    upgrade ur processor or run on the low setting maybe.
  2. But it ran great with my 8800GTS, i have a better card now, and it runs rubbish, not the fault of the processor i think
  3. Did you update the drivers properly?
  4. You never told us the other card, also why the title has GTA4 using dx11 is beyond me.
  5. Quote:
    Hello,

    I have problems running GTA4 on my PC, i only get 1~7 FPS

    My Setup:

    Asus GTX470

    Asus M2N Motherboard
    AMD Athlon 62x2 6000+ ~3.0Ghz (dual Core)
    4 Gb Ram, 800Mhz

    I think this is a weird weird problem, with my 8800GTS i was running the game perfectly.

    I hope you guys have any Ideas


    dalta centauri said:
    You never told us the other card, also why the title has GTA4 using dx11 is beyond me.


    In the OP two cards are mentioned.
  6. GTA4 requires a few things to run smoothly. Lots of CPU power (Quad preferred to Duo), lots of GPU Memory, and proper settings: clean and fresh latest Nvidia drivers + the latest game patch(es).

    The more memory you load onto your settings (even if still green), the more CPU power is required (i.e. traffic). Although your new GPU may process some of the display settings better, the overall settings becomes harder on your CPU, which is most likely your bottleneck.

    That said, if you say it ran great before, try the same settings as before and troubleshoot from there (incl resolution).

    Nota: Your new GPU processes graphics completely differently than the previous Nvidia GPU family. My guess is you need either a game patch or you need to download a driver cleaner and re/install the latest nvidia drivers.

    Hope this helps.

    Alex
  7. Hey, thanks for your reply's

    I installed the latest NVidia Drivers, and it worked! the game RAN smoothly

    But when i came back and turned my PC on, again 1 fps :(
  8. Hmm...try a virus scan...and if you really have nothing better to do this weekend, try resintalling windows? This seems to be a software issue.
  9. it is all working again somehow, just 1000 reboots later and it worked :S , Thanks all for your fast
    reply's ! :hello:
Ask a new question

Read More

PC gaming Asus Dual Core Video Games