Sign in with
Sign up | Sign in
Your question

Tritton AX 720 Mic Issues on PC

Last response: in Video Games
Share
September 15, 2010 7:40:00 PM

I can play XBL and my mic works flawlessly, I don't get the static that everyone talks about and when people are using my mic they sound perfect. BUT when I switch over to my PC I get the sound in the headset but then the mic just stops working and absolutely nothing is picked up by the mic then. The part that concerns me is that 3 months ago the mic worked fine for talking on Ventrilo while I play WoW so I am confused at what could have changed between then and now. Possibly a windows update that might have messed it up?

Out of ideas and tired,
Kilo

More about : tritton 720 mic issues

September 15, 2010 7:50:29 PM

What version of Windows on the PC?

Have you checked if your PC is detecting the mic in the control panel / sound settings?
m
0
l
September 15, 2010 8:14:18 PM

Windows 7 Professional 64-bit

Yes, the PC gives me the mic as an option to choose and I selected it as default device.
m
0
l
Related resources
September 15, 2010 8:51:09 PM

Have you gone through the mic setup wizard to see if that helps?

If you open the Sound Settings -> Recording Tab -> select the mic -> Properties -> Levels Tab -> Make sure Mic Boost is maxed.

Apply those settings and then click the Listen tab. Check "Listen to this device" and start talking. See if you can hear yourself after the boost. (also make sure your playback device is set correctly)


*SUPA EDIT* Have you looked at the user guide for connecting the setup to your PC? http://support.trittontechnologies.com/supportsuite/ind... if you click the PDF listed there it gives specific instructions for each connection method to a PC. Specifically look at Page 10. Hope this helps.
m
0
l
September 15, 2010 9:27:11 PM

Tried and nothing just a high pitches squeal that is really quiet like the mic is open but not picking anything up.

EDIT: The mic is hooked up correctly.
m
0
l
August 4, 2011 12:59:36 AM

I am experiencing the same problem. I'll update as soon as a I find a solution
m
0
l
November 26, 2011 11:14:34 PM

I think I might have a solution. If there is a little switch that says Xbox-PC2/ PS3-PC1, switch it to the opposite of what it is already set as. If the sound quality of the headset gets worse, follow these steps.

1. Go to Control Panel
2. Hardware and Sound
3. Sound
4. Set the Speakers, High Definition Audio Device to the default device
and the default communication device.

Hope this helped!
m
0
l
!