Sign in with
Sign up | Sign in
Your question

GTA IV lag spikes please help very annoying!

Last response: in Video Games
Share
September 21, 2010 8:10:10 PM

ok so i just bought and installed GTA IV on my PC, but even if i keep it on the lowest settings or higher settings i get these lag spikes every 3-5 seconds. It is very annoyting. I have great FPS when the spikes dont occour.
I also installed it on my other computer [Core 2 Duo 6600 2.4 GHz, GeForce 7950 GX2 512mb and 2 GB of RAM] and it runs medium-high settings with no problems. Piece of cake. But the computer that im struggling with now [Core i3 530 2.93 GHz, HD 5450 1 GB and 8 GB of RAM, 750 GB HD] isnt all good....
And i have some other problems/bugs in other games too, but they just give me advantages... For example i can run the crysis demo with 1024 res and everything max except shadows on low and shaders on high with 20-30 FPS...
And the same with Far Cry 2, but in Far Cry it seems to be a texture bug so the rock textures get all blurry. Has this anything to do with it? I have read that defragmenting the hard drive should do the trick... But havent tried it yet. Or is the problem caused by my ATI driver? Or do i need to patch GTA IV? Thanks for reading this book :kaola: 
September 21, 2010 8:39:06 PM

Hi eilif, my advice is always update, make sure everything is up to date and try running it again, if theres no luck in that quest try google it sometimes has whole threads just waiting there with the right answers on. Also don't forget to update your graphics card to the latest driver. I have found many times that can fix many problems big or small. Hope I helped.
m
0
l
September 22, 2010 2:04:26 AM

Ummm... buy the PS3 or XboX version?

Oh yeah.. you need a PS3 or Xbox to play those versions, nevermind.

What an excellent crap-tacular port of a console game.
m
0
l
Related resources
September 22, 2010 5:39:35 AM

Thanks moose. And jaguar, yes the xbox and ps3 version of the game is better i must agree to that. Although GTA in my opinion is the only game better on console. But its just that they didnt bother optimizing GTA IV for computers, so it has insane requirements. And i cant help seeing your q9450 and 5850... Thats a nice setup.
m
0
l
September 22, 2010 3:38:25 PM

eilif said:
Thanks moose. And jaguar, yes the xbox and ps3 version of the game is better i must agree to that. Although GTA in my opinion is the only game better on console. But its just that they didnt bother optimizing GTA IV for computers, so it has insane requirements. And i cant help seeing your q9450 and 5850... Thats a nice setup.


+ 1 on the bad optimizing. they did such a bad job, also let me know if you fix the problem :D 
m
0
l
September 22, 2010 10:40:27 PM

A 5450 for gaming. You are kidding right ? Borrow his video card and see what happens............. and that card isn't much good for that game either.
m
0
l
September 23, 2010 5:43:28 AM

Hey swift i run Crysis Demo on Very high with 1024 res and shadows to low and shaders to high with 20 FPS.... Beat it. My card isnt the best for gaming, yes, but what really matters to me is the gameplay.
m
0
l
September 23, 2010 7:50:50 PM

eilif said:
Hey swift i run Crysis Demo on Very high with 1024 res and shadows to low and shaders to high with 20 FPS.... Beat it. My card isnt the best for gaming, yes, but what really matters to me is the gameplay.


Yeah, and however badly written Crysis is GTA IV is worse so a 5450 simply won't cut it for that game.
m
0
l
September 29, 2010 7:25:29 PM

Did they even TRY to optimize GTA IV????
m
0
l
October 17, 2010 8:19:57 PM

GTA IV is Bugy game , u wont see it running fine because it has been programed very bad . but u can try GTA Liberty City , its better .
m
0
l
April 25, 2011 10:50:27 AM

Guys. I have switched the 545+ our witha GT 240 DDR3 1 GB.
it runs CoD4 on max with 100 FPS, and GTA IV on amx with 30 FPS; but still with the same lag spikes! Wtf do i do?
m
0
l
April 25, 2011 3:29:32 PM

the main problem is that your running off a dual core. gta 4 needs 3 cores minimum b4 it runs smoothly, like others have said its a bad port and because the xbox has 3 cores they decided that they didnt need to optimize it to use 2 for pc.
it really does need more than 2 cores. it will work well on 3 but even better on 4.
m
0
l
April 26, 2011 5:03:07 PM

oh. What a pile of *** that game is. But it ran fine on my other computer, with a Core 2 Duo @ 2.4 GHz, with a 7950 GX2?
m
0
l
April 26, 2011 7:30:04 PM

thats because you ran it on such a low end card. a 7950 gx2 although in its day was the nutz. today can be beaten by a 9600gt
m
0
l
April 27, 2011 5:47:23 AM

1 7950 GX2 is NOT a low end card! It is actually very powerful. and it's about 5 years old!
In fact, it runs CoD4 maxed out with 60+ FPS.

And besides, it had a C2D @ 2.4 GHz and a 7950.
I run a i3 @ 2.9 GHz (dual-core+HT) and a GT 240..
I mean.. the game is playable in between the lag spikes!
I can even run GTA IV on max with playable FPS, but only between those lag spikes wich occour every 2 seconds or so.
m
0
l
Anonymous
May 25, 2012 2:23:40 PM

the lag spikes has nothing to do with what kind of prosessor or graphics card you have its just a huge annoying bug with th game, since its just a port from the console version, its also one of the buggiest games of the decade, so dont expect to ever run it smoothly.
m
0
l
Anonymous
May 25, 2012 2:25:13 PM

and call of duty 4's graphics sucks/can be run on max on most computers.
m
0
l
May 26, 2012 6:47:24 AM

Guys, I have a core 2 Duo 2.4 GH CPU, ATI 6570 2 GB graphic card, 3.5 RAM, and still having problems. my FPs sucks, I switched between different graphic settings but it didn't change at all. :-( Im frustrated help me please

note: I have windows 7 ultimate
m
0
l
Anonymous
May 26, 2012 2:52:17 PM

its because of the pc version is a port from the console version and there is alot of bugs in the game, many of them include lag spikes, performance issues, and just general bugs like, cars falling from the skies and ***.
m
0
l
September 2, 2012 11:25:53 PM

Ok guys my game spikes to runs smooth 2 seconds then lags.. and that process repeates need help on fixing. Heres the hardware i have

CPU:AMD FX-8150 8 Core processor
MB: Gigabyte UD-5
RAM: Corsair vengance 16gb(four 4gb sticks)
GPU: Radeon 6950 2gb
And then os runs of a 3gb/s SSD and games on a 7200rpm hdd think its a WD

all liq cooled so heat is not the problem lol
m
0
l
!