Sign in with
Sign up | Sign in
Your question
Solved

Can't see the servers on Bad Company 2

Last response: in Video Games
Share
October 17, 2010 1:56:11 AM

Last week I picked up Battlefield Bad Company 2 from Best Buy. Absolutely love it so far.

However when I try to play multiplayer I can not see any servers or find any.

I have registered.

When he game was installed it pulled like 2 or 3 updates.

So I think I am current.

As you can see by my signature my PC does meet the system requirements for the game.

Is there anything else I am missing?

More about : servers bad company

October 17, 2010 2:52:00 AM

If you can log in and see the server screen then you should be able to see the servers, make sure you check the boxes according to your preferences.
m
0
l
October 17, 2010 1:50:05 PM

^ yes, make sure your filters are set up so you aren't filtering everything out. Also, there is an updater program in the BF folder. I would try forcing another update with that updater just in case. Usually when you can't see servers you are a version behind.
m
0
l
Related resources
October 24, 2010 1:12:40 AM

The updater runs on it's own every time I launch the game and it seems to like the current version. I took your suggestion and went in to the folder to force the update (I thought that was a great idea btw). However that did not work. I also placed a check mark by several of the filters. Still zero servers are showing to be available.

It's frustrating. Any other suggestions?
m
0
l
October 24, 2010 2:43:28 AM

Do you go through a router or have firewall software? Maybe you can turn it off or try directly connected to your modem. After that I am out of suggestions. Hitting up the EA BC2 forum might lend you more ideas. Sorry man, what an annoying issue.
m
0
l
October 24, 2010 1:44:28 PM

I got microsoft security essentials however that has never prevented me from playing other games like Call of Duty, Star Craft 2, or WOW.

I am thinking about uninstalling and reinstalling the game and start from scratch.
m
0
l

Best solution

October 24, 2010 8:11:33 PM

The same thing happened with me when I got the game.

1. Make sure you get the latest patch, don't do the auto-update, it was unreliable for me. Get it straight from their site.

2. Run as administrator.
Share
October 24, 2010 10:20:59 PM

THANK YOU!!! That is what I needed to hear.

Could you link me the patch?
m
0
l
November 4, 2010 1:09:08 PM

I just now got it working. I just got a new harddrive for my gaming rig and reinstalled windows in a RAID 1 configuration. This time I installed Bad Company 2 before Microsoft Security Essentials.

As a result the initial update processed and now I can see the servers and was able to play online briefly this morning.

Thanks so much for your help.
m
0
l
November 4, 2010 1:09:46 PM

Best answer selected by rwayne.
m
0
l
November 4, 2010 2:28:43 PM

I would like you to meet this case, fortunately someone help me this problem, thank you, good fun
m
0
l
!