Starcraft 2 patching problem

Hey there,

I just bought a hard copy of Starcraft 2 the other day. The disc itself is in brand new, perfect condition. I tried to install it and I kept getting an error at around 50-52% and the installation would stop. I got ahold of Blizzard and they gave me a line of worthless information that didn't help at all. I just kept trying to install and eventually.....it worked! I figured maybe it was some glitch...but who cares, it worked.

Well now I have to install the newest patch in order to play. So I click on the Starcraft icon and the patch begins to download automatically. And every time I get to 98%, I get this error:

'The patch "base\Mods\Core.SC2Mod\Base.SC2Data\BlizzardComponent.xml" could not be applied. (MD5 mismatch: expected 0x99DE5B800B92481DC551E38B375700E5, actual 0x7896F815DCC46FAA28C2355573B02C89.)(PTCApply_BSDiff failed.) If this problem persists, you may be able to solve it by uninstalling and then reinstalling the game. If you are unable to correct this problem, please contact Blizzard Technical Support. (BNUpdate::PTCApply)'

This is pissing me off. I spent 60 dollars on a game that apparently doesn't work. I found some 'solutions' online but they didn't work. Things like, make sure you're signed in as Administrator or turn off your firewall and anti-virus while downloading patch. Nothing has worked. I thought i'd ask you guys before I returned this thing to the store. From what I hear, this is a widespread problem. Any constructive ideas on how to get this to work?
1 answer Last reply
More about starcraft patching problem
  1. Oh, by the way, my specs are:

    Phenom 2 x4 955 BE

    Asus evo mobo

    Sapphire HD 5770

    500gb hdd

    4gb Ram (G.Skill)

    700w PSU

    Windows 7 (64-Bit)
Ask a new question

Read More

PC gaming Hard Copy Starcraft 2 Video Games