Sign in with
Sign up | Sign in
Your question

Sc2 ultra setting issue

Last response: in Video Games
Share
November 12, 2010 11:59:11 PM

SYSTEM SPECS:
CPU: i7 940 2.98ghz

Mobo: ASUS Sabertooth x58

Video Card: nVidia gts250 1gb DDR5

RAM: Kingston HyperX Blu 2 sticks of 2gb DDR3 1600

HDD: 1 320gb seagate 7900rpm sata, 1 500gb WD 7900rpm sata

OS: Windows 7 64-bit



ok, so as you can see i have a system that SHOULD be able to run SC 2 on ultra while doing backflips, but when i set it to ultra (up from high) i get a slightly laggy response b4 I join a game and terrible lag while in game. While i was running windows xp media center with a core 2 duo (2.4ghz), 4gb RAM DDR2 667, same video card, same hard drive, and ASUS P5N32-e SLI mobo i could run ultra like nobody's business. Now i have been told that there are some issues with SC2 and quad/6 core processors, is this my issue, or have i overlooked something?

and yes all drivers (audio, video, and mobo) have been updated, still i get the same problem....
plz halp!

November 13, 2010 3:48:55 AM

Resoution of Monitor?
m
0
l
November 13, 2010 3:58:17 AM

1980x1020, im using a DVI to HDMI cable to connect my computer and my monitor (LG w2340vg)
m
0
l
Related resources
November 16, 2010 11:28:41 PM

your video card cant handle it my gt220 lags alot when i try and play it.
m
0
l
November 17, 2010 5:54:20 AM

ownsyouall said:
your video card cant handle it my gt220 lags alot when i try and play it.


Ehhh. no. BIG performance difference between the GTS220 and the 250. The 220 is not a gaming card. The 250 is based on the older 9800GTX which is plenty powerful, though not at extreme resolutions.

The only issue with SC2 and multi-core processors is that the game doesn't know how to use more than 2 cores.

One possibility: Have a look at your Windows 7 power profile settings and check that it's not on Power Saver for some reason. I had this happen to me after I installed 7 and had a heck of time figuring out why my games were so laggy...
m
0
l
!