Sign in with
Sign up | Sign in
Your question
Closed

Street Fighter 1V FPS only 30 with 6850

Last response: in Video Games
Share
November 13, 2010 5:32:57 PM

Hi Guys,

I have the following configuration :

G-Skill 2GB DDR3 *2
AMD Phenom II x4 955
MSI 890FXA-GD70
ATI HD 6850 1 GB
WDC 1 TB Caviar Green HDD
Corsair TX 750W
Windows 7 Proffessional

The first day I set this configuration and played Street Fighter IV with all the settings maxed out at 1680X1050 resolution, the FPS was 60 and the game was running smoothly. I dont know what has happened in a week's time that this FPS has dropped to 30. The only change I can remember may be upgrading ATI Catalyst Control Center upgraded to 10.10.

I am playing other games like Race Driver Grid, COD MW, COD WAW, COD MF 2, Prototype with highest settings on resolution of 1680X1050 and they all are running smooth. Dont know what happened in this mean time..

I am playing it with Full Screen enabled. I tried reinstalling the game. I tried checking/unchecking the application settings box in ATI Catalyst Control Center and tried running the game but no joy..

Can somebody please assist me with this..
November 14, 2010 8:02:24 AM

47 people viewed it.. but no advise offered yet... :( 
November 14, 2010 12:29:34 PM

I disabled V-Sync and FPS came to 40. However, when I decrease AA from 8x to 4x then it comes out to give me 58-60 FPS. Even in this scenario, when the scene for jungle come up, the FPS again gets reduced to 30. However in other scenes it is maintained at 60 fps.

So does it mean that this card is not sufficient enough to deliver Street Fighter IV at max settings.... ??
Related resources
November 14, 2010 2:14:24 PM

You already tried , v sync off, re installing the game, what next, maybe you could try reinstalling or upgrading the drivers
November 14, 2010 2:51:49 PM

In the game option pc setting have you tried looking at the framerate setup is it "fixed or variable"?
November 18, 2010 4:34:57 AM

venjhammet said:
In the game option pc setting have you tried looking at the framerate setup is it "fixed or variable"?



Its variable.. I tried moving Supersampling to Adaptive Multi-sampling mode and that helped a lot.
November 21, 2010 12:08:51 PM

I uninstalled it completely.
November 21, 2010 10:33:11 PM

did you try stabing it with your predator claw ? or maybe shooting it with your lazer ?
November 22, 2010 4:51:37 AM

marquis said:
did you try stabing it with your predator claw ? or maybe shooting it with your lazer ?



Hehe.. None helped.. so decided to uninstall it. Now games run good.
November 25, 2010 3:59:05 AM

Best answer selected by vermakhil.
November 25, 2010 2:46:32 PM

marquis said:
did you try stabing it with your predator claw ? or maybe shooting it with your lazer ?

LOL :lol: 
November 27, 2010 10:52:01 AM

This topic has been closed by Mousemonkey
!