Sign in with
Sign up | Sign in
Your question
Closed

Blurry in fullscreen sharp in windowed mode

Last response: in Video Games
Share
December 7, 2010 12:01:52 AM

So my monitor's native rez is 1920 x 1080p @60hz, i set all my games at this standard. I'm using a 9800 GT never have had problems with it. I installed Civ5 via steam AND problems occur. So when i set to the native rez everything looks like it has jagged edges im talking menu's and text here not even ingame graphics. So i run it in windowed mode at MY NATIVE resolution and what do you know perfectly sharp textures.

This problem Also started with BC2; Yes i have the latest drivers. running windows 7 64bit, a sony bravia 32" hdtv. This issue isnt effecting CS:S i havent looked at any other games. I'm thinking of just nuking my HDD and starting fresh but would rather not as i have a huge log of Mod's ect for my gaemz

But if anyone else had some solutions O BTW WHAT I'VE TRIED SO FAR

Nvidia control panel: reset everything to default settings
same with win7 resolution options
I JUST uninstalled BC2 (dont care if i have to played windowed civ but a windowed FPS is unacceptable) currently re-downloading it via steam will update later.
December 7, 2010 5:35:30 AM

Did you reinstall the driver?
Btw, a 9800 Gt a 1080 P, is not a nice combo, I sometimes struggle to play games at highest settings with my gtx 460 paired with a c2Quad..
Score
0
December 7, 2010 5:08:44 PM

The 9800 works fine i get high settings for bc2, black ops, and hell most games just fine.

Did a fresh driver install problems still occur Everything looks pixelated in fullscreen its wierd.

Something IDK what is changing my resolution around and i cant figure out wtf it is.
Score
0
Related resources
December 10, 2010 9:03:28 PM

so Reinstalled some games that had the issue issue is still there.

Removed drivers reinstalled drivers

still there
Score
0
December 11, 2010 10:29:33 AM

Do you have v sync enabled ?
Score
0
December 11, 2010 12:14:13 PM

Might be stupied comment but...have you tryed the Auto Adjustment feature.Don't know if all TV's do but it should be their somewhere if it is an HD TV.
Score
0
December 14, 2010 8:31:37 PM

MWHWHA it wasnt the TV i just fixed that issue and i rollbacked my drivers....the roll back worked but then Civ5 was laggy as bawls so i downloaded new drivers and LAWL problem persists ONLY in fullscreen games.

So i removed the drivers installed again through win 7 driver auto updates, problem still persists...tried official drivers..problem still persists..i think its a bad nvidia driver. Because when i play in windowed mode the game run perfectly fine.
Score
0
December 14, 2010 8:56:08 PM

Just play it in windowed mode and stretch it to fit fullscreen...
Score
0
December 16, 2010 5:38:59 PM

will playing it in windowed mode require more processing power?..

Kinda doesnt matter as i just ordered a asus super comp mobo and a 5970...just needz some ramz, psu, cpu, after market liquid bloc fro the 5970....

But that wont be built for awhile. :( 

i honestly think my 9800 is either dieing or for some reason the latest drivers from nvidia suck.
Score
0
December 17, 2010 8:02:33 PM

But heres the stupid thing, it plays in 1920 x 1080 while windows but not in fullscreen WHY its the same resolution it has to be some stupid setting; either windows 7 is causing the issue, the 9800 gt is causing the issue, the 9800 gt drivers, or the sony bravia TV, but this whole occurrence is new. :pfff: 
Score
0
December 18, 2010 3:22:32 AM

the tv or the driver-
;) 
Score
0
April 28, 2011 5:44:02 PM

enossir said:
But heres the stupid thing, it plays in 1920 x 1080 while windows but not in fullscreen WHY its the same resolution it has to be some stupid setting; either windows 7 is causing the issue, the 9800 gt is causing the issue, the 9800 gt drivers, or the sony bravia TV, but this whole occurrence is new. :pfff: 


I had the same problem. Fixed it. In the nVidia control panel, go to "adjust desktop color settings" scroll down, beneath "digital vibrance and hue", you will see a setting that says, "content type reported to display" change it from "auto-select" to "desktop programs." Apply.

It seems to be an issue with the TV choosing the correct refresh rate for PC content. It seems to choose Windows content correctly but chooses poorly when any other program is running the display. This is why games work fine windowed but poorly full screen even at the same resolution and why sometimes vsync and alt+tabbing would fix it.

Sources: http://www.tomshardware.com/forum/111168-13-htpc-graphi...
http://forums.guru3d.com/showthread.php?p=3905754
Score
0
May 2, 2011 3:16:18 AM

Try going to Nvidia control panel and changing the AntiAliasing settings for that particular game.

For Mass Effect I had your exact issue using same Resolution.
I changed the settings for..

gamma correction - ON
Anti Aliasing Mode - Override any application settings
Anti Aliasing Setting - 16x (could have went higher but not necessary for my game)
Anti Aliasing Transparency - 8x (supersample) * for some games using multi works for some but i'm sure supersample is fine

I then clicked Apply and my game works flawlessly now.

Nvidia > Manage 3d settings > Program settings > select game or browse for it (if you have to browse for it, find the game and click add) > Change settings > Apply > reopen game

Edit: Didn't see you were using a TV.. what a user said above might better apply for you. I use a 22" Asus LED.
Score
0
October 4, 2011 7:38:37 PM

eightdrunkengods said:
I had the same problem. Fixed it. In the nVidia control panel, go to "adjust desktop color settings" scroll down, beneath "digital vibrance and hue", you will see a setting that says, "content type reported to display" change it from "auto-select" to "desktop programs." Apply.

It seems to be an issue with the TV choosing the correct refresh rate for PC content. It seems to choose Windows content correctly but chooses poorly when any other program is running the display. This is why games work fine windowed but poorly full screen even at the same resolution and why sometimes vsync and alt+tabbing would fix it.

Sources: http://www.tomshardware.com/forum/111168-13-htpc-graphi...
http://forums.guru3d.com/showthread.php?p=3905754



You know what friend??? If you can get me a picture of you, I'll light two candles and I'll put your picture between those... YOU FIXED MY PROBLEM!!! THANKS!!!!!!
Score
0
!