Sign in with
Sign up | Sign in
Your question

VirtualBox problem

Last response: in Business Computing
Share
February 20, 2013 10:54:15 PM

Hello everyone! This is my first post so forgive me if I sound incompetent.

I'm trying to run Ubuntu 12.10 64 bit on VirtualBox. The problem is that when I run, there's an error popping up saying that "vt-x features are either locked or unavailable under MSR".

Naturally I looked at my BIOS. I saw that there was no option to enable vt-x so I updated the BIOS. The new BIOS is supposed to have enabled the feature though there is still no option to enable/disable it.

I ran the virtual machine again and it still has the same problem. To go a bit further, I ran SecurAble and Intel Processor ID Utility. Both show a big "Yes" under vt-x.

SecurAble, however, additionally says the following:

This processor does offer advanced hardware support for virtualization. However, while running under a 64-bit version of Windows this program cannot execute its 32-bit kernel code to determine whether Intel's VMX virtual machine extensions are being locked on, locked off, or neither. Since there's a chance that your system's BIOS may be deliberately disabling support for hardware virtualization (some do) you should re-run this program, if possible, with administrative privileges under a 32-bit version of NT, XP, or Vista. That will allow SecurAble to run a bit of kernel-mode code in order to determine exactly what's going on. (Note that you can also poke around in your system's BIOS to see whether you're able to find any references to "hardware virtualization" or "VMX", etc.


So I think the problem lies there but I'm not sure how to solve it, since there is no option on the BIOS for vt-x. Since I don't have a 32-bit version of Windows lying around, I've no clue what to do next.

My system is the following:

MSI GT70 0NC, BIOS E1762IMS.10R
i7 3610QM
Windows 7 64-bit
12 GB RAM
NVidia GeForce GTX 670M


I already looked on the MSI forums and they say that virtualization should already be enabled, which is why I'm asking here, since it may have something to do with virtualbox or Windows 7. I've no clue what else to do. Please help! :cry: 

Also thank you, in advance, for taking the time to help me! :hello: 

More about : virtualbox problem

February 25, 2013 1:09:48 AM

Hmm, that's weird. It sort of sounds like a BIOS issue to me. That's odd there is no setting in BIOS for turnting VT-x on or off. Your processor definitely supports VT-x. Most BIOSs should give you a setting to enable it or disable it. It seems like it is on because your SecurAble says so. If it was disabled, I'd think the utility would say it wasn't on. I would ask them again, or ask on the virtualbox forums.

That said, I too run Ubuntu in VBox, but have had a lot of trouble with 12.10 x64. I went back to 12.04 and it runs A LOT smoother. As far as I understand, 12.10 has more 'fluff' added to it to make it more user friendly for newcomers to Linux. You probably don't need all that stuff. Try using 12.04 to see if that works better. I'm curious to see what you find.
!