64bit NIC Drivers?

I just got the Asus A8N-SLI Deluxe and the 2 NICs apparently dont support the Beta Win x64 OS.
Does anyone have 64bit drivers for these nForce4 built-in Gbit MAC w/ external Marvell PHY or Marvell PCI Gbit LAN controller?
or does anyone know of any NICs that support 64bit OS?
...or does anyone know if im just doing something wrong? :p
OS says drivers dont have support, the status shows connected @ 400Mbps wheather its pluged in or not, and ASUS support says the drivers arnt supported yet.
Thanks in advance!
7 answers Last reply
More about 64bit drivers
  1. Sure enough, you did not think about visiting nvidia web site, as they make the chipset for your board and check there for 64bits drivers ...

    And for Marvell, have you been at their website?

    I had network working with the 64 bits drivers from nvidia on my nforce3 board with win64

    -Always put the blame on you first, then on the hardware !!!
  2. thx man! ya i figured it was probably me :p
  3. I once installed xp64 on my machine, but I didnt find drivers for my scanner, printer and some other thing. It's been a while and did not look back for drivers for my stuff at manuf web site since yesterday for my sound card and no drivers yet.. So I'll wait a bit longer to reinstall it.

    -Always put the blame on you first, then on the hardware !!!
  4. ok tried both but still same.
    status shows connected even when its not pluged in but not working.
    there are 2 onboard NICs but only shows one connection and i cant even tell which one its refering to :p
    considering just buying he 32 bit xp pro for now cause all i got is 98se. :(
  5. <A HREF="http://www.nvidia.com/object/nforce_udp_winxp64_6.25" target="_new"> nvidia 64 bits drivers</A>

    You got your drivers from there? This is where I got mine and lan was working well.

    -Always put the blame on you first, then on the hardware !!!
  6. well, just thinking, better get win xp for now, as there is not that many drivers for printers and others stuff, so you'll end up like me, a computer that is just running..no printing, no scanning, no sound, no multimedia( capture, tv,..), ...

    -Always put the blame on you first, then on the hardware !!!
  7. sweet i got it man
    just found the NICs on from control panel/add HW
    and installed teh drivers from there
    guess i was trying to install them on some 1394 connection that was the only one showing up :p
    sry to bother u im an XP noob lol thx though
Ask a new question

Read More

Drivers Support Windows XP