WoW closes upon entering password

I just built a new computer:

Phenom 2 x4 965
Asus Crosshair IV Formula
2x2gb G.Skill
Still running my 9800GT until I decide on which newer card to get (too many choices)

I have not played WoW in months but I figured I would check out Cata (probably a bad productivity choice). I copied my WoW folder from my portable HDD and updated it to Cata (including 4.01 patch = 10gig update, ouch) and now when I try to log in, the game simply closes. It will hang for just a moment and then closes to desktop.

I run Comodo Internet Security anti-virus, and WoW.exe is run as an administrator and is on the trusted files list.

Anyone have an ideas?
5 answers Last reply
More about closes entering password
  1. Try WoW repair and if that doesnt work try reinstalling (Pain in the ass if you dont have the actual Cata DVD)
  2. Yeah.. No cata disk.. Ill try to repair. If that does not work I will simply copy a friends WoW folder onto my portable. Thanks.
  3. If the repair doesn't work then I'd forgo the attempt at copying the files & just do a complete reinstall. I've never heard of anyone "copying" the WoW folder instead of installing it & have a strong feeling that this may be corrupting the file in some way. As stated by Mokomaki, it will be a pain without the games disks, but would be worthwhile.
  4. Never had to do the repair. I was just about to do the repair and decided to try to log in one more time and it magically worked. I don't understand it, but all I know is it worked.

    Oh and my friends and I have all been copying our game folders for WoW, EQ, Crysis, and several other games this way for years.
  5. Well I guess you learn something new everyday. It would never have occured to my to copy the game files instead of installing them. Glad it worked out for you.
Ask a new question

Read More

PC gaming World Of Warcraft Video Games