Sign in with
Sign up | Sign in
Your question

Unusal issue with Steam Demo's

Last response: in Video Games
Share
December 20, 2010 1:23:06 AM

Hey everyone,

I'm writing on behalf of a friend - their issue with 'Steam'.

They are running Windows 7 64bit Ultimate edition 4GB Ram, Nvidia GeForce GTX 250, i5 CPU, Steam installed.

Steam runs perfectly except, when they try to download a DEMO the BLUE SCREEN of DEATH comes up.

They said they can download and run demos individually, but for some reason more than one at a time and the Blue Screen comes up. Never had any trouble with Windows 7 before. Not a big problem as the OS runs well, just curious as to why this would be happening.

Bit unusaul ay? lol

Oh well, what does everyone think? Is is just a random case, Windows 7, or Steam that's the problem?
December 20, 2010 10:18:09 AM

im not sure what has caused that problem,but to be honest i have had problems with steam also,last week i uninstalled my steam and some games(MW2..black ops)after reinstalling steam i found i could not sign into my steam account,this meant i also could not install my games..after alot of attemps.i decided to reload my operating system(i was very cranky with steam)this fixed the problem but takes alot of time to reload software and games..your freind can also contact steam support,hope they can help with the problem..
m
0
l
December 23, 2010 12:00:17 AM

mrclownface said:
im not sure what has caused that problem,but to be honest i have had problems with steam also,last week i uninstalled my steam and some games(MW2..black ops)after reinstalling steam i found i could not sign into my steam account,this meant i also could not install my games..after alot of attemps.i decided to reload my operating system(i was very cranky with steam)this fixed the problem but takes alot of time to reload software and games..your freind can also contact steam support,hope they can help with the problem..



Yeah that could be the issue. I'll tell her to give it a try - sucks about you having to re-install Windows dude!

Thanks for the reply.
m
0
l
!