Sign in with
Sign up | Sign in
Your question
Closed

Can't play Battlefield Bad Company 2 online AT ALL!

Last response: in Video Games
Share
December 27, 2010 12:52:03 AM

I've had the game since February, I'm like lvl 35 and everything. About a month ago I had a new ISP come in, I went from 768k DSL to a 12Mb ATT U-verse line and its freaking amazing. But I have not been able to play Bad Company 2 since the day I switched. I'm just know getting pissed becuase I only have like 2 online games cause I'm only 16 and this one dosent even work. It is not my Norton 2010 because I played fine months ago with it. I set my router to DMZplus mode for my computer which is not supposed to block traffic of any kind. And Ive reinstalled the game twice. The updater dosent do ANYTHING, about 30 seconds after I click "BFBC2 Updater" it just launches the game. Then I click login and after a few seconds it says "Cant Connect to EA Online".

I tried to get help on EA forums but it says page unavailable and crap so I need some help and this site is legitimate.

REALLY NEED SOME HELP! Thanks

Best solution

December 27, 2010 4:05:51 AM

Bump.

Sorry but I can't help. I read the post because I recently had a problem playing online, but that was due to punkbuster. I'm a complete noob when it comes to networking. Anybody have some advice for this dude?
Share
December 27, 2010 5:55:35 PM

Wow Ive searched all over and at EA forums I dont even have any help
Score
0
Related resources
December 27, 2010 7:24:35 PM

EDIT: The EA servers are back up and I have a solution. It involves ECN.

Read this (From EA forums)

Quote:
I fixed this problem by turning off ECN (explicit congestion notification) It's only in Vista and Windows 7, and it defaults to off, so if you haven't turned it on then it's not your problem. To turn it off type cmd in the search bar, right click it and run as administrator then type "netsh interface tcp set global ecncapability=disabled" (without quotes) and hit enter. It should say "Ok." Then you can exit the command line and the game should work fine. If you haven't turned ECN on then I've also heard of people getting this problem from programs like peerguardian blocking ports.



netsh interface tcp set global ecncapability=disabled

Copy this ^

Open Start Menu, Search "CMD", run it as administrator and paste this, then press enter. It should say "Ok."


That solved it for me, it was never off in the first place so it definitely has something to do with my new router/gateway.
Score
0
December 27, 2010 7:24:45 PM

Best answer selected by solidsteel.
Score
0
December 27, 2010 10:39:19 PM

This topic has been closed by Mousemonkey
Score
0
!