Sign in with
Sign up | Sign in
Your question

WoW FPS Issues after Win 7 Install

Last response: in Video Games
Share
January 3, 2011 1:58:06 PM

I recently built a new PC:

HIS H545H1G Radeon HD 5450 (Cedar) 1GB 64-bit DDR3 PCI Express 2.1 x16 HDCP Video Card
OCZ Reaper HPC Edition 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Memory Model
Intel Core i3-550 Clarkdale 3.2GHz 4MB L3 Cache LGA 1156 73W Dual-Core Processor
ASRock H55M/USB3 R2.0 LGA 1156 Intel H55 HDMI USB 3.0 Micro ATX Intel Motherboard

I initially had Ubuntu 11 64bit installed and was running WoW via Wine. I never noticed a fps issue, I was constantly over 30 (not great but playable). I decided I wanted Windows 7 to get a couple peripherals working and did a clean install. Everything is working great, but I'm constantly running between 13 - 25 fps with my graphics set LOWER than what I had running on Ubuntu.

I did some research and most people suggested making sure my video drivers were the most current. Windows installed the drivers automatically and then I updated them to the latest ATI drivers from their site. That had no impact. I did some more research and increased the TCP packet size to see if that would help. It cut my latency by 1/3rd but didn't touch my fps.

My wife is using the same video card on an older dell machine with higher graphics hitting 30 - 45 fps so I know the card is capable. I'm just not sure what I could be missing.

Thanks,
Adam

January 3, 2011 6:02:17 PM

What power supply unit are you using? Anti-Aliasing set to x0 from graphic card options and in game?
m
0
l
January 3, 2011 6:28:00 PM

My PSU: OCZ ModXStream Pro OCZ700MXSP 700W ATX12V V2.2 / EPS12V

I'll double check again tonight, but I'm pretty sure AA is off on both. I do have to double check shadows, I just read that people had issues with shadows in WoW.
m
0
l
Related resources
January 3, 2011 8:01:01 PM

Shadows are the biggest performance issue with WoW. You should check your graphics settings and make them identical to your wife's settings. You already increased your TCP packet size and with it your latency (my initial thought when I read the post). You are also sure that the card is up to snuff from experience with it, as is the rest of your system (I was leary about the 64 bit memory bus with that video card). I would guess that you're on the right track with checking the graphics settings. I can't think of anything else that you may have missed.
m
0
l
January 3, 2011 8:55:15 PM

After re-reading your initial post and system specs I've noticed something odd. The performance that you are seeing is more consistant with what you would see from the Intel H55 graphics, not your video card. I know this is a long shot, but any chance that you're running in some sort of "hybrid" or "power saver" mode, utilizing the H55 graphics instead of the video card? I'm not too familiar with the H55 graphics or these "hybrid" modes, but I'm curious as to whether or not this may be the issue.
m
0
l
January 4, 2011 12:28:33 AM

I rechecked my settings and set them the same as my wife and even lower and I still can't break the 20ish range...seems like I could hit 30fps, but never stay there. While playing tonight I saw 13 - 31 averaging in the low 20's.

I checked the bios to see if there was anything about which video card it might be using but it was already set correctly.

I double checked all display settings and I can't see anything that would indicate a mixed mode, but I'm not 100% if I am missing something. I did run it through the "Windows Performance Check" and it got a 5.0 in graphics. It shows that it's got the correct video card selected.

As for the ATI Catalyst control panel, everything is set to "Use Application Settings". WoW is configured with their recommended settings (minus fog at a resolution of 1920x1080. These are all consistent with my Ubuntu config.

Any other utilities or something that I should run? Could it be a directx 10 issue?
m
0
l
January 4, 2011 12:49:26 AM

You could try using your card in your wife's computer. Just could be a bad GPU...

**Edit: Or, try using another game. Gauge the FPS in there and see what you get.
m
0
l
January 4, 2011 6:22:45 PM

This is a long shot too, but since you didn't list your monitor, I have to ask... What is the native resolution of your monitor? Your in-game settings are identical to your wife's, but the screen resolution may be to high for your monitor.
m
0
l
January 4, 2011 7:07:55 PM

I'm running at the native resolution (1920X1080).
m
0
l
January 4, 2011 9:11:28 PM

Is your i3 running at the proper speed (3.2GHZ)? I would think that you should be seeing improved performance with Windows as opposed to running on Ubuntu through Wine. A defective GPU would make sense, but you ran on Ubuntu ok.
m
0
l
January 4, 2011 9:42:10 PM

I have one more thought. Check Task Manager and see what other programs are running (mainly while running WoW). See if there is a program that is using a large amount of system resources. Antivirus programs sometimes can cause FPS issues while playing WoW. Just a thought. On another note, the Radeon 5450 isn't going to run WoW on anything higher than low-med settings with shadows turned off (especially at that resolution).
m
0
l
January 5, 2011 2:36:53 PM

This could be because of a few things, first are you runing with Vsyic on? if so are you also running in windowed mode? this could give you a cap of 30fps.
I have also seen i5/i7 CPUs not come out of idle state and stay @1.7ghz in WOW, same thing with the GPU it could be staying in 2d clocks.
Check that and see if you notice any of them.
m
0
l
January 8, 2011 3:00:10 AM

Did you set the correct cpu affinity in your config file?
By default it comes with cpu affinity set for 2 cores.(or at least this was the case in the past)
If you did not:
go open your WOW installation folder,and there open the WTF folder where you have the file config.wtf .
Open the file config.wtf
See there how "Set ProcessAffinityMask=" is set.
If you want that WOW will use all 4 cores put Set ProcessAffinityMask=15
http://www.wowwiki.com/CVar_processAffinityMask
(your processor is seen like a quad core,so you need to put 15 there).

After you check this,open a Taks manager,and open there "performance" to see how your cpu cores are used.
(You can do this by puting WOW runing in a window but put it full screen;you should see there high utilization on all cpu cores,just check this,to be sure).

If you still have low fps after that:

Go here:
http://event.msi.com/vga/afterburner/download.htm
And get MSI afterburner.
After install it start it go to options and enable monitoring to some log file.
(see how you configure the size of the log file,so you will not get it stoped on 10 mb which is default,if you want to run the test for a longer period).
Let it started and start WOW and do something that will take your frame rate low.
After go and open the file (with wordpad or something like that) and look at GPU usage history.
Normally it should reach 100%.
If it is at 100% than you need to lower your graphic settings to get more frame rate.
If it is at max 50% 60% is something about CPU /or something else like that.
If it is about cpu you should go in BIOS and disable sppedstep,Enhance Halt State,Intel C-STATE.
(those are in bios - advanced/cpu configuration)
If you have those enabled and you disable them and it works fine after is good.
If not look at this also:
In case you have activated thermal throtling (which you should have,cause this prevents cpu from burning) maybe your cpu gets too hot and this will reduce cpu frequency (I doubt that your cpu gets too hot ,is 32nm,but check this also).
You can monitor your maximum cpu temeprature with coretemp .
Here you can find coretemp:
http://www.alcpu.com/CoreTemp/
m
0
l
January 9, 2011 10:43:30 PM

So, did you figure the problem out yet? Wondering where the issue was? Any updates?
m
0
l
!