Sign in with
Sign up | Sign in
Your question

Starcraft 2 even on low

Last response: in Video Games
Share
January 15, 2011 6:05:30 PM

I have a AMD Athlon II X4 620 Processor and a GTS 250 with 4G of ram And can play on ultra in single but when playing on Lan or online even on low i have major lag when Scrolling over a big army or city

where as my roommates comp next to mine does not lag once and his comp has a Intel core 2 quad q66oo with 3G of ram and a Ati radeon HD 2400 pro

More about : starcraft low

January 16, 2011 4:19:45 AM

Online - might be due to internet connection.. If your mate has same connection which i suppose he does, an upgrade to your specs might be needed.
m
0
l
January 16, 2011 5:50:25 PM

I have a feeling that there is an issue with something else, just for the sake of troubleshooting please set your StarCraft 2 to play in Windowed Mode, while it's in Windowed Mode continue playing like normal. When you experience a drop attempt to Alt + Tab and then Alt + Tab back in.

This may sound odd but I have a feeling I know what the issue is. In addition make sure your ATI Drivers are updated from the drivers on the ATI website. If you used the drivers that came with your disk they are extremely out of date.

Current version is 10.12.
m
0
l
Related resources
January 26, 2011 2:35:57 PM

turn off limewire/utorrent/any other filesharing ;) 
m
0
l
January 26, 2011 2:36:19 PM

also try reinstalling mainboard drivers if it includes network driver. such as inf update intel
m
0
l
February 2, 2011 3:47:56 AM

i used to have a phenom 9500 with hd 4850 512 mb, i was getting around 30 to 40 frames and 10 to 15 frames when a lot of people is playing and battles... i read a lot on the forums and guides.. i bought a core i5 and paired with the same video card and BOOM 120 frames at starting the the game and 70 when the battle is heave, no lag, no nothing, great graphics dammm... the core i5 750 rocks!!!!!
m
0
l
!