Sign in with
Sign up | Sign in
Your question

Help!!! KT7 + MX300 = Big Problems

Last response: in Motherboards
Share
January 24, 2001 12:58:13 PM

I have been working on my system for 4 days now and I still don't have it right. I have tracked the problem down to the sound card. I have a DiamondMM MX300. At first I couldn't boot, it would freeze when the OS would load my sound card drivers(straight off the diamond cd). So then I could only boot in safe mode and removing the sound card fixes the problem. My modem does work so I get on the internet and start looking for a solution. I find that I am definitely not the only one with this problem. I found on a forum off VIA's website that MANY ppl have the same problem w/ their KT133/KX133 + MX300 combo. The problem lies in the sound cards "sound blaster pro emulation" which is one of the several devices listed under sound controllers in the Device Manager. Apparently this operates to supposedly run old 16-bit DOS sound applications and works as a legacy device, so it cannot share it's resources. It needs one IRQ and a DMA channel. So in the KT7 faq it says there is a workaround. It says I need to go into bios and manually reserve IRQ #5 for legacy cards, enable it to reset configuration and it should work. Wrong! I did this and I also tried it w/ reserving the DMA channel it wanted to use. I looked up the IRQ assignments for the PCI cards and tried the ones I figured to work best, heck I tried them all. The only other cards I have in the system are an ISA 56k modem and an AGP Geforce DDR. So all PCI's are available(except #6 shared w/ ISA). Ok so when I do all this it will load up the driver and not crash immediately on start-up but it still crashes when playing most any sound besides the windows startup sound (which btw is where it crashed alot before). So this so called work around brought my system from being 0% stable up to 2% stable. What a great deal huh.
Ok so disabling the "Sound Blaster Pro Emulation" in Device Manager let's me run my system normally except one big problem, I don't have any sound! From the posts I read I must have seen at least 100 ppl on that forum alone that have been begging VIA for help since the days of the KX133. Same thing with DiamondMM. A few ppl said that Diamond told them there was an updated sound card driver for them that would fix it but nobody can seem to find it anywhere.
I am so angry. This industry seems to have almost zero customer support. No offense but it's kinda sad that the best customer support I can get is to post in a forum and ask for help from you guys. When I call Abit I get a machine that says voice box is full and hangs up on me. When I email them I get an automated response that says we get too many emails too help you the individual, hell they probably didn't even read it. And VIA just needs to take a look at their message boards to realize that 99% of the ppl with Vortex2 based cards cannot use their KT133/KX133 chipset MB's. I mean do they test these things for compatability before they start shipping? Vortex2 is a popular chipset, it's not like I have a sound card that is 5 years old and made by a co. that has gone out of business. Well enough ranting for now. I'm sure you all know this already and I'm not giving you any new information about the poor status of customer support in the PC industry.
So to wrap this up I must ask, Has anyone had the same problem and found a fix for it? Is there a fix or workaround besides disabling practically all the sound on my comp? I'm a gamer so I must have sound. I have a cheapo ISA sound card that I haven't tried yet because I will also have to use a 56k modem that for some reason doesn't perform as well as my ISA modem. I suppose that's one thing I can try. But I really don't want my nice MX300 sound card to sit on the shelf and collect dust if there is some way that I can make it work.
Please only post replies if you want to help. I don't particularly want to hear "the MX300 sux get a SBlive". I suppose I will be getting a SBlive eventually if I don't find a solution for this problem but I would really like to keep my MX300. I appolagize for the length of the post and going off on a ranting tangent for a while there.

Thanks to all who take the time to help me with my problem, it is much appreciated.

sodium.

Parachute for sale:
Only used once, never opened... small stain.

More about : kt7 mx300 big problems

Anonymous
a b V Motherboard
January 24, 2001 1:28:25 PM

And your sound card is in a slot that does not conflict with the Promise IDE controller or the AGP slot?

And you're not sharing any irq's with the modem?

Try disabling all unused peripherals i.e. com1, com2, lpt1, etc.

Also, you got the right drivers - Windows Me, Windows 98 ...

If you've done all that, then it's possible that you may have some bad drivers for your card. I don't think Diamond is all that great with drivers.

There is a new bios out for the kt7 - kt7_ww. I'm not sure that will help you though ...
January 24, 2001 1:43:19 PM

Hmmm, let's see. As far as the Sound Blaster Pro Emulation goes I did check. And after reserving the IRQ and DMA recources for Legacy in the Bios and enabling the reconigure option then the soundcard drivers load up without the exclamation point symbol. I checked every single item on the Device Manager and the Emulation has its own IRQ and DMA channel that nothing else uses. And Yes I even disabled the LPT1 port. Although when I do this it does not lock up immediately if I were to load a game up it will crash. In a game it will play the sound through the AVI movies at start but once it gets past those and into the game it crashes then. Also it plays browser clicks while surfing the web for a while but then at random when I click the back button (for instance) it locks up solid. I have used the original drivers off the cd and the latest ones from diamond. BTW my OS is window98(not SE) and I have d/l-ed all critical updates.
One thing I just read was that a couple ppl had success using the aureal vortex2 reference drivers 2048. So I guess that's next on my to-do list. I'll give that a try. But after all I've been thru the last 3 days, I'm not going to get my hopes up.

Parachute for sale:
Only used once, never opened... small stain.
Related resources
Anonymous
a b V Motherboard
January 24, 2001 3:13:10 PM

I'm not sure what else you can try. I run 98se and Me. You may wish to try that. Make sure you are running latest m/b bios and HighPoint drivers.

If you could try this on another board, it would be good.

Other than that, return the sound card and see if the techs where u bought it have the same problem with a kt7.

I just saw the following post from "Cannex" on the sound forum:

Problem solved. Follow the instructions here:
http://forumz.tomshardware.com/hardware/modules.php?nam...

<P ID="edit"><FONT SIZE=-1><EM>Edited by gorenc on 01/24/01 12:22 PM.</EM></FONT></P>
January 24, 2001 4:43:39 PM

About the bios... For some reason I can't get any of the bios updates downloaded from their site. I guess I'll have to try somewhere else.
And about the sound card, it is not a new soundcard it is an OEM part that I ordered over a year ago so the sending back thing isn't an option.
But hey. Guess what?!? I got it working :)  kind of anyway. I installed the latest Vortex2 reference drivers. Version 2048. This pretty much fixed the problem(I think, knock on wood). I hope it's fixed anyway. Since my last post I uninstalled the diamond drivers and installed the 2048 ref. drivers and now it doesn't crash on boot-up, I don't have to disable anything and at least one game runs :)  I've only tried one game so far and played several .wav files from the windows directory and that all worked. The game sound was chopped up a little for the first minute or so and then it was fine, and then after about 30-40 minutes the whole game got choppy. I closed the game out and everything seemed to be fine. Then I tried to log onto the internet and my connection dialed up and connected fine but then it would recieve no data. So I couldn't open up web pages run Instant messenger or anything. It was sending bytes out but not recieving any. Perhaps coiincidental but I'm thinking now my soundcard works but it has somehow screwed up my modem!?! Well I tried disabling the sound card and same thing. So to make a long story short I tried to Reboot to see if things would cclear up. So when i tried that i got a blue screen of death. I shut down the computer and cranked it up again. Re-enabled the sound-card and rebooted again, just to be safe. Well I ran the game I was playing (Still got a little choppiness in the sound at the beginning but it smoothed out). I ran that for 5 or 10 minutes and shut it down. Connected to my ISP again and now everything there works fine. Maybe my ISP was just screwed up for a little while. That's what I'm hoping anyway.
So for right now things are working (And I have my fingers crossed in a big way). I hope and pray everything keeps working. The choppy sound is annoying but I can deal with that for a while. With all I've been thru with this the last few days I feel I should take what I can get.

So for all those who might be experiencing the same problem my reccomendation is... Use Bios to manually reserve IRQ 5 for legacy and possibly also reserve a DMA channel then install the Aureal Vortex2 chipset reference drivers v. 2048. And hey you should probably use those drivers anyway, they have support for EAX.
Thanks for your help gorenc, I'll post here again if things take a turn for the worse.

Parachute for sale:
Only used once, never opened... small stain.
January 24, 2001 5:38:05 PM

I had sound card problems (and resource conflicts) on my KT7 when I first installed it. My sound card is real legacy Turtle Beach TBS-2000, 16-bit (old!). Nothing I could do would make it work. I tried reserving legacy IRQs in the BIOS but the card was assigned different IRQs than the ones I reserved and still didn't work. I was forced to disable it in Device Manager.

I was about ready to just go out and replace the sound card with a PCI card when I stumbled on the following BIOS setting.

PnP/PCI Configurations

- Reset Configuration Data

Right after I enabled this Windows 98SE detected my sound card and everything was fine. Computer has been stable ever since (about 3 months).
Anonymous
a b V Motherboard
January 24, 2001 7:50:39 PM

Resetting the configuration data is a good idea. I've used that in the past and I use it frequently now.

Sodium, also try the link:

http://forumz.tomshardware.com/hardware/modules.php?nam...

Looks like others have had the same problem.
!