Sign in with
Sign up | Sign in
Your question

BFBC2 slowdowns during explosions & smoke

Last response: in Video Games
Share
January 19, 2011 9:00:45 AM

I have a problem with BFBC2. I set it up to high settings and the game goes up to 40-50 FPS, (1280x1024) BUT when an explosion occurs the FPS goes down dramatically to 'bout 10-15 FPS. I have an HD 4850 and i've tried the app. profiles for BFBC2 but no change. Any solution?
January 19, 2011 9:59:20 AM

I have a 4850 and see the same too. It's not really man enough for the high settings I think. Low and medium settings are better with shadows on low. I play at 1920x1080. Also I think the game is quite CPU heavy so you may be maxxing out the CPU during the explosions and smoke as I think the particle effects eat up the clock cycles.
January 19, 2011 10:43:36 AM

Lower the shadow level and then check
Related resources
January 19, 2011 11:13:59 AM

If you had a card with enough vram, a processor with enough L2 and L3 cache on it and enough system memory you might not have these problems. You can try enabling more virtual ram but it's not going to do you any good because it still takes time to off load the HD when it's needed. .......... slow downs/stuttering. BBC2 also likes multi core processors.
January 19, 2011 11:35:36 AM

swifty_morgan said:
If you had a card with enough vram, a processor with enough L2 and L3 cache on it and enough system memory you might not have these problems. You can try enabling more virtual ram but it's not going to do you any good because it still takes time to off load the HD when it's needed. .......... slow downs/stuttering. BBC2 also likes multi core processors.


My HD 4850 is a 1GB VRAM model, and i have a Q8200 which while playing BFBC2 never goes up more than 60-70%, and i have 4GB RAM.

I turned down AA to 1x, everything else on high, 4xAF and the game is silky smooth even when explosions occur. It looks like AA causes the problem?

Would an CPU OC do the job? (I run the Q8200 @ stock freq., 2.33GHz)
January 19, 2011 11:39:29 AM

unknown_13 said:
My HD 4850 is a 1GB VRAM model, and i have a Q8200 which while playing BFBC2 never goes up more than 60-70%, and i have 4GB RAM.

I turned down AA to 1x, everything else on high, 4xAF and the game is silky smooth even when explosions occur. It looks like AA causes the problem?

Would an CPU OC do the job? (I run the Q8200 @ stock freq., 2.33GHz)

If it's silky smooth I don't see the reason why you need to overclock. You could start the overclock at 2.6GHz and see if the problem stops.
January 19, 2011 11:41:30 AM

dalta centauri said:
If it's silky smooth I don't see the reason why you need to overclock. You could start the overclock at 2.6GHz and see if the problem stops.


It is smooth BUT with no AA on. :D 
And the difference in BFBC2 with AA on and off is night and day.

And i've seen guys on youtube with the same card and similar CPU running the game with AA on and it doesn't slowdown during explosions.
January 19, 2011 1:36:27 PM

It mainly will slow down to such a rate because there will be a lot of particles to be formed and thus it will result in a large amount of FPS. You can try and reduce the other options in the game like the Shadows as an example. I really think that the shadows are a bit too bad . Really, they look like a bunch of perfect ovals and circles at high. Put it in medium , maybe that will increase FPS
January 19, 2011 1:49:19 PM

Gman450 said:
It mainly will slow down to such a rate because there will be a lot of particles to be formed and thus it will result in a large amount of FPS. You can try and reduce the other options in the game like the Shadows as an example. I really think that the shadows are a bit too bad . Really, they look like a bunch of perfect ovals and circles at high. Put it in medium , maybe that will increase FPS


Yeah well i've tried shadows on medium, it was a bit faster but it was still running very bad during explosions. Should i try to rollback to 10.4 drivers?
January 19, 2011 4:40:04 PM

I have cards with 1gig vram and sometimes that isn't enough. However, your card doesn't have the speed or architecture to run the game properly. Your processor is also slow. Unless you make up your mind to reduce settings and over clock you're going to have to suffer. Run it in Dx9 mode. This will help somewhat. And yes, AA will hurt systems to one extent or another.
January 19, 2011 7:12:10 PM

swifty_morgan said:
I have cards with 1gig vram and sometimes that isn't enough. However, your card doesn't have the speed or architecture to run the game properly. Your processor is also slow. Unless you make up your mind to reduce settings and over clock you're going to have to suffer. Run it in Dx9 mode. This will help somewhat. And yes, AA will hurt systems to one extent or another.


Stupid Question: How to do that? :D 
January 19, 2011 9:15:01 PM

I don't have the game on this computer. But try going to the games folder... start/games......... right click on games icon and see if it gives you options... ???
January 20, 2011 7:38:33 AM

Thanks. I know 'bout the .ini files, i opened them previosly but there wasn't any dxverson line. That's why i asked. I'll try again later.
January 24, 2011 9:25:26 AM

There was a configuration tool ?liseda? I think. A GUI for setting your ini files, Google is probably your friend here. Allowed you to tweak a lot more than you could in game. Haven't played for a few months so don't know if it is still current
January 28, 2011 7:37:00 AM

I'll try to OC my CPU in the next few days, hopefully it'll make a difference. Thanks for all the suggestions and hints.
January 31, 2011 10:55:27 AM

unknown_13 said:
I'll try to OC my CPU in the next few days, hopefully it'll make a difference. Thanks for all the suggestions and hints.



Just go into the .ini file and after "effects" replace high with either medium or low, your graphics will look the same but when explosions happen your FPS won't dip as much. Also, try only turning AA up a little bit. Contrary to what you say, after AA is turned about halfway up, the difference is less and less, and will stress the GPU more and more.

Trust me, the game will still look pretty. Hell, the game even looks great on all medium settings. Don't let the notion of "max settings" keep you from turning a few settings down, because in the end, a consistent playable framerate is more important than visuals.
February 6, 2011 8:46:19 AM

OK i've tried the .ini file, it didn't make much difference, so i guess i'll be playing the game w/o AA. But hey, i have everything on high and 16xAF, so i probalby won't miss the AA much because BFBC2 has a lot of action and you don't notice the lack of AA when you're in a fight.

Thanks for the help.
!