Sign in with
Sign up | Sign in
Your question

Keyboard problem

Last response: in Video Games
February 3, 2011 1:42:41 PM

Hey guys,

I changed recently my pc for a window 7. I used to play Call of duty, WOW on my old xp and the same keyboard all was working perfectly! I've a french keyboard but i put it FR (Keyboard , languages) And my window 7 is english. My problem is when i play call of duty or wow i press forward "Z" and if i want press jump or crouch or whatever that's stop walking.. and that's really annoying coz actually i can't play. I tried different way in "Make the keyboard easier to use" Sticky key blablabla but nothing working.

Thx for help And sorry for my poor english. :hello: 

More about : keyboard problem

February 3, 2011 2:53:54 PM

Can you not just go into control panel/keyboard and set your k/b to French? I've never tried, but assume this is how it works....
February 3, 2011 3:06:47 PM

oldmangamer_73 :What's re-map the keys and how can i do that?

jay_l_a : i put already my keyboard in french all working well excepte when i playing games (Ex. i playing call of dutty i press the key forward "Z" i want to press sprint in the same time "SHIFT" and when the sprint is finnish i stop walking i need to press "Z" again and normaly i don't need to!

I dl a Upgrade for microsoft keyboard but that's didn't helped me. My keyboard is PS/2 But i bought an adaptor to USB should be working well
Related resources
Can't find your answer ? Ask !
February 3, 2011 3:23:54 PM

Yes i did that but i still get the problem and i've got this problem in all games.. when i press 2 keys that's stop the first key i pressed! if you know what i mean..
February 3, 2011 3:26:42 PM

Good question let me try!
February 3, 2011 3:36:32 PM

Yes i just Tried same problem :(  "i changed to eng and i re map the control on call of duty but i still stop forward when i jump or sprint or whatever"
February 3, 2011 4:33:21 PM

Can you rule out the keyboard as the culprit? Is there another keyboard in the house you can try?
Seems odd that you cannot press multiple keys at once, that doesn't sound like a regional setting.
February 3, 2011 4:35:26 PM

Hang on, is this a stickykeys problem? That can happen with some function keys (shift, alt, cttl etc).

Find stickykeys in control panel, and make sure it is OFF
February 3, 2011 5:04:56 PM

Nope the Stickykeys is off and it's not a Keyboard Wireless. it's "Microsoft Inernet Keyboard"!. Normaly this keyboard working well. I've just got my new pc Window 7 64-BIT and i've got this problem. But i used to play on my XP like 3 days ago all was fine. It's something wrong with my settings for my keyboard i'm sure but i tried all but i can't find it..

My mouse (Razer Diamondback) working good.
February 3, 2011 5:11:30 PM

Have you tried updating the drivers?
February 3, 2011 5:22:43 PM

Yes i did! i've got a new "key settings" Bank 1 (standard), Bank 2 (Gaming).. i tried all but that's not working :( . "IntelliType Pro 7.1" that's the name of the Upgrade on Microsoft website.