Sign in with
Sign up | Sign in
Your question
Closed

Shift Key Stuck!!

Last response: in Windows XP
Share
February 8, 2005 12:27:53 PM

My Window XP SP2 machine crashed night. When I rebooted it, I quickly discovered that Windows “thought” the shift key on the keyboard was being held down.

Typed letters were in caps and all the desktop and applications behaved as if one of the shift keys was being held down. Very weird.

Silly me, I tried a different keyboard. No change. Using NAV 2005, I scanned the machine for viruses and found nothing. I booted the machine and went into the BIOS and tried typing text and the shift state seemed correct (not all caps). Then, I booted the machine using a DOS diskette and discovered that everything seemed fine under DOS as well.

But, when I went back into Windows, everything was messed up again… Feels like some kind of virus or corruption but I have no idea how to fix it.

Any ideas?

More about : shift key stuck

February 8, 2005 12:53:22 PM

Its for handycapped people. Holding Shift for 8 seconds is a shortcut for turning it on.

In Control panel open up Accessiblity option and uncheck any in use, then click settings and uncheck the shortcuts.

Also you can turn if off by pressing two keys, might be both shitfs or ctrl right shift or some such.
April 19, 2010 12:32:48 AM

I have the same problem - the shift key seems being pressed down all the times. I went to Control Panel, Accessibility and unchecked all. However, the problem is still there.

More, I have tried - replaced with a new keyboard, did PC recovery, downloaded a newer version of BIOS, uninstalled keyboard drive, used an external keyboard... Couldn't get rid of the shift key problem.

Interesting thing is - this happened before and it went back okay itself several months later, and now the problem appears again a few months later.

Any other suggestions, please?

Thanks!!!
Related resources
April 19, 2010 12:55:59 AM

When all else fails, re-install the OS (PITA)
April 19, 2010 3:12:01 AM

heidi6 said:
I have the same problem - the shift key seems being pressed down all the times. I went to Control Panel, Accessibility and unchecked all. However, the problem is still there.

More, I have tried - replaced with a new keyboard, did PC recovery, downloaded a newer version of BIOS, uninstalled keyboard drive, used an external keyboard... Couldn't get rid of the shift key problem.

Interesting thing is - this happened before and it went back okay itself several months later, and now the problem appears again a few months later.

Any other suggestions, please?

Thanks!!!



Your Caps Lock key on the keyboard :)  isn't on is it?
April 19, 2010 3:13:50 AM

Norton 2005? It's outdated, full of bugs and a resource hog. If you want to test for malware, run MalwareBytes AntiMalware, and get back to me. DO NOT reinstall your OS, as that is a last resort, not a way to solve problems, like burning your house down to kill some ants.
April 19, 2010 3:17:23 AM

Hey Graywolf. I was getting worried, what with you not on the forum much lately... or is that a sign that I'm on here way too much! <grin>
April 19, 2010 3:18:28 AM

Been working at Windows Secrets too. And I actually worked every day this week, first time in many moons.
[:digitalprospecter:3]
August 13, 2011 2:27:31 AM

I AM HAVING A SIMILAR ISSUE HENCe ALL THE RANDOM CAPS AND THEN NO CAPS> I WENT TO THE CONTROL PANEL AND ACCESSIBILITY OPTIONS AND UNCHEcKED EVERYTHING< SO STICKY KEYS AND FILTER KEYS ARE NOT ON< NEITHER IS MY CAPS LOCK AND YES I AM SURE< BUT ITS SO ANNOYING ITS KEEPING ME FROM BEING ABLE TO USE MY SCROLL PAD SO MY MOUSE BASICALLY FREEZES AND THEN I HAVE TO HOLD DOWN ONE OF THE SHIFTS IN ORDER TO USE IT I DONT KNOW WHY> SOMETIMES IT IS ALSO ACTING LIKE CONTROL IS DOWN BUT IT "UNSTICKS" EVERY NOW AND THEN LIKE I CANT TYPE NUMBERS EITHER BUT SOMETIMES IF I HOLD DOWN A BUTTON IT WILL EVENTUALLY TYPE CORREcTLY> I HAVE TAKEN THE KEYS OFF TO SEE IF THEY ARE ACTUALLY STICKING AND IT DOESNT SEEM LIKE IT> PLEASEEEEEEEE HELP> AND ALL OF THE CHEVRONS ARE SUPPOSED TO BE PERIODS SOOO SORRY> I HAVE A DELL INSPIRON E_ONE_FIVE_ZERO_FIVE AND I HAVE WINDOWS XP
September 20, 2011 12:55:00 AM

This happened to me. This fixed it. Hope it works for you:
1. Start > All Programs > Accessories > Accessibility > On Screen Keyboard.
2. Point to a SHIFT key on screen and click it on and off.
3. Do the same with the other on screen SHIFT key.
4. Close the On Screen keyboard.
5. Hopefully, all is back to normal.
September 30, 2011 12:57:43 AM

biromike said:
This happened to me. This fixed it. Hope it works for you:
1. Start > All Programs > Accessories > Accessibility > On Screen Keyboard.
2. Point to a SHIFT key on screen and click it on and off.
3. Do the same with the other on screen SHIFT key.
4. Close the On Screen keyboard.
5. Hopefully, all is back to normal.



biromike you are amazing i don't know why in the hell that worked but it is soooo nice to have 1234567890 numbers and punctuation again!.....,,,,,,, love it. do you happen to know why it happened
Anonymous
August 16, 2012 9:08:43 PM

biromike said:
This happened to me. This fixed it. Hope it works for you:
1. Start > All Programs > Accessories > Accessibility > On Screen Keyboard.
2. Point to a SHIFT key on screen and click it on and off.
3. Do the same with the other on screen SHIFT key.
4. Close the On Screen keyboard.
5. Hopefully, all is back to normal.



thanks very much i tried ideas in other forums but your's is the only one to work. thanks very much.
January 10, 2013 1:48:24 AM

I had the same problem and nothing seemed to fix it... when I opened the on screen keyboard it showed both shift keys were pushed but i could not deselect them. Even after unplugging my keyboard they still stayed pushed on the on screen keyboard. THEN out of the corner of my eye, I spotted my old wireless keyboard under a pile of clothes. It still had batteries in it and was still liked to the computer. It's shift key was held down by the clothes. I'll bet very few people will have this same issue but just in case... I hope I saved someone some time. =)
March 23, 2013 6:49:14 AM

biromike said:
This happened to me. This fixed it. Hope it works for you:
1. Start > All Programs > Accessories > Accessibility > On Screen Keyboard.
2. Point to a SHIFT key on screen and click it on and off.
3. Do the same with the other on screen SHIFT key.
4. Close the On Screen keyboard.
5. Hopefully, all is back to normal.


March 23, 2013 6:50:32 AM

biromike said:
This happened to me. This fixed it. Hope it works for you:
1. Start > All Programs > Accessories > Accessibility > On Screen Keyboard.
2. Point to a SHIFT key on screen and click it on and off.
3. Do the same with the other on screen SHIFT key.
4. Close the On Screen keyboard.
5. Hopefully, all is back to normal.


March 23, 2013 6:53:07 AM

Thank you! dont know how u figured that out but glad you did.People with this problem should really see this
!