Sign in with
Sign up | Sign in
Your question

Strange Crysis problem

Last response: in Video Games
Share
March 2, 2011 1:34:19 PM

ever since I installed Crysis on my PC it has been running at close to unplayable speeds on Low. I can't understand this because Crysis warhead runs at 25-40 fps enthusiast 1050x1680 no AA. Even Sandbox 2 runs at Warhead speeds at very high. I really need help on this one thanks. Tell me if you need my specs.

More about : strange crysis problem

March 16, 2011 12:47:52 PM

EAH5850
OCZ 1333mhz platinum 4gb
Phenom II x6 1075T 3ghz
500gb WD Green HDD
DVD Drive
Gigabyte 870A UD3 Mobo
That's my specs. It did this even before when I had my Phenom 9550, 4gb DDR2 and crap mobo.
March 16, 2011 3:04:06 PM

What kind of power supply are you using?
Related resources
March 19, 2011 7:04:15 PM

650W High Power Plus ATX
March 19, 2011 8:15:52 PM

welcome to the club mate :/ ...thats just how crysis works hard to tell exactly but some computers just have that little extra. And some don't.

I also get bad fps at crysis with very high 1440x900 res and no AA.. 20-25 and 35-40 with warehead enthusiast 16 Q AA

:/ 
March 19, 2011 8:19:42 PM

Download Crysis 2 instead :D  there u should atleast get 50 + with your specs (y)

I get 40 + with:

AMD Quad core 640 3.0 Ghz

8 Gb Corsair DDR 3 1333 mhz

Geforce GTS 450 1 gb GDDR5 factory clocked :) 

Crysis 2 for the WiN ^^ :D 
March 20, 2011 6:56:25 PM

EA have been completely useless so no help from them, and this problem happened on a preivious copy wich I replaced with the current one. If I get that high fps with Cry 2
YEEEEESSSS, eat PC ass, console noobs!!!!!!
March 31, 2011 7:12:55 PM

please i need more responses
April 3, 2011 10:10:03 PM

Makes little sense. I would try reinstalling the game, defragging the hard drive, make sure the game is patched (I know it had a memory leak at one point).

Make sure your graphics card settings arent different for crysis and warhead. Make sure you don't have anything like 8xaa set globally or somthing.

Other than that sorry I cant help.
April 11, 2011 6:55:32 PM

nocturnal7x said:
Makes little sense. I would try reinstalling the game, defragging the hard drive, make sure the game is patched (I know it had a memory leak at one point).

Make sure your graphics card settings arent different for crysis and warhead. Make sure you don't have anything like 8xaa set globally or somthing.

Other than that sorry I cant help.

Tryed all of that before.
It is not something wrong with the engine I know that so its a start.
Crysis 2 running maxed at 1680 x 1050 at 40+ fps so makes no sense. :p 
:??:  :??:  :??:  :p 
!