Sign in with
Sign up | Sign in
Your question

Why my Gaming PC performs so bad in FSX?

Last response: in Video Games
Share
March 4, 2011 7:43:29 PM

Rig config

CPU: INTEL i5-750 (4.00Ghz)
GPU: ASUS HD 6970 (x2 crossfire mode) OC
MB: ASUS Maximus III Formula
HDD: SEAGATE 1Tb 7200 SATA 2
PSU: ENERMAX Revolution85+ 1020W
RAM: CORSAIR Dominator Gt 2000Mhz (8Gb)

resolution: 5760x1080 getting a max of 20 FPS also if i change the graphics setting
tried also with standard 1920x1080 same thing 20 FPS

i really don't know what to do....

please need some help...


March 5, 2011 4:21:44 AM

mayer19 said:
Rig config

CPU: INTEL i5-750 (4.00Ghz)
GPU: ASUS HD 6970 (x2 crossfire mode) OC
MB: ASUS Maximus III Formula
HDD: SEAGATE 1Tb 7200 SATA 2
PSU: ENERMAX Revolution85+ 1020W
RAM: CORSAIR Dominator Gt 2000Mhz (8Gb)

resolution: 5760x1080 getting a max of 20 FPS also if i change the graphics setting
tried also with standard 1920x1080 same thing 20 FPS

i really don't know what to do....

please need some help...


A CrossFireX EyeFinity configuration. There are many other users experiencing the same problem with the config, low fps, stuttering, glitches, and so on.
Try these:

0. What Dadiggle said. Update drivers, or do a clean install to ensure all systems up-to-date and apply the latest patches and fixes for the game you play.

1. Download appropriate Catalyst Profile from here http://www.rage3d.com/cap/
for each game you can specify different profile in Catalyst Control Center. Or, if you want something easier to use, try the Radeon Profile tool http://www.radeonpro.info/en-US/. It can help you manage profiles for different games at different resolutions.

if it still doesn't help then try

2. disable Catalyst A.I. in the CCC, also disable Vertical Sync. If you have Anti-Aliasing and Anisotropic Filtering turned on either in CCC or in the game settings, turn it oFF or lower it all the way down.

lastly,

3. some people said that playing the game in Windowed mode helped, especially for Blizzard games (WoW, SC II), which are un-optimized for nonstandard resolutions. Set up the game to Windowed - maximized mode, with resolution a notch lower than your desktop's native resolution.
March 5, 2011 9:13:06 AM

Quote:
You have a terrible hdd I must say.

Dropping resolutions same fps. Drivers?
Are they up to date? uninstall them using a driver sweeper. Then reinstall the latest or a earlier version. Google to check what catalyst drivers have the least issues and try them


yes the graphic card drivers and the CCC are updated at 11.2 versione i've already tried to uninstal theme and download the same and an earlier version no differcences to fps in FSX

but i noticed that when i'm in game , the game stress only one core making it go to 100% load and the other 4 cores at 30% load why?

same with the graphics card if using the dx10 crossfire remains enabled and bothe work at highest load 69%
but when i use de dx9 the game disable the crossfire make the first gPu load 99%.....
Related resources
March 5, 2011 9:14:13 AM

KorganoS said:
A CrossFireX EyeFinity configuration. There are many other users experiencing the same problem with the config, low fps, stuttering, glitches, and so on.
Try these:

0. What Dadiggle said. Update drivers, or do a clean install to ensure all systems up-to-date and apply the latest patches and fixes for the game you play.

1. Download appropriate Catalyst Profile from here http://www.rage3d.com/cap/
for each game you can specify different profile in Catalyst Control Center. Or, if you want something easier to use, try the Radeon Profile tool http://www.radeonpro.info/en-US/. It can help you manage profiles for different games at different resolutions.

if it still doesn't help then try

2. disable Catalyst A.I. in the CCC, also disable Vertical Sync. If you have Anti-Aliasing and Anisotropic Filtering turned on either in CCC or in the game settings, turn it oFF or lower it all the way down.

lastly,

3. some people said that playing the game in Windowed mode helped, especially for Blizzard games (WoW, SC II), which are un-optimized for nonstandard resolutions. Set up the game to Windowed - maximized mode, with resolution a notch lower than your desktop's native resolution.




ok i'm going to try those solutions....

report later if something changed
March 5, 2011 9:22:30 AM

in your opinion wich HDD should i buy instead of the one i have?
March 5, 2011 11:15:19 AM

Make sure you have the patches for the game. There are two patches and one of them makes the game make use of more than one cpu core. This patch made a huge difference to my experience because the game is very cpu limited.
March 5, 2011 11:31:32 AM

Micropat said:
Make sure you have the patches for the game. There are two patches and one of them makes the game make use of more than one cpu core. This patch made a huge difference to my experience because the game is very cpu limited.

wich patches? DO you mean service pack 1 and 2 for FSX? i already got the acceleration installed does it have both 2 patches?
March 20, 2011 2:19:03 PM

1. Are you flying online (VATSIM)? If so, are you using FSInn/FSCopilot or Squawkbox?
2. What OS are you running?
3. What Add-Ons, if any, are you using? ActiveSky, FSPax, REX, scenery addons, etc. Some of them can be FPS killers.
4. Have you done any FSX.cfg tweaks. There are several that can make a big difference.
http://members.cox.net/spambait/FSXTweakGuide.pdf
Google "FSX Tweaks". You'll find a wealth of information. Just make sure it's talking about FSX and not FS9 (2004). The AffinityMask setting will allow FSX to use all your cores. Also, if you're using FSInn to connect to VATSIM or other online network, there's a Multicore setting in the FSCopilot menu.
5. If you're running Windows 7 in windowed mode (not full screen, that's recommended), set your task bar (bottom of screen) to auto hide. Everyone that does, including myself, has seen a 5 fps increase when it's hidden.

My system is a bit more modest than yours. Q9550 cpu o/c to 3.4ghz, HD 5850 (just one, I've heard that SLI or Crossfire doesn't help FSX much), Win7 Ult x64, 8gb PC2-8500 OCZ, 28" monitor at 1920x1200. I run in windowed mode and get 25-50 fps average, set for unlimited. Depending on the plane, I'll get 40-over 100 when at cruise altitude (I fly online on VATSIM). My FPS will drop to around 15-30 when coming into a big city. KJFK is the most intensive. Most of my display 'sliders' are at max or close to it. I have the AI traffic turned off.
March 21, 2011 4:53:55 PM

the game only uses ONE core , it came out before the multi core rage took off ....

btw what do you need TWO 6970's for ? i mean geez , there are only maybe three games MAYBE where that would even make a slight difference in game play , talk about over kill ..
May 16, 2011 12:38:10 PM

i need 2 because i use eyefinity 6064x1080 it's a huge resolution for a single card
May 16, 2011 12:42:46 PM

KaptainKaos said:
1. Are you flying online (VATSIM)? If so, are you using FSInn/FSCopilot or Squawkbox?
2. What OS are you running?
3. What Add-Ons, if any, are you using? ActiveSky, FSPax, REX, scenery addons, etc. Some of them can be FPS killers.
4. Have you done any FSX.cfg tweaks. There are several that can make a big difference.
http://members.cox.net/spambait/FSXTweakGuide.pdf
Google "FSX Tweaks". You'll find a wealth of information. Just make sure it's talking about FSX and not FS9 (2004). The AffinityMask setting will allow FSX to use all your cores. Also, if you're using FSInn to connect to VATSIM or other online network, there's a Multicore setting in the FSCopilot menu.
5. If you're running Windows 7 in windowed mode (not full screen, that's recommended), set your task bar (bottom of screen) to auto hide. Everyone that does, including myself, has seen a 5 fps increase when it's hidden.

My system is a bit more modest than yours. Q9550 cpu o/c to 3.4ghz, HD 5850 (just one, I've heard that SLI or Crossfire doesn't help FSX much), Win7 Ult x64, 8gb PC2-8500 OCZ, 28" monitor at 1920x1200. I run in windowed mode and get 25-50 fps average, set for unlimited. Depending on the plane, I'll get 40-over 100 when at cruise altitude (I fly online on VATSIM). My FPS will drop to around 15-30 when coming into a big city. KJFK is the most intensive. Most of my display 'sliders' are at max or close to it. I have the AI traffic turned off.


1)no i don't use VATSIM i use IVAO
2)Windows 7 home premium 64bit
3)Addons i only have wilco airbus pack and aerosoft airbus x and barcellona mega scenaries
4)i've tried only one fsx.cfg tweak with a little increase like 7fps
a b Ĉ ASUS
May 16, 2011 5:38:47 PM

sounds like you have hit a bottlekneck turn off the eyefinity for a test. max out the settings and run fraps to see what you get.
then reduce all the eye candy but leve the screen rez.
if you get similar fps then you can be sure the cpu is the bottlekneck and sadly there isnt anything you can do abt it, as its such an old game. it really does prefer dx9 and win xp.
a b Ĉ ASUS
May 16, 2011 6:56:50 PM

would be very odd if it was. they do say on many forums that the game plays smoothly at less than 20 fps as the fps isnt as important due to the game mechanics. i still find that odd though.
!