Sign in with
Sign up | Sign in
Your question

Help games lagging on Custom PC?

Last response: in Video Games
Share
March 5, 2011 5:21:50 PM

Hello, When i say Lag, I mean not playable like GTA IV 20-30FPS, Metro 2033 20-30FPS, Borderlands 20-30FPS. etc. I have all drivers etc up to date, not viruses spyware, no uneccesary processes, my specs are, AMD Phenom II x6 1100T BE, Asus RADEON HD 6950, Asus Crosshair formula IV, 8GB of special ops ram, 650W PSU. help please :(  I dont know what to do...

More about : games lagging custom

March 5, 2011 5:23:05 PM

I meant no viruses or spywares...
March 5, 2011 7:00:07 PM

Yep bad fps considering the card.
Monitor your temps with HW monitor to start with.
Also, remove your current drivers, clean the registry then re install them or any latest available.
Related resources
March 5, 2011 8:00:49 PM

Temps are fine.
Keep the app open and put the pc on load.
March 5, 2011 10:24:18 PM

On your screen shots of Hardware Monitor, why are we not seeing any Fan speeds for your CPU and GPU Fans ?
March 5, 2011 10:26:52 PM

Ok i notice on your underload picture, your CPU fan is registered and is spinning at nearly 3500 RPM, this seems very very high to me,what cooler are you running on your CPU, is it seated correctly ? This could be a reason, and your CPU could be throttling back to protect itself.
March 5, 2011 10:29:29 PM

You could do to run CPU Z also underload along side Hardware Monitor, so we can see what your CPU is doing as far as its frequency/multiplier is concerned.
March 5, 2011 10:50:22 PM

I'am using the stock cooler provided by with the CPU... I doubt it's spinning at 3500RPM it's probably not giving proper results. http://i403.photobucket.com/albums/pp118/nervz123/Temps... CPU-z and HWmontior with GPU-z. 2nd BIOS Readings. http://i403.photobucket.com/albums/pp118/nervz123/IMG_0... . http://i403.photobucket.com/albums/pp118/nervz123/IMG_0... . I will reply in the morning now since its 1Am must sleep. Please post as much as you can to help me out, I have been frustrated for several weeks because of this problems... !?
March 6, 2011 2:58:29 AM

As i said, you need to snapshot after cpu has gone into full load for some time. Your idle temps are fine.
March 6, 2011 8:18:21 AM

That is a snapshot of the CPU underload... lol. It's taken while playing GTA IV on max settings....
March 6, 2011 9:57:26 AM

Sir? lol. Anyways, 1920x1080
March 6, 2011 10:06:40 AM

Quote:
GTA IV is cpu depended and a bad port. You need about 20 patches for it to run properly. If you haven't installed the patches do so.
Metro in dx 11 all on high are heavy on the gpu. Run it in dx 10 mode and have a look.
You got a 6950 flash it to a 6970.


Lol I did flash it, but it's a bit pointless it made no difference to the FPS. GTA IV is patched and up to date, i get were you're comign from playing metro 2033 in Dx10, I mean no offence but if i wanted to play it in DX10 I would'nt of spent as much money... Though I digress. I did play it in DX10 it makes a significant difference though theres still that annoying stuttering.
March 6, 2011 10:08:00 AM

Oh whats clip recorder? And I'm running ESET smart security x64
March 6, 2011 11:27:36 AM

Huh? Wait I'm confused... Are you sure you read my post properly? ASUS Radeon HD 6950 as far as I know it's 2GB of GDDR5 memory on the GPU....
March 6, 2011 2:18:18 PM

I don't have any "unsupported, uncompressed files." So as far as ESET goes, it doesn't affect my pc.
March 6, 2011 3:27:25 PM

I know, I wasn't questioning your superiority, and intelligence. Obviously you know more than me, but the problem is that I tried these games without any antivirus, plus ESET is so quiet in terms of eating resources, it's like I dont even have antivirus installed. No I'm a 100% sure all Radeon HD 6950's come with 2GB of GDDR5 VRAM. Anyways, as far as the CPU is concerned I have a HEX core CPU so it's still a bit baffling... I doubt you need more than GTX 470 to run metro 2033 at max settings. Lol
March 6, 2011 4:10:32 PM

I clearly stated it was a ASUS Radeon HD 6950, so I dont know why you're linking me to a sapphire card o_o. Lol. Anyways moving on topic, scanning with malware bytes won't make a difference my computer was recently formatted a couple of days ago. i've scanned with several different programs, defragged yesterday night. By superiority I wasn't being sarcastic, I was referring to your knowledge, as your profile states you are an addict? So you should have more knowledge than me on these subjects etc. http://www.hardocp.com/images/articles/126962492671BZgJ... . That should emphasize my point enough, I'm sorry if I'm sounding like a 12 year old moany kid, but after spending so much money and trying to find a solution for over a month, wouldn't everyone be as frustrated? Won't dowgrading drivers cause distress for the game, as everyone I've searched everyone emphasizes having the "latest drivers" though I would give anything to make the games run properly :) . Yes I know AMD are stubborn, as far as drivers go... But you get what you pay for so....
March 6, 2011 4:25:58 PM

He linked you to a sapphire card since you said that your 100% sure that all 6950 have 2gb Vram... therefore he proved you wrong... and i have no clue whats going on but how old is your graphics card? could it possibly be undervolted or something? and what's your PSU? maybe it's not giving enough power for everything.
March 6, 2011 4:32:25 PM

Not really, he said that he thought I had a 1GB card, meaning he didn't bother reading my first post... Just like you haven't read the first post...
March 6, 2011 5:15:34 PM

Can you link me to ASUS Radeon HD 6950 that is 1GB? Any other, immensely useful information...?
March 7, 2011 12:18:25 AM

I've never heard of that brand before why wouldn't you go with a trustworthy/known brand like corsair or coolermaster? or am i completely wrong and OcUK is a completely known and trustworthy brand in the UK?
March 7, 2011 11:47:32 AM

Lol I would get a new PSU, the thing is someone needs to convince me the problem is PSU related. Otherwise why would I bother wasting 100-290 pounds and at the end of it I find out that the GPU is faulty etc. OCuk have been in business since 1990's I doubt they would risk their reputation selling crappy PSU's. I'm thinking of getting a Coraair TX something 850W for when I crossfire. But that's another story. Now I need to fix this issue. So help ? 0:
March 7, 2011 3:09:08 PM

I have the same Problem, new components but games perform worse than before same thing happened when i upgraded from my 8800 GTX to GTX 280 on my old build I suddenly got problems.
March 7, 2011 3:20:38 PM

Lol it's frustrating right :( ?

@Mithness Btw I found out the brand isn't actually ocUK it's PowerCool :) 
March 7, 2011 3:23:27 PM

TheHobbitGamer said:
Did you find a fix for it? :bounce: 


No I still have the problem i am still waiting for someone to help me in my thread i made yesterday.
March 7, 2011 6:16:03 PM

PowerCool even yet another Brand i've never heard of. do you have any friends with PC's and such could you maybe ask them to atleast test a new PSU? i know this can be difficult and if you can't could you maybe buy a new one and then if it doesn't work get a refund?
March 7, 2011 7:37:01 PM

Quote:
OP did you try the antivirus suggestion or the driver suggestion? You won't find a solution unless you prepared to take possible reasons out of the equations. you might have gotten a bad update from Eset. So start at the antivirus.


Yes I tried both, tried catalyst 10.6 and 10.8 they would install all apps apart from the display driver which is quite odd, as I knew I wasn't doing anything wrong, I then proceeded to the manufacturers site (ASUS) and downloaded the appropiate driver. Made no difference to the performance etc. I flashed again to a ASUS 6970. The un-installation made no difference. Did you see the PSU image?
March 7, 2011 7:42:26 PM

Mithness said:
PowerCool even yet another Brand i've never heard of. do you have any friends with PC's and such could you maybe ask them to atleast test a new PSU? i know this can be difficult and if you can't could you maybe buy a new one and then if it doesn't work get a refund?


Would I be eligible for a refund, as I've already opened and used the product. Or should I ask for a refund based on the PSU's gurantee thing :) . Yes I agree never trust a company based on their repuatation. No unfortunately I'm the only computer enthusiast out of the bunch, so no hope there. Should I buy a new PSU? Which would you recommend? I probably wont crossfire for a couple of months so... Yeah 500W+ should be enough right...
March 7, 2011 8:07:45 PM

so much files starting with ATI? which one do you want?
March 7, 2011 8:10:50 PM

I would suggest one of the 4 brands

Corsair
Thermaltake (i own a 500watt Thermaltake TR2 PSU and it works wonders)
Coolermaster
or Antec....
maybe OCZ ( i want one for my next computer becuase its the only PSU with a red LED)

and i know what you mean being the only computer guy around thats like me and my friends i have a computer and all my other friends have consoles ):

and for the refund i ment buy a new one... if you can and test it. if it doesn't fix your solution take it back? or try to get a refund on the one you have now and get a good brand...

How long ago did you make this computer how old are the parts? Sorry if you've already answered this im short on time right now
March 7, 2011 8:11:35 PM

Its not modular :( . Modular please?
March 7, 2011 8:13:09 PM

3Weeks ago... Yeah, consoles suck hard. LOL
March 7, 2011 9:06:58 PM

OH, I don't know what I would do without the internet. Should I remove CCC from Programs and features than reboot into safe mode use drive sweeper and clean, then reinstall? Btw just to let you know I filed a complaint for the PSU, and requested a refund. :)  Though me getting one about 40% chance, might get a replacement, lol.
March 7, 2011 9:14:33 PM

@Dadiggle why wouldn't you touch the TR2 series? it's been good to me so far. but my specs are nothing great.

And I'm guessing you could get a refund since it's only 3 weeks old.
March 8, 2011 2:33:28 PM

@Dadiggle I tried drivesweeper method it didn't work, installed 10.8 display driver wouldn't install. I have requested a refund for a PSU. I think they will accept as it was within 28 day policy :) 
March 9, 2011 3:27:35 PM

Removed ESET. Installed MS Security essentials. It isn't any faster! Though I'm probably not going to revert back now. :) . More help please! I downloaded Everest ultimate edition it shows the 12V+ 5V+ 3V+ all fine, and now problems.
March 9, 2011 7:25:47 PM

TheHobbitGamer said:
I clearly stated it was a ASUS Radeon HD 6950, so I dont know why you're linking me to a sapphire card o_o. Lol. Anyways moving on topic, scanning with malware bytes won't make a difference my computer was recently formatted a couple of days ago. i've scanned with several different programs, defragged yesterday night. By superiority I wasn't being sarcastic, I was referring to your knowledge, as your profile states you are an addict? So you should have more knowledge than me on these subjects etc. http://www.hardocp.com/images/articles/126962492671BZgJ... . That should emphasize my point enough, I'm sorry if I'm sounding like a 12 year old moany kid, but after spending so much money and trying to find a solution for over a month, wouldn't everyone be as frustrated? Won't dowgrading drivers cause distress for the game, as everyone I've searched everyone emphasizes having the "latest drivers" though I would give anything to make the games run properly :) . Yes I know AMD are stubborn, as far as drivers go... But you get what you pay for so....

I could be wrong as you didnt link the whole article but any benchmark stating 60FPS on full setting as of right now in Metro 2033 is most likely a benchmark ran on a crossfire sli setup. And that card gets close to double performance in crossfire so getting 30 FPS with full settings is about right, that game is real hard on GPU's
March 9, 2011 7:29:36 PM

not all 6950 unlock and are stable thats one thing. Second I have an XFX 6950 unlocked nad I see about 5-10 FPS boost in Crysis if I keep the setting the same so if it flashed right you should see a diff. I also have a tr2 PSU and it runs that card fin its a 750w
March 9, 2011 8:41:08 PM

I dont see the point of unlocking a card just to see hotter temperatures, and a 5-10% boost. IMO not worth it. That benchmark is from TechPowerup single 5850, they ran it several times and averaged the scores to that, as far as I know it's not a SLI. GTA IV at max settings uses just about 65-70% of the GPU, I wouldn't expect Metro 2033 to use nearly as much as that, unless im wrong. Then disregard this message :/ .
March 9, 2011 9:35:10 PM

TheHobbitGamer said:
I dont see the point of unlocking a card just to see hotter temperatures, and a 5-10% boost. IMO not worth it. That benchmark is from TechPowerup single 5850, they ran it several times and averaged the scores to that, as far as I know it's not a SLI. GTA IV at max settings uses just about 65-70% of the GPU, I wouldn't expect Metro 2033 to use nearly as much as that, unless im wrong. Then disregard this message :/ .

you see a temp increase yes. But its only the same increase you see if you had purchased a 6970. If you have a HD 5770 and upgrade to a 6950 you will see a temp increase but that upgrade is far and away worth it. Now i know GTA IV has some issues and that is why it is such a hard game on the PC. But go ahead and read as manny benchmarks as you want and they all say that Metro 2033 is one of the highest system requirement games out right now. This is just like Crysis was a few years back. When you turn the graphics up as high as you possibly can every single GPU single card setup out right now will have a hard time getting anywhere near 60 FPS.
March 10, 2011 6:19:42 AM

How would you explan the fact that I only get 20, if I'm lucky 30 FpS on borderlands. I understand where you're coming from about metro, but my point is that I can't even play it on mediocre settings without stuttering raping my FPS most games are like that. Though Starcraft 2 runs just fine on ultra settings with occasional lag but I can't complain about that.
March 10, 2011 6:43:29 AM

NordicFrog said:
How would you explan the fact that I only get 20, if I'm lucky 30 FpS on borderlands. I understand where you're coming from about metro, but my point is that I can't even play it on mediocre settings without stuttering raping my FPS most games are like that. Though Starcraft 2 runs just fine on ultra settings with occasional lag but I can't complain about that.

i cant say if its one game and the other are fine have you tried to reinstall that game, i know it sucks but if the other games are fine that might be it. I had bad performance after switching a mobo out and had to open device manager and enable show hidden driver and clear out EVERY driver my PC wasn't using. That helps bunches.
March 10, 2011 4:43:33 PM

I done that, by D3Doverider did yo mean RivaTuner? What do I do with RivaTuner? I disabled V-Sync, in CCC and enabled Triple buffering, I still average at about 27FPS, which isn't bad but it stutters when moving the camera wtf?
!