Sign in with
Sign up | Sign in
Your question

Lagging on Crysis and New Vegas

Last response: in Video Games
Share
March 6, 2011 11:09:34 PM

I recently Up graded my PC from a Core 2 Duo, 2 Gb of ram and a gigabyte motherboard to a Asus X58 Sabertooth, Core i7 950, and G.Skill DDR3 1600 6 GB triple channel memory.

so my specs go

Windows 7 64 bit Home Edition
G.Skill DDR3-1600 6GB Triple Channel memory
Asus X58 Motherboard
Core i7 950
GTX 280
Asus Xonar STX sound card.

Instead of getting an improvement I noticed games like crysis slow down to barely playable framerates in action sections which I never got before, also i noticed a performance decrease in New Vegas such as stuttering when i turn around when out in the wasteland again i never had that problem before.

More about : lagging crysis vegas

March 7, 2011 1:15:46 AM

I also updated the driver to my mother board and GPU and I still get problems in the games, could it be my RAM?
March 7, 2011 3:27:51 AM

I found playing Crysis in DX 9 got rid of the bad stuttering problem but however i still get stutters in New Vegas.
Related resources
March 7, 2011 11:49:41 AM

Did you upgrade the psu too?Also did you format the hdd and do a full reinstall of windows just to be sure?
March 7, 2011 2:06:54 PM

i didn't upgrade the PSU, but I have the Corsair 750 Watt PSU which i got 2-3 years ago.

I had Reformated my hard drive when i installed windows 7 64 bit i use to have Vista 32bit.

I Find Crysis works fine if I play in DX 9 but DX10 I get all these framerate problems going from 55 to 1 until i leave THAT area it goes back to 35-55 FPS.

New Vegas is different in that I maintain 60 FPS but if i turn i lose half of that and I end up looking the other way.
March 8, 2011 11:07:50 PM

New Vegas has issues with it as it is. There are mods and such on the Fallout New Vegas Nexus that you can use to help you game along. There was one called "No Stutter" that seemed to fix a few issues I was having. I have been running it in 1080p with all settings to max so this may be more my issue than just the game itself.
March 9, 2011 7:50:40 PM

If you didnt do a full reinstall of win 7 you shouldent have to. I just had a similar issue. I swapped out a mobo and would get ok frame rates except for when I would turn with my mouse. I went here.

http://www.howtogeek.com/howto/windows-vista/remove-old...

It shows you how to find hidden drivers.

I deleted EVERY driver that was grey and not being used.

My system is now smooth as can be.

Hope it helps :) 
!