Sign in with
Sign up | Sign in
Your question

CRYSIS - Computer runs it very slowly!

Last response: in Video Games
Share
Anonymous
March 29, 2011 9:41:37 PM

Hi,

I bought a new computer, mid range I'd say, and can play Just Cause 2, Battlefield Bad Company 2, Fallout 3, Far Cry 2 and OF2DR all on max settings with 8x anti aliasing at a decent frame rate, around 30-60fps. However my system doesn't seem to like Crysis.

I know that Crysis requires an expensive, extremely powerful setup to run well on max settings, but I thought my system would at least play it at a good frame rate on medium/high settings without any anti-aliasing. It is playing it all on low settings at a resolution of 1280x1024 without any anti aliasing, with about 20-35 fps, and seems to be very jerky despite when its at 35fps. I expected my system to play it a lot better than that. Am I overestimating what my system can do or is there a problem with my software, hardware or Crysis even? I don't think its my drivers, because it plays all other games at max really well.

I have:

- AMD 640 Quad Core, 3.00GHz
- 4 GB RAM
- Sapphire Radeon HD5770 Vapor X edition
- Windows 7 64 bit.

Any help would be great.

Thanks
March 29, 2011 10:31:20 PM

idk but my laptop will play all the crysis games on medium to high settings including crysis 2.
also i could play crysis the original on ultra but with frame rates in the low 20 high teens. so i think something is wrong.
crysis - i7 740qm mobility 5730 20ish on ultra settings
crysis 2 - i7 2630qm gt 540m 35ish on advance settings.
Anonymous
March 29, 2011 10:51:45 PM

cheers for the reply,

yeah it does seem slightly odd, seeing as I am well over the recommended system requirements :/  You don't suppose it could be to do with my graphics card being DX11 compatible or anything, although it is running DX10. I don't know much about computers so I'm just thinking up random ideas.

Cheers
Related resources
March 29, 2011 11:16:15 PM

recommended requirements don't mean anything anymore. you have to take them with a grain of salt. your processor doesn't have any L3 cache on it. Bad move for gaming. the video card isn't the greatest for crysis. try gaming at 1024x768 on medium settings. set your virtual ram as high as possible. turn off all running apps.....
Anonymous
March 29, 2011 11:38:30 PM

what do you mean by virtual ram and how do you change it? sorry I'm not great with computers.
Thanks for the reply
March 30, 2011 12:01:21 AM

start/right click my computer/ advanced system settings/ performance "settings"/advanced/virtual memory-change.......... i use custom size. initial+max are set the same for me..... way over suggested but not more than what's available.

make your changes, hit set/save or whatever is there. then okay to exit. i think you have to restart after.
March 30, 2011 3:43:33 PM

your well within specs i have heard of 1 problem relating to 1 cracked version of the game that causes severe slowdown to like 2-5 fps
if your not using the cracked version then update your gfx and sound drivers. dissable any extra audio you may have running that your not using.
Anonymous
March 30, 2011 9:05:09 PM

Nah I've got the normal version. But it's ok now I've fixed it, I updated my graphics drivers and that was the problem after all. Didn't expect it because all other games run great. I can now play with high settings at around 30-45fps which looks soooo much better.

Cheers for the help
March 30, 2011 9:33:18 PM

Crysis 2 Getting DX11 tomorrow?

check out the above named thread and find some links for optimization of the gfx.
April 4, 2011 2:58:55 AM

This game seems to be very finicky. With my old C2D and gtx260 I get 20fps in crysis with textures, shaders, water, objects maxed everything else on high.

Game feels butter smooth at 20fps, before I checked my frames I thought I was getting at least 30.

I would try googling for tweaks. This game is highly tweakable.
April 5, 2011 10:20:05 AM

There can be a virus problem in your system, try out scanning may be it is helpful.
!