Sign in with
Sign up | Sign in
Your question

3D apps crash, caused by Diamond Monster MX300!

Last response: in Motherboards
Share
Anonymous
a b V Motherboard
March 26, 2001 3:42:31 AM

Hello, all. This is my first post to this forum. I posted this to two other Tom's Hardware boards because it also relates to them; I hope nobody minds. I have been working on this problem for literally weeks (even staying up all night and morning working on it for several hours straight). I've finally got to the point where I will actually admit that I cannot fix it myself and I need some help. ;) 

All of my 3D accelerated games crash! _Every_ time. Within a few seconds of play, it hard crashes, and I have to physically reset the machine. Just FYI, I'm using Unreal as my testing program. The only thing that remedies the problem is removing the sound card. It runs fine after that (er..other than the fact that there's no sound ;)  ).

Here are my detailed current specs:
AMD Athlon CPU, 600MHz (Not overclocked)
ASUS K7M motherboard
256MB PC-133 RAM
Diamond Viper v770 video card, 32MB
Diamond Monster Sound MX300 Sound Card
Windows Millenium (ME)

Here is what I have tried so far (that I could remember; I have been working for weeks on it...):

Swapping video card (no luck, so obviously not hardware failure on the video card's part)

Using 1 of the 128MB DIMMs and then switching it (eliminating memory failure)

Removing the sound card (which, as I mentioned before, stopped the crashes)

Disabling all extra parts of the sound card in the System/Devices tab (such as the Gameport, midi, etc.), with only the "PCI audio driver on, still crashed

Defragging

Reinstalling Windows ME

Formatting the hard drive, installed Win98 this time, no luck, reinstalled ME, no luck)

Removing all extra hardware (modem, NIC)

Tried using DirectX 5, 7, 8

Tried latest video reference drivers (Detonator), latest drivers from Diamond, drivers that the card shipped with

Tried latest sound card drivers from Diamond

Moved sound card into a different slot

Changed sound card's IRQ

Reduced AGP aperature from 64MB to 32MB and then back

Getting latest patch for test subject (Unreal)

Removed both sides of the case and placed a (perfect sized) fan on the left, which served as a very good cooling device that I shall remember if I ever consider overclocking, but still didn't solve the problem

Checked to make sure the video card was using AGP 2x, as 4x is not supported on my board

OpenGL rendering as opposed to Direct3D

I think that about does it. I have tried _EVERYTHING_ that I can think of, and I am so completely stumped. I'm a serious gamer and it is driving me crazy. Oddly enough, Unreal Tournament (which a large part based on Unreal's engine) does not crash, but every other 3D accelerated application does that I've tried so far (Unreal, Quake III, Half Life...) I'm lost! It works in software rendering mode just fine, and works with the sound card disabled or removed just fine. I'm going to try enabling the "memory hole" in the BIOS, and that's the only thing left that I can think of. PLEASE SOMEBODY HELP ME!!!!!!!!

-InsanePyroTeknix
David Michael
March 26, 2001 4:03:26 AM

How about trying a different sound card or putting yours in another computer?
Anonymous
a b V Motherboard
March 26, 2001 6:11:27 AM

take a look at www.vortexofsound
and you will probably see that there are a few things you havent tried yet.

good luck

I want a tbird
Related resources
Anonymous
a b V Motherboard
March 26, 2001 12:56:57 PM

I've had the same problem. I admit, months of research and HW swapping.

Finally I've found what my last step could be: Advanced BIOS, step by step.
1. Note all the possible settings on a sheet of paper.
2. Set all the settings to "safe" (load bios default safe)
3. Change one option at a time, put it in the second column in red when it crashes and green(blue) when ok.
4. Test it, if it fails get back in BIOS and change another setting. Repeat the steps untill you see major change, this means if the crash time is very much later then 30 minutes then you are going in a good direction.
March 26, 2001 3:06:41 PM

I also had the same problem with a MX300 and my (at the time new) Thunderbird. No matter what, it refused to allow me to run 3D software. I swapped the MX300 for a Sound Blaster PCI128 and everything ran completely fine and stable (though I've since upgraded to a SB Live).
Anonymous
a b V Motherboard
March 27, 2001 1:46:11 AM

Aureal's reference drivers _FINALLY_ fixed this problem!! Thanks everyone for all of your help.
!