Sign in with
Sign up | Sign in
Your question

High FPS but appears extremely low on-screen

Last response: in Video Games
Share
April 9, 2011 11:45:55 AM

Just built a new PC. It runs things great however in Crysis and some other games I've noticed something strange.

With Vsync disabled, I can get an FPS of anywhere between 70-100. The problem is that this apparent high fps looks horribly low onscreen - morel ike 25-30 fps, perhaps lower. Then when I enable Vsync, the FPS obviously syncs to my monitors at 60 FPS/Hz and the game appears to run butter smooth. Why is it that without Vsync, the higher FPS appears alot lower? This annoys me because as you know having Vsync in most games sacrifices mouse responce. - I would prefer ot have it off - what is going on here? I have a fairly high end system :

i7 960 (stock)

6gb DDR3 Ram Patriot Viper 2

HD 6990

Asus VE278Q 27" monitor
April 9, 2011 2:02:16 PM

Darkenraja said:
Just built a new PC. It runs things great however in Crysis and some other games I've noticed something strange.

With Vsync disabled, I can get an FPS of anywhere between 70-100. The problem is that this apparent high fps looks horribly low onscreen - morel ike 25-30 fps, perhaps lower. Then when I enable Vsync, the FPS obviously syncs to my monitors at 60 FPS/Hz and the game appears to run butter smooth. Why is it that without Vsync, the higher FPS appears alot lower? This annoys me because as you know having Vsync in most games sacrifices mouse responce. - I would prefer ot have it off - what is going on here? I have a fairly high end system :

i7 960 (stock)

6gb DDR3 Ram Patriot Viper 2

HD 6990

Asus VE278Q 27" monitor



Its an issue with the 6990 or most Xfired rigs.....alot of them get screen tearing which is what you are seeing. Hopefully a driver update in the near future fixes this.
m
0
l
April 12, 2011 8:44:35 PM

I play with vsync on because of tearing. I dont notice mose lag but I could just be much less sensitive than you are to that type of thing? Do you have tripple buffering on? I have heard that will give you imput lag as well. Maybe try playing with vsync with no tripple buffering?
m
0
l
!