Sign in with
Sign up | Sign in
Your question

Slowdown starcraft 2 ati radeon 5670

Tags:
  • PC gaming
  • Starcraft 2
  • Video Games
Last response: in Video Games
Share
April 17, 2011 2:55:45 AM

Hello,

I seem to have slowdown at intervals playing starcraft 2, with a radion 5670 hd 3d graphics card. even on the lowest settings, or highest settings (not due to units on screen, it just happens whenever it feels. here are my specs: <<< System Summary >>>
> Mainboard : Asus M2N68-AM SE2
> Chipset : Athlon64/Opteron/Sempron (K8 Family) HyperTransport Configuration
> Processor : AMD Athlon 64 X2 5200+ @ 2700MHz
> Physical Memory : 3072MBDDR2-SDRAM
> Video Card : ATI Radeon HD 5600 Series
> Hard Disk : SAMSUNG HD501LJ SCSI Disk Device (500GB)
> DVD-Rom Drive : HL-DT-ST DVDRAM GH22NS50
> Monitor Type : Envision EN-775e - 16 inches
> Network Card : Juniper Network Connect Virtual Adapter
> Network Card : NVIDIA nForce Networking Controller
> Operating System : Microsoft Windows XP Professional 5.01.2600 Service Pack 3 (32-bit)
> DirectX : Version 9.0c (May 2010) please help!

More about : slowdown starcraft ati radeon 5670

April 17, 2011 4:12:02 AM

Your processor or CPU, seems to be the problem. You need to have a good, processor, like a Phenom X 4, in order to run the game without having much slowdowns. This is mainly because Starcraft 2 is CPU hungry rather than GPU. So having a better processor may help. Did you install any new patches or downloaded the latest ATI drivers for your HD 5670. Do you have issues with any other games ?
m
0
l
April 17, 2011 4:31:19 AM

no issues with any other games that I have played, doom 3 quake 4, devil may cry 4, I dunno starcraft 2 is the real recent game I have, yes my drivers are up to date. as to patches? patches to what starcraft? well yea I have to to play online. patches up to date in game as well. (as you may know Im not a pro in computers, actually I dont know anything lol) I just found it wierd, that weather I was on low graphics or high, it would still slow down for 30 seconds, then go back to normal for 3 minutes then drop. doesent matter if its in a huge battle or not. could be right off the beginning of the game.
m
0
l
Related resources
April 17, 2011 4:35:03 AM

Do you have any apps running in the background. If so, try and disable them, that could help.
This could be the problem with CPU usage.
m
0
l
April 18, 2011 8:32:23 AM

not that I know of. here is my processes right now, and mostly every day. (I dont know all of them and which ones I can turn off.

iexplorer.exe.
bluebirds.exe.
SC@.exe (thats starcraft no point turning the program I want off lol
alg.exe (this one says local service not user)
ctfmon.exe
svchost.exe - SYSTEM
soffice.bin
ati2evxx.exe (could that be my ati card?)
scvhost.exe (again?)
jusched.exe
wmiprvse.exe - SYSTEM
msseces.exe
ntuneservice.exe (this should probably be removed alltogehter)
jqs.exe. -SYSTEM
l3trace_initualizer - SYSTEM
spoolsv.exe -SYSTEM
inen_qos_service w322-1-1.exe -SYSTEM
MsMpEng.exe -SYSTEM
CCC.exe (control catalyst center)
Issas.exe -SYSTEM
Services.exe -SYSTEM
Winlogon.exe -SYSTEM
crss.exe -SYSTEM
smss.exe -SYSTEM
soffice.exe -SYSTEM (open office I think for my work)
System -SYSTEM
System idle process -SYSTEM

anyways I think thats all of them, any junk you notice in there?
I also noticed (like i said Im a noob) having task manager up, playing starcraft 2, there is a total of 3144924 for physical memory (must be ram in kilobytes?
when playing the game I have 600,000 available. (can I use that memory for the game?
do you need any other info from me I could pull up while running the game?

Im watching a replay (that sometimes slows down too. and while task manarger is open I have SC2.exe using resources, taskmgr (obviously) internet explorer, cause this page is up. and thats it the rest is system idle process.

viewing my replay i notice that sc2.exe can go up to 66% cpu usage.
hope this helps!
m
0
l
April 18, 2011 12:02:44 PM

open your ati pannel and select gaming/3d applications.
set your AA mode to multisample. set mipmap level to quality, turn off morphological filtering. you may need to turn down the ai mipmap levels but see how the game runs first
m
0
l
April 18, 2011 9:06:57 PM

Ill try that thanks
m
0
l
April 18, 2011 9:39:06 PM

same issue persists
m
0
l
April 18, 2011 10:33:32 PM

check your memory usage.
m
0
l
April 18, 2011 10:57:01 PM

Im new with computers. this is done how? and what am I looking for exactly
m
0
l
April 19, 2011 12:21:36 AM

Ev1lryu said:
i've seen this before and i say its a cpu bottleneck. I have seen a performance jump going from 3-core to quad (when I unlocked my x3).

See this article for reference: http://www.tomshardware.com/reviews/starcraft-ii-radeon...


this pc is only 2 years old, it needs an upgrade? :( 
m
0
l
April 19, 2011 4:24:56 PM

But 2 years ago the 5200 X2 was already old. Not sure when it fist came out, but i found information about OC the CPU from 02-04-08.
m
0
l
April 19, 2011 5:40:29 PM

@Dominic6,
I have the AMD Phenom X4 BE 2.6ghz and SC2 ran like crap, I had to OC it to 2.9ghz and now it runs great. SC2 needs more CPU power. I have the black edition and was able to OC to 2.9 on a stock cooler. Your CPU does not appear to be a black edition and you will need to research the best way to OC it.

also, based on the requirements for the game http://us.blizzard.com/support/article.xml?articleId=26... your video card is sub par.

My recommendation is upgrade your video card, upgrade your processor and upgrade your OS...for your hardware look on ebay and craigslist
m
0
l
!