Sign in with
Sign up | Sign in
Your question
Solved

Bad Company 2 AA problem

Last response: in Video Games
Share
April 22, 2011 4:58:47 PM

To start off here are my specs:
Core 2 Duo E6600 OC @ 3.00GHz
4GB RAM(Only 3GB useable)
4870 512mb
500W PSU

I recently upgraded to Windows 7 32-bit from XP 32-bit with the understanding that I would be able to use the in game setting for aa/msaa. However, whenever I set it higher than 1xmsaa in the game options, the msaa works but all water disappears and the sky turns gray. Changing it in the settings.ini file results in the same thing or doesn't apply msaa at all. I am running the latest (11.3) drivers, and have tried leaving dx version on auto and 10 in the settings.ini file, have tried using a launching program. Alos, when I attempt to force AA with CCC, it seems to have no effect on the game whatsoever. How do I get aa? What is the problem here? Can DICE really not implement anti-aliasing properly into a 2010 game?

More about : bad company problem

Best solution

April 22, 2011 7:16:06 PM

well this is a new 1 to me. most of the problems i have come across with guys that have dual core's is that they cant push there gfx past 50 percent usage. the game really does need a quad to be playable.
a m8 of min has an identical setup as you but his problem is keeping the fps from stalling out and getting massive drops down to 15fps from an average 50.

i will ask him later if he has updated to the latest drivers or if he has had any gfx problems after doing so and get back to you.

btw dx10 in win xp doesn't work it only supports dx9.0c. you need vista minimum. so set your dx version to 9 in the ini file... also make sure you haven't inadvertently corrupted it. try deleting that ini the game will make a fresh 1 when next run. (set that 1 to dx9)
forcing aa by the ccc panel doesn't work on this game not all games will allow you to over ride there settings. only about half will and its often more demanding when you do do it...
1 other thin have you adjusted the mip map settings and gone from multi sampling to super sampling in the cc panel. if so or you have adjusted other settings in there i recommend you reset it back to default just for testing. and to get a baseline.

anyways my m8 wont be on TS till late so i will reply in about 4 hours if you dont get a proper answer b4 then.
Share
April 22, 2011 7:28:34 PM

@Hexit .. 30 years of gaming experience ..woah ..Ive been playin since I was 5 and ive only played 12 years ..!
m
0
l
Related resources
April 22, 2011 8:20:35 PM

Yeah, I really wish I had a quadcore, but I would have to get a whole new mobo unless I bought a C2Q(Overpriced imo). Yes, the reason I got W7 was so I could take advantage of DX10. I have W7 now, not xp anymore. I have tried leaving the dx auto, and changing it to 9 and 10 in the file. Wouldn't it have to be at 10/auto in the file for the in-game msaa to work though? A guy on ea's forums swears that I don't have enough VRAM for AA. He told me to try running at lower resolution and see if aa works then...nope. I went all the way down to 1024x768(native of 1680x1050)and the sky turned gray and the water disappeared then still with 2x and 4x msaa. He still insists I am running out of VRAM and these effects are how BC2 handles it. I just don't know anymore. Thanks for the feedback.
m
0
l
April 22, 2011 8:35:18 PM

sorry m8 i didnt see your reference to win 7.
no m8 you have enough gfx ram like i say my m8 has the same system specs and he runs his at x1 msaa setting.
im more inclined to think its a dx problem. have you tried reinstalling the latest dx libraries.
i found after a fresh win7 install i needed to update them even though win 7 comes with em.

http://www.microsoft.com/downloads/en/resultsForProduct...

get both the user runtime and redist dated 4/18/2011

the runtime may just tell you your up to date if you have kept on top of it. but its best to check anyway.
m
0
l
April 22, 2011 11:33:40 PM

well i just finished chatting to my m8 and he has no issues like you describe.
all he can think of is defragging your hdd as you may be suffering with missing textures due to fragmentation.
m
0
l
April 23, 2011 12:28:40 AM

Has he tried running it at over 1xmsaa? I can do that, it's anything higher that messes things up. I'm installing the dx thing now, so maybe that will fix it.
m
0
l
April 23, 2011 1:14:36 AM

No change after installing the dx package, I've heard AA has always been an issue with this game. Guess I'll have to live without it. It's a shame that game made in 2010 cannot have AA properly implemented. Don't think I'll be buying anything by EA/DICE after all these problems.
m
0
l
April 23, 2011 4:14:57 AM

he has ran it all the way up to max m8, as i said he was trying to get his card to run at more than 50 percent gpu which because he has a dual core, it wont do. check your gpu usage...
m
0
l
April 23, 2011 6:41:13 PM

Best answer selected by trogdor796.
m
0
l
!