Sign in with
Sign up | Sign in
Your question
Closed

Command and Conquer 3 Tiberium Wars not working on 64-Bit Win 7??

Last response: in Video Games
Share
April 22, 2011 7:19:09 PM

Today I tried installing CnC 3 Tiberium Wars on my new PC which is running Windows 7 64-Bit. However the Game Installer told me or rather gave me a message that the game doesnt run on 64-Bit versions of Windows. Is that true? Because I thought most modern games could run on 32-Bit and 64-Bit Windows?
a b $ Windows 7
April 22, 2011 7:29:28 PM

Can you give us the exact message? I have Win7 64 bit and C&C 3 works perfectly.
a b $ Windows 7
April 23, 2011 4:19:03 AM

@pw, its not true. i have ran all the c'n'c games except red alert 2 and another early 1 in win7 64bit ulitmate.
i not long ago got rid of tiberiam wars and kains wrath. they both work flawlessley on 64bit.
Related resources
April 23, 2011 5:40:51 AM

hmm ..ill try again and let you know ..it seemed suspicious to me ..
a b $ Windows 7
April 23, 2011 7:41:55 AM

often when a game has been corrupted it will say this game is not a valid 64bit application.
if your windows installer is out of date you can get this app isnt supported in 64bit also.
http://www.microsoft.com/downloads/en/details.aspx?Fami... so try these updates and see if it fixes your problem.
August 11, 2011 5:49:02 AM

my c&c 3 stops working after i build a power plant
a b $ Windows 7
August 11, 2011 8:39:17 AM

thats sounds like a game crash caused by a corrupt file... i guess it happens every time you make the plant.. if so then it could be a bad sector on the disk. a scratch on your dvd... theres little you can do about that 1 apart from get another copy.
a b $ Windows 7
August 11, 2011 1:37:04 PM

clarkb said:
my c&c 3 stops working after i build a power plant



Could also be copy protection.... In RA2, everything exploded 1 minute into the game if you tried playing with a non-legit version.
!