Sign in with
Sign up | Sign in
Your question

HTPC graphics (vsync?) glitch... FIXED!

Last response: in Video Games
Share
April 28, 2011 5:46:02 AM

I've exhausted my patience and ability trying to fix this so I thought I would turn to the wonderful community here. I have used Tom's articles for lots of computer maintenance/build projects including building my current HTPC.

It's hard to describe the glitch. It causes many 3D games to look extra blocky - almost as if they are un-anti-aliased. This is independent of the resolution or any AA settings. The bizarre thing is (hopefully this is diagnostic!) that if I take a screenshot (like, to show you the glitch instead of poorly describing it) the screenshot looks beautifully smooth and aliased. So, many games (HL:2, Portal 1 and 2, Sanctum, Starcraft 2, etc.) look like hell and Steam overlay looks like hell but if I try a screenshot, the shot comes out with everything looking like it "should".

So I'm thinking Vsync, right? It's a HDTV monitor so maybe I need to Vsync it up. With Vsync forced on (nVidia control panel), I can fix this problem sometimes. With Source Engine games or Starcraft II, the game will start up looking bad but alt+tabbing back and forth fixes it. Running any game in windowed mode fixes the problem (but them I'm stuck in windowed mode).

UPDATE - FIXED. It seems to be an issue with the TV choosing the correct refresh rate for PC content. It seems to choose Windows content correctly but chooses poorly when any other program is running the display. This is why games work fine windowed but poorly full screen even at the same resolution and why sometimes vsync and alt+tabbing would fix it.

The Fix. In the nVidia control panel, go to "adjust desktop color settings" scroll down, beneath "digital vibrance and hue", you will see a setting that says, "content type reported to display" change it from "auto-select" to "desktop programs." Apply.

Source. http://forums.guru3d.com/showthread.php?p=3905754.


System:
AMD Phenom II x4
Hard drives in Raid0
Win 7 64-bit
8GB RAM
2x GeForce 9800 GT (current drivers)
Monitor is a Sony Bravia @ 1080p. HDMI connection

Help please. Much thanks.
April 28, 2011 6:35:30 AM

I thought the vsync in the nvidia control panel was only for the desktop and not for fullscreen. I thought full screen needed to have the vsync enabled on the game itself in the video options. That could be why printing screenshots look right since it would reactivate the desktop control panel.

Again, I could be totally wrong it is 2am.
m
0
l
April 28, 2011 6:56:58 AM

have you changed the screen rez in game? not every game will configure itself to the monitor...
m
0
l
Related resources
April 28, 2011 12:26:32 PM

If you are overclocking, this could be a cause as well. Configure the games' settings in the games themselves, as well as in the NVidia control panel, and see if that makes a difference!
m
0
l
April 28, 2011 2:43:37 PM

You can't actually force a resolution through nVidia CP so I have to change the rez in game. It doesn't seem to make any difference whether or not the other (vSync, etc) settings are in game or through nVidia CP. I've tried it both ways. Changing resolution in game does sometimes fix the problem with Source games or SCII but I think this is only because it forces the game to refresh - same fix as alt+tabbing out and back. This does absolutely nothing for other games.

I am not overclocking. :) 

Thanks for replies.
m
0
l
April 28, 2011 2:50:19 PM

crewton said:
I thought the vsync in the nvidia control panel was only for the desktop and not for fullscreen. I thought full screen needed to have the vsync enabled on the game itself in the video options. That could be why printing screenshots look right since it would reactivate the desktop control panel.

Again, I could be totally wrong it is 2am.


You can use nVidia CP to force certain settings (such as vSync and AA) globally. At least: that's what it says it does. :)  Anyway, it makes no difference whether I force it in nVidia CP or in the game.
m
0
l
!