Assassin,s creed 2 shuttering

hello everyone i have:


cpu:amd athlon x2 x250
gpu:ati readon hd 5770
Ram:2gb ddr3
HDD:500 seagate hdd

i have the following problem i played assassin,s creed without any shuttering or hitching it only hitched in a few areas but with assassin,s creed 2 it shutters when i,m walking or running after every 15 seconds i have turned of anti alliasing and use 1024p as my resolution 1280x1024

i fought that the cpu cant keep up with the gpu so i turned on vsync to lower the framerate what can i do to play this game shutter free? thank you
4 answers Last reply
More about assassin creed shuttering
  1. turn the eye candy off. and play at native rez of your monitor.
    if your still stuttering then try defragging.
    your cpu is stronger than an amd 6000+x2 so should manage decent frame rates as i sold my old 6000+x2 88gt to a m8 and he plays it no problems.
  2. ^+1
    Also, AC2 requires a good internet connection. If you have the minimum of 1mbps connection, then its okay.
  3. well 1280x1024 is as high as my monitor can go so i will try loweting the settings and defraging my HDD thanks you guys
  4. thegameking said:
    hello everyone i have:


    cpu:amd athlon x2 x250
    gpu:ati readon hd 5770
    Ram:2gb ddr3
    HDD:500 seagate hdd

    i have the following problem i played assassin,s creed without any shuttering or hitching it only hitched in a few areas but with assassin,s creed 2 it shutters when i,m walking or running after every 15 seconds i have turned of anti alliasing and use 1024p as my resolution 1280x1024

    i fought that the cpu cant keep up with the gpu so i turned on vsync to lower the framerate what can i do to play this game shutter free? thank you


    First, make sure your graphic card driver, game version, and direct x are up to date.

    Vsync can really be helpful sometimes but it can also hurt you. Because if your system struggles to hit the 60 FPS that most people's monitors refresh at it will start cutting your FPS in half which can be a dramatic performance hit. Vsync cures "screen tearing" so I would recommend turning Vsync off until we figure out whats going on.

    Stick with your native monitor resolution.
Ask a new question

Read More

PC gaming Video Games