Sign in with
Sign up | Sign in
Your question

KT133a DMA problem?

Tags:
  • Motherboards
  • DMA
Last response: in Motherboards
Share
Anonymous
a b V Motherboard
April 24, 2001 5:38:48 AM

Hi!

This is my first post (but I read THG a ton).

First of all, shame on you, SandMan for having DMA in your name! :)  I wondered why all my search results on this subject were from you.

I was about to buy a new A7V-133 motherboard. For my new job, I will eventually be working with some fairly exotic (as far as PC's go) sound hardware.

I just received a link to an article claiming boards with VIA's kt133a chipset have major problems with DMA conflicts. Here's a clip from that link (and the link itself):

VIA's Chipsets can have massive problems with DMA conflicts, which are very likely to cause system crashes and data losses.

http://www.au-ja.de/review-kt133a-1-en.html

I was wondering, was this true? If so, it is very very bad! As a programmer, data integrity is extremely important to me, and I will often be copying huge amounts of data. I also planned on having two hard drives, and like I said, the sound hardware that's likely to have a major need for reliable DMA. Furthermore, the thought of having to rebuild my system more than say once a year makes me cringe.

Could somebody let me know if this is legit, if there is any sure-fire way to fix it (I am/was planning on getting an Asus A7V-133 mobo), and will it actually fix any problems that might occur with other DMA hungry hardware? Thanks very much in advance!

I really like AMD's chips from a performance and design standpoint. The TBird just seems cleaner, whereas the P4 is a huge cluttered mess (or at least it seems to me) so I would rather not have to buy a P4 (not to mention I hate rambus, and have major issues with helping them survive any longer). Then again, I need to make a living here. I am wondering (if this problem is for real, at least) why Tom hasn't written an article on it. He jumped on Intel's case quick enough with the 1.13 P3 thing, but this sounds just as much if not more serious, even if it is VIA instead of AMD. Its not like I can run a TBird with an Intel mobo after all! :) 

Sorry for the rambling. Thanks for reading it though.

z

More about : kt133a dma problem

April 24, 2001 5:28:44 PM

Unbenounced to me previously (another reason to spend more time in the lab) our technicians found out about this about 3 weeks ago, and have been testing ever since.

The bad new is that the results reported on the above site are accurate and yes, this is an issue.

Yesterday we began testing the suggested bug fix manually, and actually had to follow the second suggested method to alleviate the problems on our Asus A7V133's.

NOTE: BIOS Revisions tested were 1.03, 1.04a, 1.04_02a and 1.04_02D on both Rev 1.02 and Rev 1.03 motherboards.

As soon as we get in a Rev 1.05 motherboard, we will test for the problems on it as well. We tried every variation of the Via drivers from 4.26 up, getting staggeringly different results.

Under Windows 2000, the problems were ESPECIALLY evident (lockups before the darn tests even start), versus on Windows 98 S/E where the problems were not AS evident. (Crashed usually 3 out of 100 runs).

We tested using SoundBlaster Live! Value and Live! 5.1, as well as with the Hercules Game Theater XP (Using the v4023 updated configuration from using the Version 2.0 download from the Hercules web site.)

One interesting note is that if we used an Adaptec 29160 SCSI controller, we obviously did not experience any of these problems, since we avoided the ATA-100 debacle completely using only traditional ATA33 devices on the two primary channels (I.E., CD-ROMs, CD-RW's, ZIP Drives, Etc...) We would GREATLY advise anyone doing audio or video editing, server work or heavy mathematical calculations in large data blocks to use a RAID 0+1 SCSI configuration anyway as not only is CONSIDERABLY (Woo-Hoo is it ever!) faster, but data integrity is MUCH higher. Obviously, we would also recommend using Registered DIMMs in this configuration as well. While it will cost you a clock cycle, data integrity is assured.

Additionally, we did not find the problems when using ATA-100 drives in a RAID 0 configuration on the two onboard promise ATA-100 RAID interfaces. (NOTE: We are investigating this further to determine exactly why that is, but we suspect it is from having a separate controller for DMA checking in the RAID configuration.)

Any other information that others have would be useful.

Thanks
Steve Benoit


Stable Technologies
'The way IT should be!'
Anonymous
a b V Motherboard
April 25, 2001 8:39:17 AM

Hi there,

As u may know (stable), I have an Asus A7V133 on which I used to have powering pb (resolved with an Enermax PS EG365-VP : $85 !!)

But with this board, I have, since the beginning in fact, another kind of pb which goeqs against what u've said.

I have an Adaptec AHA2940 to which are connected a HD (6Go), a CR writer (TEAC CDR55S) and a CD reader (Plextor). I also Have a ZIP250 // (recognize as SCSI drive under w98se, who knows why ?!). On the primary IDE, I have a Pioneer DVD reader, on the secondary a Maxtor 30Go hd.
All connections are ok, no irq or DMA conflict reported, no nothing but...

When I try transfering files (let's say at least 1MB !) from any drive (SCSI HD, ZIP //, DVD, CD scsi or IDE), the system just freezes !

I tried many patches, nothing worked. Updated Bios to latest release : no result. Removed my SB Live card : didn't change a thing (this WAS NOT an issue then !).

What I think now is Via chipset is garbage, unless somebody tells me how to fix this !

Nota : sent an e-mail to Via Support 4 days agos : no result. Their support stinks as much as their chipset !!!

zentrad
Related resources
Can't find your answer ? Ask !
April 25, 2001 8:55:46 AM

Actually, no.. That sounds like something completely different. Additionally, my comments were regarding using ONLY SCSI devices for HD access and nothing over ATA-33 on the IDE's resulted in us NOT seeing the DMA problems.

Your problem (sounds) like it could be:
a) A conflict between the ZIP drive SCSI driver and the Adaptec SCSI driver or sharing interrupts for SCSI between these devices in the miniport driver.
b) A conflict arising from having miniport drivers loaded before all devices were recognized with the latest individual drivers (we see this one often).
c) A misconfiguration of the SCSI devices (either device IDs for the CD drives in the wrong places or incorrectly sharing interrupt 7 for the SCSI controller)

With a SCSI configuration I usually say that we need to see it to fix it. The bottom line is that in today's world of interrupt sharing, device ID's and multiple drivers for IDE/SCSI/ATA-100 things can get very tricky.

One idea might be to disable the interrupt sharing miniport drivers in your system settings (under PCI Bus) and reboot your system to individually recognize the correct drivers for each device.

Before doing this I would remove your SCSI driver for the ZIP drive and physically disconnect it from IDE connector, then change your BIOS settings to NOT SHARE interrupt 7 which should be reserved for your PCI SCSI controller.

After the reboot, you should reboot 1 more time to make sure everything is recognized. Then go back in and re-enable interrupt sharing in the PCI Bus section. When you reboot, your system will once again re-recognize all of your devices. If successful, you should then be able to re-install your ZIP drive without any problems. Again, it should automatically recognize it when you reboot and assign it the proper interrupt to share.

Finally, before doing any of this, you should read this article on the Microsoft web site regarding your SCSI card.
http://support.microsoft.com/support/kb/articles/Q188/8...

I hope this helps.
Steve Benoit

Stable Technologies
'The way IT should be!'
Anonymous
a b V Motherboard
April 25, 2001 12:16:21 PM

Thanks stable,

But my additional question is : why do I have the same pb when transfering between 2 IDE drives (DVD-ROM (primary IDE) to IDE HD (secondary IDE)), when they have nohing to do with the SCSI controller ?

Thanks
zentrad
April 25, 2001 2:28:47 PM

I haven't seen the problem on my A7V133, but perhaps it's happened to me and I've not noticed (data corruption yet to be detected?). This is awful! There have to be a lot of people who are screwed now. VIA should do a recall and replace all the defective boards. Perhaps a class-action suit is warranted?
April 25, 2001 3:52:20 PM

As for the first question regarding the IDE issues, did you read the Microsoft link I enclosed? That should answer your questions. DRIVER CONFLICTS AND INCOMPATIBILITIES BETWEEN THE DEVICE AND WINDOWS. Thus, as the drives are part of your system, any transfer between ANY device could cause the system to freeze as indicated in the notice.

As for the second post, I'm not sure things are so serious that people should be jumping on the phone to call their lawyers. It appears as though the problem is "fixable", I think we're best to continue to debug the DMA problem and keep working with VIA to create an easier solution for consumers to implement (as well us we dealers). Hopefully, we can debug this to the point where we can simply implement a revised driver download.

Steve Benoit


Stable Technologies
'The way IT should be!'
April 25, 2001 5:46:04 PM

In the interim, until VIA gets this straightened out, would disabling the onboard IDE controller and adding a promise ata66/100 controller insure that this would not happen? In theory it seems that this should completely take care of the problem. You could even leave the primary onboard IDE controlller enabled and use it for your cd/dvd/cd-r devices all of which only use the ultra 2 mode.

A little bit of knowledge is a dangerous thing!
April 25, 2001 9:22:32 PM

Well, I wasn't serious about calling my lawyer. A more likely action from me would be to call ASUS and ask that they do something about this.

Working with VIA to solve the problem sounds great, but this has been out for two weeks now and the nature of the problem is very serious. Neither VIA nor ASUS has put up even so much as a warning on their sites as far as I can see. It's very frustrating because now even though I've not personally experienced a problem I'm operating my system in a constant state of fear that I will corrupt some valuable stuff (like a backup image) without knowing it.

I sure hope you're right that the problem is "fixable". I'm worried that the "fix" may take the form of reducing system performance or disabling some functionality of the board. If that's the best that can be done, I would like to see them own up to this and do a recall, like Intel did with the MTH issue and the Pentium math issue before that.

Still, thanks for the reassurance. It helps a lot to know that you guys at least are "on the case". I'll keep my fingers crossed and keep monitoring this and other forums for info.
Anonymous
a b V Motherboard
April 26, 2001 2:18:38 PM

Well, well, well...

Yesterday I tried a trick that I saw on this site in order to resolve my pb (http://www.au-ja.de/review-kt133a-1-en.html)

The thing is, it solved it a little bit (I managed to transfer about 6 files of 15Mo, one by one). However, during full CD file transfer (many files, big size), the thing frose again. I even tried the same very 6 files that worked, but altogether, and this time it froze.

Now, I'm fed up (unless someone has a miracle to propose), and tomorrow, I will go to my retailer's to have my mobo+CPU change to Intel system (Asus CUSL-2 or equivalent + PIII 900 or 1G). Maybe that will cost me some more bucks, but I will avoid psychiatric hospital.

By the way, I wrote two "strong" mails to Via to explain them how awful their KT133A is.

Has someone ever heard about pb with CUSL-2 ?

thanks pals
zentrad <:( 
April 26, 2001 4:22:21 PM

Supposedly, it only happens when the sblive is making sounds. I've gotten a few bad cdr's when I was playing deus ex, but that's a usb burner I was using. It didn't underrun, just produced bad disks.
Anonymous
a b V Motherboard
April 26, 2001 6:19:40 PM

Most all posts I've seen about the Asus CUSL series boards has been good. Sorry to hear you can't get your current system working. It's quite a wierd bug. My configuration including an A7V133 and SB Live suggests I should be having the worst of these problems yet I can't confirm any bad transfers. (And I transfered all kinds of data trying to see it.) I've only got one ATA100 capable hard drive, the other is ATA33 so maybe the transfers work reliably for me because they are going slow.
April 26, 2001 7:48:21 PM

Steve, this is obviously a minor issue relative to data integrity problems but did your technicians happen to notice if the fixes for the Via ATA100 problems fix the crackling sound problems with the Sound Blaster Live cards?
April 27, 2001 8:04:08 AM

I sent you question to the lab and this is what I got back.
-----------------
Yes. We've heard the 'crackling' sounds reported by the end-user. Found out that Interrupt sharing (9) was being used so we disabled it. Then reserved the interrupt in the BIOS and rebooted/re-recognized. Also found that the DOS drivers finally began working right again, something that we were talking about on monday as a problem, and that we've reported back to Creative/VIA as a problem using the suggested fix. Had some conflicts when going back into windows, so we re-enabled the interrupt sharing (4.29 final), rebooted, re-recognized, still crackling. Then reloaded the latest SB drivers, still crackling. After Jen jumped up and down cussing for like 20 minutes, we finally figured out the process. Should mention that Creative has provide zero feedback so far. Attitude seems to be pretty negative regarding the sharing of info. Tell the users that our via reps are saying that tech support is getting about 5000 emails a day now, so don't expect any direct feedback, just too many to deal with.

1) Assign & Reserve INT in BIOS for SBLIVE
2) Disable INT Sharing in Windows
3) Reload SBLIVE Latest Drivers & Patches
4) Apply VIA ATA-100 Debug Patch (Make sure end-user has Via 4.29)
6) Verify INT is exclusive
7) If necessary re-enable INT sharing (but not for SB or Video)
8) Reload (of all things) Latest Detonator drivers BUT NOT the Detonator drivers from Nvidia. The spec drivers don't always work with any particular OEM's cards. The latest drivers should come directly from the card manufacturer.

The trick was making sure that the SBLIVE card was not using a shared slot. If the slot shares with Video or USB, BOINK. For sure a real problem. Still had to do a video reload in every config so far. Don't understand this, as one should have nothing to do with the other. We have been doing traces on the video drivers and can only "assume" (yes, that dangerous word that you hate so much) that the 4-in-1 drivers don't bind to the correct drivers when doing 4-in-1 updates, instead they address whatever drivers were in place when you first installed and enabled INT sharing. Another major bug if you ask us. This is why disabling and then re-enabling seems to help as the drivers bind to the driver LOADED when you reshare INT, versus updating your drivers and having the 4-in-1 point to the wrong ones. Still working on it, but our primary attention right now is helping AMD and MSI with the K7Master & -S with the 6 Clock/4 DIMM situation. Hope to have it all worked out by tomorrow. We'll let you know if we get any further with the Via KT133a issues in the next few days. (Jen says if the sun comes out this weekend, she won't have the KT133A crew in here on 'Sunday')

P.S. Get feeback if you can, including DEBUG screenshots and we'll try to build the end-users' config in the lab if he/she can't make it work.

Co-op:AMD-TL4, Tom
END-TRANS
-----------------------------------

Hope this helps.
Steve Benoit

Stable Technologies
'The way IT should be!'
April 27, 2001 5:39:01 PM

Steve, thanks for quick and detailed response. It sounds like you have a real crack team of technicians. Please thank them for me for their hard work.

The problem system belongs to my friend and we'll give the suggestions a try as soon as possible. The system has a Radeon video card so I don't know if that will make a difference but at least the drivers can only come from one source.

I have a question. I've been supporting PCs for years but I never had to disable interupt sharing in Windows. I'm amazed that it is even possible with the Via chipset. How do I do this?

Thanks again.
Anonymous
a b V Motherboard
April 30, 2001 8:00:20 PM

Thanks for the replies (esp. Stable). Having been burned waiting for hardware fixes before, I have decided to order boards with Ali's chipset instead of Via's. Let's hope I can avoid this problem altogether without discovering any new ones!

Anybody have a system using this chipset? (ALi MAGiK1)

Thanks again

z
!