Sign in with
Sign up | Sign in
Your question

Need For Speed Shift Unleashed texture problems

Last response: in Video Games
Share
May 13, 2011 4:59:53 PM

I've been having texture problems and memory leaks for the PC version of need for speed shift unleashed. Sometimes the textures on the cars, and on the road, and in the sky, are all solid black.

I had this same problem with star wars the force unleashed.

Is there anything I can do to fix this? What might be causing this problem?
a b } Memory
May 13, 2011 6:30:10 PM

possibly a bad initial installation of direct x. try updating it with the web installer and the latest redist.

you gfx card may also be the problem. i dont have any issues with shift or shift 2. i have a 1 gig 5870 i guess it could be something to do with the crossfire you have... have you updated to 11.5? if so try downgrading to 11.2
m
0
l
May 13, 2011 7:08:37 PM

HEXiT said:
possibly a bad initial installation of direct x. try updating it with the web installer and the latest redist.

you gfx card may also be the problem. i dont have any issues with shift or shift 2. i have a 1 gig 5870 i guess it could be something to do with the crossfire you have... have you updated to 11.5? if so try downgrading to 11.2


I've got x2 HD 5870's (1GB) in CF. I think I'm using drivers 1.4 or something to that effect.

ATI's drivers are notorious for bugs and glitches.
m
0
l
Related resources
a b } Memory
May 13, 2011 8:46:18 PM

yeah i read your specs... i have a similar setup but i have no issues so i guess its down to the crossfire....
try disabling 1 card. the game runs perfectly well on 1@60+fps
m
0
l
May 13, 2011 10:27:16 PM

HEXiT said:
yeah i read your specs... i have a similar setup but i have no issues so i guess its down to the crossfire....
try disabling 1 card. the game runs perfectly well on 1@60+fps


I tried doing that, it didn't work.

I haven't tried the "fix" that someone said worked for them in this link.

http://www.gamefaqs.com/boards/604345-shift-2-unleashed...
m
0
l
a b } Memory
May 14, 2011 1:11:31 PM

ah rite i get you now. i had *** similar problem with deadspace it was down to 1 of the ccc panel settings.. i went from multi sampling to super sampling and i got blead out from the colours so much so i couldnt see anything when i fired certain weapons.

try resetting your ccc pannel back to defaults especialy the fsaa becuase when i cured this bug deadspace 2 i moved from msaa to fsaa
m
0
l
May 14, 2011 1:51:15 PM

HEXiT said:
ah rite i get you now. i had *** similar problem with deadspace it was down to 1 of the ccc panel settings.. i went from multi sampling to super sampling and i got blead out from the colours so much so i couldnt see anything when i fired certain weapons.

try resetting your ccc pannel back to defaults especialy the fsaa becuase when i cured this bug deadspace 2 i moved from msaa to fsaa


I tried using the fix in my previous post, and it worked 100%
m
0
l
a b } Memory
May 14, 2011 3:43:52 PM

cool. id like to know how its such an intermittent problem. as i don't have it and my system isnt much different from yours... also im using the 11.5 drivers. you may want to update them also...
m
0
l
May 14, 2011 4:15:12 PM

HEXiT said:
cool. id like to know how its such an intermittent problem. as i don't have it and my system isnt much different from yours... also im using the 11.5 drivers. you may want to update them also...


Whats the difference between 11.4 and 11.5?

Where do I go to download them?

I am not familiar with updating/installing drivers, could someone walk me through this perhaps?
m
0
l
a b } Memory
May 14, 2011 5:57:09 PM

just open your ccc panel make sure its on advanced then select the bottom button (information) and select software update. that will then open the download section on the amd site. select your setup info and it will send you to the download page you need.
m
0
l
!