Sign in with
Sign up | Sign in
Your question

Crysis running terrible on capable PC

Last response: in Video Games
Share
May 14, 2011 9:59:02 AM

I recently purchased the first Crysis on Steam (from the EA sale) but ever since jumping into game I've been getting terrible FPS rates. I usually stay on 30fps or below on medium settings with forced DX9 (AA completely disabled), I find this relatively strange, as I've heard of less powerful machines run the game far smoother than I do.

My specifications:
4GB Kingston DDR3
CPU – AMD Phenom II X6 1055T
GPU – Sapphire AMD Radeon 6870
OS – Windows 7 Professional 32Bit

I've tried several fixes/played around with the config files nothing seems to help. Please don't say 'just set it to low' as that doesn't help.
May 14, 2011 12:53:14 PM

your cpu may be the problem. crysis only uses 2 cores so if there not fast (3.0ghz+) you may struggle with framerates. try upping the settings to max with no fsaa. see if you get *** fps drop. if you dont its the cpu.
m
0
l
May 14, 2011 1:02:42 PM

HEXiT said:
your cpu may be the problem. crysis only uses 2 cores so if there not fast (3.0ghz+) you may struggle with framerates. try upping the settings to max with no fsaa. see if you get *** fps drop. if you dont its the cpu.


How would I turn FSAA off? AA is already completely disabled.
m
0
l
Related resources
May 14, 2011 6:00:17 PM

open your ccc panel select gaming/3d application settings.
just click the default button and click ok...
what ever you did to enable the forced dx9 mode. undo that.
m
0
l
May 15, 2011 8:28:38 PM

your processor is fine for crysis. i used to have problems with the steam version of crysis. I solved them by using ``verify integrity of game cache`` which checks for errors in the download and installation process. Right click on crysis in your games library, go to ``properties``, then ``local game files``.

also make sure your drivers are up to date and thatyour memory is not all being used up by background processes. also as hexit says just stick with dx10.
m
0
l
May 16, 2011 6:53:07 AM

Overclocked Toaster said:
your processor is fine for crysis. i used to have problems with the steam version of crysis. I solved them by using ``verify integrity of game cache`` which checks for errors in the download and installation process. Right click on crysis in your games library, go to ``properties``, then ``local game files``.

also make sure your drivers are up to date and thatyour memory is not all being used up by background processes. also as hexit says just stick with dx10.


I checked the integrity of game files yesterday, everything was fine - no improvement.

Quote:
open your ccc panel select gaming/3d application settings.
just click the default button and click ok...
what ever you did to enable the forced dx9 mode. undo that.


Doesn't make a difference. Perhaps my problem is that I'm on 32 bit system?
m
0
l
May 16, 2011 6:56:01 AM

Maybe your GPU clocks are stuck in 2d mode.
m
0
l
May 16, 2011 7:06:09 AM

Tamz_msc said:
Maybe your GPU clocks are stuck in 2d mode.



How would I go about checking that?
m
0
l
May 16, 2011 7:37:34 AM

Download and install GPU-Z, fire it up, then game for a while and take a look at the historical graph of your clock speeds and GPU usage. GPU-Z will show you min, max and average values.
m
0
l
May 18, 2011 11:07:43 AM

HEXiT said:
your cpu may be the problem. crysis only uses 2 cores so if there not fast (3.0ghz+) you may struggle with framerates. try upping the settings to max with no fsaa. see if you get *** fps drop. if you dont its the cpu.

i dont like to disagree with veterans, but this is complete BS. http://www.tomshardware.com/reviews/amd-phenom-ii-x6-10... <- at 1080p most cpu's perform similarly. i do agree 6 cores do not get used, but it is still fine for crysis. its more demanding on gpu than cpu. you have some other problem. enable tripple buffering and vsync and see what happens. I actually have this problem with crysis since switching from xp to win 7. I believe the cure may be in more ram and dx9 mode really helped me a lot. Upgrade to 8gb ram.
m
0
l
May 20, 2011 6:36:49 AM

ummm...shot in the dark, do you have any taxing programs running in the background?

To check open system configuration and check under the "services" and "startup" tabs

Those listed under services are background operations currently active or stopped

Those under startup are the ones set to automatically start when booting windows
m
0
l
May 21, 2011 12:36:52 AM

iam2thecrowe said:
i dont like to disagree with veterans, but this is complete BS. http://www.tomshardware.com/reviews/amd-phenom-ii-x6-10... <- at 1080p most cpu's perform similarly. i do agree 6 cores do not get used, but it is still fine for crysis. its more demanding on gpu than cpu. you have some other problem. enable tripple buffering and vsync and see what happens. I actually have this problem with crysis since switching from xp to win 7. I believe the cure may be in more ram and dx9 mode really helped me a lot. Upgrade to 8gb ram.


if you look at thoughs benches you will see although there is a marked difference in cpu clocks the results are very similar the reason being the game doesnt use the more cores efficently and that is my point. crysis preferes faster cpu's over cores. the reason i come to this conclusion is that i have played it myself on 3 differenc pc's an amd 4600x2 and amd6000 x2 and an i7 920
the 4600x2 complained a lot when run on an 88gt medium settings were to much.
the 6000x2 in the same basic pc ran the game much much better yet there was only 600 mhz in it.
i then ran it on the i7 920 and although it has 2 much more efficent cores it didnt really improve on the 6000x2 you would think that having 2 extra and much better cores wold increase performance noticably but on crysis it didnt i got an extra 3 fps.. yes the game is very gpu bound but even dropping the settings didnt really offload that much on to the cpu. so i came to the conclusion the game is as much cpu bound as it is gpu bound.
in the end im only going off my own experience yours may be different, and thats the beauty of toms. the wide ark of experiance, it may not always concur but its all usefull.
m
0
l
!