Sign in with
Sign up | Sign in
Your question

Witcher 2 running worse than it should

Last response: in Video Games
Share
May 21, 2011 7:15:56 PM

I've got 8 gigs of RAM, Intel i2500k 3.3Ghz processor overclocked to 3.7Ghz, running a GTX 460 768MB with the core clock up to 820. While the graphics card isn't the best at this point, I feel like it should be able to run this game reasonably well. However, even with all settings on Low, I get considerable stuttering and a playable but unacceptably low framerate.

I have the new beta Nvidia drivers, and did a clean install without the 3d drivers. Even on low my GPU usage is at 100% at all times (though temps are fine) and my CPU is running extremely cool, loads almost never exceeding 30%.

I'm at a loss as to what else to do. I know a patch is coming soon to smooth out performance issues a bit, but this is far more than "a bit" worse than my system should be doing. Anyone have any insight? Is there some tweak for this game I'm missing or should I just wait for the patch and hope it increase my performance by, well, a hell of a lot? Thanks in advance for any help.

More about : witcher running worse

May 21, 2011 8:30:43 PM

some people are having issues especially with nvidia cards. best you go to the witcher forums and ask as they will be able to point you in the rite direction of a fix.

also use the witches loader and select the auto detect. then save and dont change anything.
i tried other options and found adding more just crippled it. so im playing on default high. yours should be on default mid-high depending on rez.
m
0
l
May 21, 2011 8:35:59 PM

That's the problem: default settings put me at medium, but even if I manually choose all low settings performance improves literally not at all. I'll check out the witcher forums, I suppose, just making sure I wasn't overlooking something on the hardware side of things. The GPU being at 100% even on stone-dead lowest settings just doesn't sit right.
m
0
l
Related resources
May 25, 2011 2:11:21 PM

Sounds like the default is disabling one of the advanced options on medium, that you are manually selecting on low.

SLI time...:) 
m
0
l
May 26, 2011 11:27:03 PM

Yeah there has been alot of problems with the ndvidia cards on this game try not overclocking your gpu and try it then thing should smooth out for ya and give you better frame rates....I think but not positive it has to do with the shaders on the cards... if you lower the shader too you should notice a big difference
m
0
l
!