Sign in with
Sign up | Sign in
Your question

The witcher 2 running poorly

Last response: in Video Games
Share
May 22, 2011 3:40:08 AM

I have a amd 6870 at stock clocks, i recently bought the witcher 2 and its running like **** any suggestions on how to improve performance??

the rest of my specs are:

i5-2400
4gb ddr3 ram
and running on a native resolution of 1440x990 which isn't even a high res lol..

More about : witcher running poorly

May 22, 2011 8:01:20 AM

Makesure you have ubersampling turned off. You should be able to run it at high-ultra pretty smoothly on that card with ubersampling off. Ive got 2 5850's but crossfire is broken at the moment, and I get 30-40 fps at ultra, ubersampling off on 1920 x1080. Also turn off SSAO as well if you want even more fps
m
0
l
May 25, 2011 1:38:58 PM

huh? In the settings at start up.

More specifically; when you start the game, and it shows a menu with the Witcher Wolf face, in those setting it shows the generic low, medium, etc. Below that is a box that says 'Advanced'. Click that and go through the options. Now what sgs2008 said is you can have ultra preselected and then go turn off ubersampling. Which is wrong. I'd work the otherway if I were you. Click medium...how's it run? Exit out, click High and play again in the same area. Does it still run well? if not, look at the options that are enabled between Medium and High and unclick a few of them (or turn their selection down one).

I have a GTX580 and there are times when I can play it on ultra (every playable part) and i have low framerates (outdoor movie cutscenes and the animated cutscenes). My card SHOULD be able to play this fine at 1080p and somehow I still have a few problems too.
m
0
l
Related resources
May 29, 2011 6:57:42 AM

I just did the 1.1 patch and it has improved the frame rate quite a bit, you should try it to!
m
0
l
December 20, 2011 4:13:04 PM

joshyboy82 said:
huh? In the settings at start up.

More specifically; when you start the game, and it shows a menu with the Witcher Wolf face, in those setting it shows the generic low, medium, etc. Below that is a box that says 'Advanced'. Click that and go through the options. Now what sgs2008 said is you can have ultra preselected and then go turn off ubersampling. Which is wrong. I'd work the otherway if I were you. Click medium...how's it run? Exit out, click High and play again in the same area. Does it still run well? if not, look at the options that are enabled between Medium and High and unclick a few of them (or turn their selection down one).

I have a GTX580 and there are times when I can play it on ultra (every playable part) and i have low framerates (outdoor movie cutscenes and the animated cutscenes). My card SHOULD be able to play this fine at 1080p and somehow I still have a few problems too.



#
I had an 8800gt and it burned out -replaced it with a palit gtx560ti and its simply pathetic in comparison.
Graphics drop out - no rendering in places and never more than 2 seconds without jerky play.
New drivers - uptodate patches - clean install
and No I wont upgrade to windows 7 just on the offchance it will improve the performance of my card!
did you have any luck?
Even playing on minimum the results were tragic.
(palit gtx 560ti - amd 3000 dual core 4gb ram vista)
m
0
l
December 21, 2011 12:02:37 PM

TG003 said:
#
I had an 8800gt and it burned out -replaced it with a palit gtx560ti and its simply pathetic in comparison.
Graphics drop out - no rendering in places and never more than 2 seconds without jerky play.
New drivers - uptodate patches - clean install
and No I wont upgrade to windows 7 just on the offchance it will improve the performance of my card!
did you have any luck?
Even playing on minimum the results were tragic.
(palit gtx 560ti - amd 3000 dual core 4gb ram vista)


Did you follow the directions and turn off ubersampling and SSAO?

Edit: which CPU do you have? Could be a CPU bottleneck.

The 560ti is several times more powerful than the 8800GT, so I doubt the GPU is the issue.

Just curiously, why are you running Vista and refuse to jump to Win7?
m
0
l
!