Sign in with
Sign up | Sign in
Your question

Witcher 2.

Last response: in Video Games
Share
May 27, 2011 7:58:27 AM

Hello Everyone. i also just the Witcher 2. and i got all the grahic all on max. i havet patch it yet i just saw theres a new patch out but..

i wondering i dont konw if it me but i got this system on it

CPU: Q9450 QUARD CORE 2.66
GFX CARD: ASUS 570 GTX CARD
MOBO: EVGA 750 SLI
RAM: OCZ REAPERS X DDR2 @ 1066
PSU: CONSAIR 750 TX

MONITOR TV: SAMSUNG TV 8 SERIE 40B-8050

i dont know know if it my system that can't handle the wticher 2 or it just me but it feeel like that my system canit follow the game. or the tv have a slow respone.. i dont know..

so i was hoping you guys could help me figur out whats is kinda is wrong..

thanks you all for the help.

More about : witcher

May 27, 2011 8:45:03 AM

You should turn off Ubersampling that really strains the GPU. Play the game after that it should run fine. If it still slows down then turn off SSAO it should be fine after this. Also get the patch if you bought the retail version the patch helps alot.
May 27, 2011 8:54:30 AM

How much RAM do you have my friend? :) 
Related resources
May 27, 2011 9:20:36 AM

Following are my system specs:

I7 980x OC to 4.5ghz
GTX 580 SLI
6gb ram

Just turn off ubersampling your system will run this fine ;-)
May 27, 2011 11:20:13 AM

Nihilis said:
How much RAM do you have my friend? :) 


4 GB Ram bud :)  set to 1066 :) 
May 27, 2011 1:00:34 PM

you have a pretty capable machine, I didn't look at the monitor but I don't imagine it would have problems with having the game at 60 fps.

what are the game settings that you are using to play the game?
also, what are the settings in your nvidia control panel?
May 27, 2011 4:04:09 PM

use the advanced settings on the loader and select high settings.
the game will now run fine.
May 27, 2011 11:48:42 PM

I'm having the same problems, the game is playing ok on ultra with ubersampling off with the nvidia 275 beta drivers. Only problem is when I look at afterburner it says GPU 2 utilization is 0%. I tried the workaround where you paste the new value into nvidia Inspector, but that hasn't worked. Any thoughts, I'm around 20 fps in cutscenes and 40ish during gameplay.

!