Sign in with
Sign up | Sign in
Your question

I have liberty city game he is saying i require windows vista pack 1 & windo

Last response: in Video Games
Share
May 28, 2011 10:36:02 AM

i have liberty city game he is saying i require windows vista pack 1 & windows xp
May 28, 2011 11:20:08 AM

Machine specs would be nice.
m
0
l
May 28, 2011 2:16:43 PM

^+1, PC specs are to be provided.
m
0
l
!