Sign in with
Sign up | Sign in
Your question

Bad Company 2-Problems

Last response: in Video Games
Share
May 29, 2011 4:30:37 AM

I have a factory overclocked gtx 560 ti. I have the settings on all the way max and i get about 50-60 fps, but the game runs like crap :cry:  . I am constantly seeing black lines and huge black blotches all over the place. I think that with my cpu and gpu i should own this game. Can anyone tell me how to fix.

Thank You

More about : bad company problems

May 29, 2011 5:32:21 AM

What driver are you using? The most recent one gave me problems in bbc2.
m
0
l
May 29, 2011 7:38:32 AM

Drivers might be your problems here. Do you experience this any other games ? Do a clean installation of your drivers. Don't just update it.
m
0
l
Related resources
May 29, 2011 12:20:49 PM

im using the newest ones, not the new beta, i have done a clean driver sweep. which drivers would u recommend then
m
0
l
May 29, 2011 1:00:02 PM

Roll back to the next laetest drivers. Before your current.
m
0
l
May 29, 2011 5:45:17 PM

jtgolden1s said:
im using the newest ones, not the new beta, i have done a clean driver sweep. which drivers would u recommend then


I reinstalled and am currently using drivers 266.58.
m
0
l
May 30, 2011 12:00:04 AM

are you using msi arfterburner?
m
0
l
May 30, 2011 3:41:53 AM

no but i was told to turn my fan speed up on my gpu so i was going to use evga precision cuz i heard that afterburner can mess up bad company 2
m
0
l
May 30, 2011 4:25:35 AM

yeah thats why I asked there was another guy same problem he went to afterburner 2.0 and that solved his problems with crasshing and you can syill adjust your fans if need be....but I have never tried evga so that might help ya too
m
0
l
!