Sign in with
Sign up | Sign in
Your question

Assassins Creed - High End System, Poor Performance

Last response: in Video Games
Share
June 2, 2011 2:10:46 PM

Hey all,

So I recently took advantage of Steam's Ubisoft sale and purchased myself Assassins Creed 1 and 2. The game runs in quite frankly terrible performance of between 20-30 FPS in any built up area. Now as you might be saying this is 'playable', that is besides the point, the point is that I have a friend who has a system nowhere near as fast as mine, runs at the same settings, who gets a constant 50-60fps everywhere on max graphics.

For a game that was released over 3 years ago, this is just craphouse. My specs are as follows:

i7 960 @ 3.6GHZ
HD 6990 4GB
6GB RAM
MB ASUS SABRETOOTH X58
WINDOWS 7 64bit

I'm running limited background process, and running the latest NVIDIA drivers. I can max Crysis out and maintain a steady 60FPS, BC2 will net me with an average of about 60-80fps.

Surely something else is at work here.

Thanks,

JT
June 2, 2011 4:02:45 PM

Latest NVIDIA drivers ??
You mean the catalyst ?
Have you tried, alt- tabbing out of the game and setting the affinity to four cores ? Since this is AC 2 and AC1 you are talking about, AC 2 should run better.
m
0
l
June 2, 2011 5:01:09 PM

Wow, I can't believe I slipped that typo in there :p  Yeah, I mean Catalyst. I'll try the affinity work around. If not I might just grin and bare it - it is a console port after all.
m
0
l
Related resources
June 2, 2011 5:07:55 PM

I'm sorry to say I don't have any suggestions either than what Gman posted about the latest drivers, but I wanted to include my own experience with the game.

I don't have what anyone would call a high-end system, but I was able to play the game on max settings, with my fps never dropping below 50fps even in the built up areas. i5 750, XFX 5770, 4GB ram, etc... Not exactly a high-end system.

So with your setup (especially the 6990 you shouldn't be having that kind of trouble). I hope you find your answer.
m
0
l
June 2, 2011 9:15:16 PM

It's possible that AC may have problems with Crossfire, and doesn't like the dual GPU setup of your 6990 card. If possible, try to disable one of your card's GPUs and see if that helps performance.
m
0
l
June 3, 2011 1:21:39 AM

you may be able to use the renaming trick. rename the ac.exe to ut3.exe this will fool the gpu drivers into using special routines that were introduced to help unreal 3 to perform better. i have tried it with a few games with mixed results.
m
0
l
June 3, 2011 12:43:38 PM

Does that really work ? I have to try it out ! So its just UT3.exe ? or anything elese should be added ?
So does this work with AC Brotherhood ?
m
0
l
June 4, 2011 2:53:38 PM

brother hood should work as amd brought out beta drivers for it. but yes on some games it does work. crysis 2 for instance had fps issues. and on some systems, renaming it to ut3.exe worked. but not all sadly.
m
0
l
!