Alienware M17x R3 - Witcher 2 Won't Launch

Hello,

I'm wondering if anyone is having trouble getting Witcher 2 to run on their laptop? My specs are Intel Core i7 2820QM, GeForce GTX 460m, 8GB Ram.

I downloaded steam/witcher2 last night and have the most updated drivers (according to dell, I can't update to nvidia's site's drivers because of compatibility issues). The game launcher pops up just fine but when I click launch it just goes black then returns to desktop with no error or background process.

I've tried running as admin, running with "video card" (because of optimus), and reinstalling/restarting.

Anyone have any suggestions?
4 answers Last reply
More about alienware m17x witcher launch
  1. there should be no compatibility issues with nvidia drivers. unless dell are up to there old tricks of putting block ware on there o.s. installs.. (software that deliberately gives misleading messages about compatibility issues when there are none.)

    as for it not running make sure you have it set to run as admin on the games icon.
    if it doesnt work check that the games cache and files aren't corrupt.
  2. http://www.nvidia.com/object/notebook-win7-winvista-64bit-275.33-whql-driver.html

    Scroll down to the bottom of the supported products tab. Basically it says intel chipsets that support Hybrid Power technology aren't compatible with the latest drivers. So I guess I have to wait for Dell to update theirs. The error I get is "Compatible hardware not detected" or something to that extent.

    As for using "run as admin", I can't do it for Witcher 2 as there is no straight exe for it. You have to use the launcher. And using "run as admin" on the launcher produces no results.

    The game's files and cache are clean. I downloaded it the same way on my desktop and it works fine.

    I've done some thorough searching and can't seem to find anyone with similar problems on this set-up...makes me wonder if my laptop is defective.
  3. if you can disable hybrid turn it off (in bios preferably). if its not working you may be able to install the drivers. if it doesn't work then just boot into safe mode and system restore
  4. Alright I'll try that next. It's the only thing I haven't tried and I'm reading more and more that it very well could be a driver issue. Just sucks I have to jump through so many hoops just to install drivers...
Ask a new question

Read More

PC gaming Video Games