Sign in with
Sign up | Sign in
Your question

File Sharing Between Wired and Wireless Computers

Last response: in Wireless Networking
Share
December 4, 2004 6:30:17 PM

Archived from groups: alt.internet.wireless (More info?)

Hi, I was wondering if anyone here has had a similar problem and
worked through it.

I have a Belkin 802.11b wireless router, with 4 wired Ethernet ports
on the back. I have desktop computer wired into the router, while I
have a laptop computer that connects wirelessly. Both computers run
Windows XP Home, and can access the Internet great, but I haven't been
able to get file sharing to work 100%. The wired computer can view the
files of the laptop, but the laptop cannot view anything on the
desktop. Here's what I have tried:

Going to My Network Places, and clicking 'View workgroup computers'
(Both computers have the same workgroup name). When I do this from the
laptop, I get an error message saying that "You may not have
permission to use this resource" and "Windows cannot find the network
path".

Typing '\\Dell' in the address bar (Dell is the name of the wired
computer). This gets me another error message: "Windows cannot find
'\\Dell'

I believe that I have opened all the ports necessary (TCP 129 and 445,
UDP 137 and 138) in my firewalls.

Any help would be greatly appreciated. Thanks!
Anonymous
a b F Wireless
December 4, 2004 10:06:26 PM

Archived from groups: alt.internet.wireless (More info?)

"Douglas" wrote in message
> Hi, I was wondering if anyone here has had a similar problem and
> worked through it.
>
> I have a Belkin 802.11b wireless router, with 4 wired Ethernet ports
> on the back. I have desktop computer wired into the router, while I
> have a laptop computer that connects wirelessly. Both computers run
> Windows XP Home, and can access the Internet great, but I haven't been
> able to get file sharing to work 100%. The wired computer can view the
> files of the laptop, but the laptop cannot view anything on the
> desktop. Here's what I have tried:
>
> Going to My Network Places, and clicking 'View workgroup computers'
> (Both computers have the same workgroup name). When I do this from the
> laptop, I get an error message saying that "You may not have
> permission to use this resource" and "Windows cannot find the network
> path".
>
> Typing '\\Dell' in the address bar (Dell is the name of the wired
> computer). This gets me another error message: "Windows cannot find
> '\\Dell'
>
> I believe that I have opened all the ports necessary (TCP 129 and 445,
> UDP 137 and 138) in my firewalls.
>
> Any help would be greatly appreciated. Thanks!

What I have found that sometimes works when you dont know what else to do is
to:
Select a folder on your desktop and add it to sharing, you will then get
some windows that open to configure sharing.
Just tell it to share with the other PCs and wallllloh
it starts working.
Of course if it doesnt work then, make sure file and print sharing is
selected correctly in the adapter settings.
December 5, 2004 5:19:20 AM

Archived from groups: alt.internet.wireless (More info?)

"Airhead" <campbell@alliancecable.net> wrote in
news:41b25fc1$0$797$2c56edd9@news.cablerocket.com:

> "Douglas" wrote in message
>> Hi, I was wondering if anyone here has had a similar problem and
>> worked through it.
>>
>> I have a Belkin 802.11b wireless router, with 4 wired Ethernet ports
>> on the back. I have desktop computer wired into the router, while I
>> have a laptop computer that connects wirelessly. Both computers run
>> Windows XP Home, and can access the Internet great, but I haven't
>> been able to get file sharing to work 100%. The wired computer can
>> view the files of the laptop, but the laptop cannot view anything on
>> the desktop. Here's what I have tried:
>>
>> Going to My Network Places, and clicking 'View workgroup computers'
>> (Both computers have the same workgroup name). When I do this from
>> the laptop, I get an error message saying that "You may not have
>> permission to use this resource" and "Windows cannot find the network
>> path".
>>
>> Typing '\\Dell' in the address bar (Dell is the name of the wired
>> computer). This gets me another error message: "Windows cannot find
>> '\\Dell'
>>
>> I believe that I have opened all the ports necessary (TCP 129 and
>> 445, UDP 137 and 138) in my firewalls.
>>
>> Any help would be greatly appreciated. Thanks!
>
> What I have found that sometimes works when you dont know what else to
> do is to:
> Select a folder on your desktop and add it to sharing, you will then
> get some windows that open to configure sharing.
> Just tell it to share with the other PCs and wallllloh
> it starts working.
> Of course if it doesnt work then, make sure file and print sharing is
> selected correctly in the adapter settings.
>
Check the Windows firewall settings on the wired computer. Looks like a
firewall problem. If you are using Zone Zlarm, check that it recognizes the
network as a trusted zone.
Related resources
December 5, 2004 1:08:37 PM

Archived from groups: alt.internet.wireless (More info?)

Colin <nkm12345@yahoo.com> wrote in message news:<Ieusd.391353$a85.319924@fed1read04>...
> "Airhead" <campbell@alliancecable.net> wrote in
> news:41b25fc1$0$797$2c56edd9@news.cablerocket.com:
>
> > "Douglas" wrote in message
> >> Hi, I was wondering if anyone here has had a similar problem and
> >> worked through it.
> >>
> >> I have a Belkin 802.11b wireless router, with 4 wired Ethernet ports
> >> on the back. I have desktop computer wired into the router, while I
> >> have a laptop computer that connects wirelessly. Both computers run
> >> Windows XP Home, and can access the Internet great, but I haven't
> >> been able to get file sharing to work 100%. The wired computer can
> >> view the files of the laptop, but the laptop cannot view anything on
> >> the desktop. Here's what I have tried:
> >>
> >> Going to My Network Places, and clicking 'View workgroup computers'
> >> (Both computers have the same workgroup name). When I do this from
> >> the laptop, I get an error message saying that "You may not have
> >> permission to use this resource" and "Windows cannot find the network
> >> path".
> >>
> >> Typing '\\Dell' in the address bar (Dell is the name of the wired
> >> computer). This gets me another error message: "Windows cannot find
> >> '\\Dell'
> >>
> >> I believe that I have opened all the ports necessary (TCP 129 and
> >> 445, UDP 137 and 138) in my firewalls.
> >>
> >> Any help would be greatly appreciated. Thanks!
> >
> > What I have found that sometimes works when you dont know what else to
> > do is to:
> > Select a folder on your desktop and add it to sharing, you will then
> > get some windows that open to configure sharing.
> > Just tell it to share with the other PCs and wallllloh
> > it starts working.
> > Of course if it doesnt work then, make sure file and print sharing is
> > selected correctly in the adapter settings.

I tried your suggestion, but the configuration wizard didn't pop up,
probably because I had gone through it previously. On the subject of
the adapter settings:

I went to the Network Connection properties from the control panel,
and saw that "File and Printer Sharing for Microsoft Networks" was
checked on the laptop with a white background, but on the wired
computer it is checked with a grey background. Doesn't that usually
mean that some, but not all components have been installed. I tried to
find a way to install the other components, but I couldn't find one.
Could this be the problem?


> Check the Windows firewall settings on the wired computer. Looks like a
> firewall problem. If you are using Zone Zlarm, check that it recognizes the
> network as a trusted zone.

Thanks for the suggestion, but I had turned off all firewalls
temporarily.
Anonymous
a b F Wireless
December 5, 2004 9:49:03 PM

Archived from groups: alt.internet.wireless (More info?)

Douglas wrote:


> Any help would be greatly appreciated. Thanks!

If WEP is enabled on the wireless NIC, then you may have a problem
communicating wire and wireless due to the NIC protocol being used. If
Netbeui is the protocol, then un-install it off the NIC(s) on the machines.
You can use NWlink as the protocol on the NIC(s) or just leave Netbeui off
the NIC.

I run with the following on the NIC(s):

1) Client for MS Networks
2) F & P S for MS Networks
3) QoS Packet Scheduler
4) Internet Protocol (TCP/IP)

I use to run with NWlink but found that I didn't need it.

HTH

Duane :) 
Anonymous
a b F Wireless
December 9, 2004 6:34:45 PM

Archived from groups: alt.internet.wireless (More info?)

On 4 Dec 2004 15:30:17 -0800, doug1990@gmail.com (Douglas) wrote:

>Hi, I was wondering if anyone here has had a similar problem and
>worked through it.
>
>I have a Belkin 802.11b wireless router, with 4 wired Ethernet ports
>on the back. I have desktop computer wired into the router, while I
>have a laptop computer that connects wirelessly. Both computers run
>Windows XP Home, and can access the Internet great, but I haven't been
>able to get file sharing to work 100%. The wired computer can view the
>files of the laptop, but the laptop cannot view anything on the
>desktop. Here's what I have tried:
>
>Going to My Network Places, and clicking 'View workgroup computers'
>(Both computers have the same workgroup name). When I do this from the
>laptop, I get an error message saying that "You may not have
>permission to use this resource" and "Windows cannot find the network
>path".
>
>Typing '\\Dell' in the address bar (Dell is the name of the wired
>computer). This gets me another error message: "Windows cannot find
>'\\Dell'
>
>I believe that I have opened all the ports necessary (TCP 129 and 445,
>UDP 137 and 138) in my firewalls.
>
>Any help would be greatly appreciated. Thanks!

You also need TCP port 139.

Make sure "Use Netbios over TCP" and "Register this connection's
addresses in DNS" are both enabled on your connections. The settings
are per connection, so if your wireless uses USB or PCMCIA you'll need
to check the settings individually for each slot or port you want to
be able to use.

Make sure the computer browser service is running on all machines. It
is sensitive to firewall settings and shuts itself off if it doesn't
like something.


I have a similar problem ... I completely lost the ability to browse
my network when I installed SP2 on my WinXP machines (I have 3 running
XPpro, 1 XPhome and 1 Win2K - 2 are wired and 3 are wireless). I can
connect the shares using IP addresses and can resolve names statically
by editing the hosts file on each machine but dynamic name resolution
no longer works on any of them.

I have no answer to it as yet.

George
--
for email reply remove "/" from address
!