Sign in with
Sign up | Sign in
Your question

Software Raid 5 recovery ?

Last response: in Windows XP
Share
March 25, 2005 12:20:00 PM

Hi,

I have a P5AD2-E Asus motherboard with 5 200Gb hard disks.
I installed XP Pro Media Center on the first HD, and used the remaining 4 HDs for a software RAID 5 solution, as per Tom's Hardware article on how to enable software RAID 5 on XP Pro.

Everything was running smoothly. Then, I decided to re-install XP Pro MC, because I was having problems making my TV tuners work on it.

I re-applied the procedure to enable software RAID 5 after XP finished re-installing (e.g. modified the 3 files...).

Now, when I go in Disk Management, all I see is my first HD, and my CD-ROM. The RAID array is nowhere to be found.

I'm hoping that there's a way to "reconnect" XP to the RAID array... The drives haven't been touched, obviously...

Can anyone help ?

More about : software raid recovery

March 25, 2005 6:36:16 PM

No, they're not... Nothing has changed in the BIOS, I was expecting them to be there (but not really expecting that they would work without some intervention)...
Related resources
March 26, 2005 2:12:07 AM

Do they even show up in the bios?
Could you see the hard drives or the array during windows setup?
I'd really never trust a completely software raid, much less one in windows. It "should" have been there after the reinstall but it really doesn't surprise me that it isn't. Hopefully you didn't have anything extremely important on there.

<A HREF="http://www.folken.net/myrig.htm" target="_new">My precious...</A>
March 26, 2005 10:23:13 AM

Now that you mention it, no, the drives in the array were not visible during the windows re-install... As for the BIOS, I haven't checked yet...

What could explain the disappearance of the drives in Windows ?
March 26, 2005 4:03:50 PM

If there arn't any missing drivers in device manager (meaning the controller they are on is installed) the array (or individual discs) "should" at least show up in disk management.

<A HREF="http://www.folken.net/myrig.htm" target="_new">My precious...</A>
March 29, 2005 1:29:45 PM

I checked, and the drives are there in the BIOS. In disk management, all I see is the first drive (C: in XP), and the DVD-ROM (D:) . No trace of the 4 other HDs.

What I did notice though is this : in Windows Explorer, I have an A: and a B:, seen as floppies by XP, but I don't have a floppy installed on this system :-)

Both are displayed as "RAW" file system. I'm guessing XP is mixed up somehow...

Now, why I have 2 floppies displayed when I really have 4 missing hard-drives really boggles me...

Any suggestions ?
March 29, 2005 3:28:25 PM

You can make 2 floppies show up by enabling floppy B in the bios. It will be on the same page that shows your hard drive information. It will have something like
Floppy A: 1.44mb 3.5"
Floppy B: 1.44mb 3.5" (set it to disabled)

I'm sorta lost on the hard drives though :(  That is extra crazy. Check over everything that you needed to do to enable raid5 again just to make sure.

<A HREF="http://www.folken.net/myrig.htm" target="_new">My precious...</A>
March 30, 2005 2:03:07 AM

Well, I tried running fdisk to see if the drives were REALLY accessible from ANY piece of software besides my system's BIOS, and yes, all drives are reachable in FDISK. They all had a special type of partition on them (which was created by the software RAID setup I imagine).

I proceeded to delete the partitions, thinking that it would now make them accessible in Windows...

NOT !

Since I had no partitions anymore (and thus no hope of recovering the data), I decided to go for a complete reinstall (again) of XP.

Still, the XP setup doesn't show me drives 2 to 5 in the screen where it asks to choose a partition to install itself on...

It looks as though the RAID set creation rendered the disks unreadable by Windows (somehow).

Any ideas how to fix this ?

Thanks.
March 30, 2005 7:33:23 PM

If those drives are seen in fdisk (from a boot floppy I assume) and you repartitioned/formatted them from fdisk there is absolutely no logical reason why they wouldn't show up in windows. If fdisk on a boot floppy can see it ANYTHING can see it, lol.
How about just for the heck of it unplug all the drives, boot to windows, shut down, plug them all back into different places, and boot back to windows (making sure all the master/slave is correct of course if they are ide drives)

<A HREF="http://www.folken.net/myrig.htm" target="_new">My precious...</A>
March 31, 2005 1:26:36 PM

Thanks for your help folken, problem is resolved.

I don't know if it was the order in which I reinstalled the drivers for all my hardware, but with another complete reinstall (in which Windows did NOT give me the option of installing on drives 2-5), as soon as I installed the Silicon Image RAID controller driver, the drives appeared in Disk Management.

Of course, the device was shown to be WORKING in my previous install in device manager, but hey, it's Windows...

So, I'm back to re-creating my content :-)
March 31, 2005 2:31:48 PM

ahhh... that makes perfect sense now. I didn't realize they were on a separate controller. I don't know why but this whole time I've had it in my head that they were ide drives on the primary/secondary ide controller or a chipset raid controller. In those cases you wouldn't need aditional drivers to see them.
That is bizzar that fdisk saw them though, or did you run that while in windows?

<A HREF="http://www.folken.net/myrig.htm" target="_new">My precious...</A>
March 31, 2005 2:38:27 PM

No, I ran FDISK from the Asus Boot CD (FreeDOS)...

I also ran Seagate Seatools and Seagate Disk Wizard, both from Boot CDs, and they also saw the drives...

The thing is that the P5AD2-E Premium BIOS lets you install the RAID controller in SATA mode (instead of RAID mode), which (according to either the docs or some posts I have seen, don't remember) makes the SATA drives supposedly appear as regular IDE drives.

Seems to be the case for FDISK, but not for XP until some driver is installed...

Weird...
!