Morrowind graphics trouble - HELP!!

Archived from groups: alt.games.elder-scrolls (More info?)

Hello

I have recently bought a new video card, the GeForce 5600 Asylum.
Ever since I installed it, my graphics are a jerky in Morrowind. Its
like when I turn around it loads the scenery very slowly, the turn of my
character is very jerky. After I turn 360 degree, the game is smooth
and fast again, until next scenery load comes along.

Also, switching to and from the inventory screen takes long (it
used to be almost instantenous, but now it takes about 3 sec or so).
Equipping is also slow, as is opening containers, trading, and entering
new areas.

It drives me NUTS!!

The game run great with my old GeForce4 card. I was hoping the
faster card will improve things, but now I can hardly play the game
anymore.

Anybody can help? Please...

--
______________________
- Bantari
11 answers Last reply
More about morrowind graphics trouble help
  1. Archived from groups: alt.games.elder-scrolls (More info?)

    "Bantari" <bantari@mynet.com> wrote in message
    news:MPG.1b4d0f2e325b877f989754@news.qualcomm.com...
    >
    > Hello
    >
    > I have recently bought a new video card, the GeForce 5600 Asylum.
    > Ever since I installed it, my graphics are a jerky in Morrowind. Its
    > like when I turn around it loads the scenery very slowly, the turn of my
    > character is very jerky. After I turn 360 degree, the game is smooth
    > and fast again, until next scenery load comes along.
    >
    > Also, switching to and from the inventory screen takes long (it
    > used to be almost instantenous, but now it takes about 3 sec or so).
    > Equipping is also slow, as is opening containers, trading, and entering
    > new areas.
    >
    > It drives me NUTS!!
    >
    > The game run great with my old GeForce4 card. I was hoping the
    > faster card will improve things, but now I can hardly play the game
    > anymore.
    >
    > Anybody can help? Please...

    I had this problem with my old machine that had an nVidia card. I had to
    update the graphics drivers so I could play KotOR, and doing this blew
    Morrowind's performance away exactly as you describe. Unfortunately, the
    only way I could get Morrowind back up to snuff was to downgrade to the
    previous driver versions. So that might be what you have to do. Hopefully
    the older drivers will work with your new card.

    Note that the official Morrowind forums contain several posts about this
    problem. Now I have an ATI card and I'm able to play with the latest
    drivers with no performance degradation.
  2. Archived from groups: alt.games.elder-scrolls (More info?)

    In article <MPG.1b4d0f2e325b877f989754@news.qualcomm.com>,
    Bantari <bantari@mynet.com> wrote:
    >
    > I have recently bought a new video card, the GeForce 5600 Asylum.
    >Ever since I installed it, my graphics are a jerky in Morrowind. Its
    >like when I turn around it loads the scenery very slowly, the turn of my
    >character is very jerky. After I turn 360 degree, the game is smooth
    >and fast again, until next scenery load comes along.

    My only suggestion would be to turn off real time shadowing in the
    Morrowind graphics options.

    --
    Juris Baidins
    baidins@udel.edu
  3. Archived from groups: alt.games.elder-scrolls (More info?)

    [Fri, 2 Jul 2004 13:39:42 +0000 (UTC)]
    --- Juris Baidins wrote:
    > In article <MPG.1b4d0f2e325b877f989754@news.qualcomm.com>,
    > Bantari <bantari@mynet.com> wrote:
    > >
    > > I have recently bought a new video card, the GeForce 5600 Asylum.
    > >Ever since I installed it, my graphics are a jerky in Morrowind. Its
    > >like when I turn around it loads the scenery very slowly, the turn of my
    > >character is very jerky. After I turn 360 degree, the game is smooth
    > >and fast again, until next scenery load comes along.
    >
    > My only suggestion would be to turn off real time shadowing in the
    > Morrowind graphics options.

    This was the first thing I tried.
    I also tried minimizing the "view distance" option.

    Both helped a little, but not much.

    --
    ______________________
    - Bantari
  4. Archived from groups: alt.games.elder-scrolls (More info?)

    >Subject: Morrowind graphics trouble - HELP!!
    >From: Bantari bantari@mynet.com
    >Date: 01.07.04 03:56 (MEZ) - Mitteleurop. Sommerzeit
    >Message-id: <MPG.1b4d0f2e325b877f989754@news.qualcomm.com>
    >
    >
    >Hello
    >
    > I have recently bought a new video card, the GeForce 5600 Asylum.
    >Ever since I installed it, my graphics are a jerky in Morrowind. Its
    >like when I turn around it loads the scenery very slowly, the turn of my
    >character is very jerky. After I turn 360 degree, the game is smooth
    >and fast again, until next scenery load comes along.
    >
    > Also, switching to and from the inventory screen takes long (it
    >used to be almost instantenous, but now it takes about 3 sec or so).
    >Equipping is also slow, as is opening containers, trading, and entering
    >new areas.
    >
    > It drives me NUTS!!
    >
    > The game run great with my old GeForce4 card. I was hoping the
    >faster card will improve things, but now I can hardly play the game
    >anymore.
    >
    > Anybody can help? Please...
    >
    >--
    >______________________
    >- Bantari
    >
    >
    >

    You need some Ram too (I use 512 MB) and a fast Graphic-Card (I've buy some
    Times ago a GeForce MX440 8x AGP 128 MB, and this damn Thing can't show
    Shadders).
    Now I use a ATI Excalibur Radeon 9200 128 MB and have no Prob at my AMD 2400+).
    Sometimes it need much Time to open a Inventory, if it is very full.
  5. Archived from groups: alt.games.elder-scrolls (More info?)

    Bantari wrote:

    > [Fri, 2 Jul 2004 13:39:42 +0000 (UTC)]
    > --- Juris Baidins wrote:
    >
    >>In article <MPG.1b4d0f2e325b877f989754@news.qualcomm.com>,
    >>Bantari <bantari@mynet.com> wrote:
    >>
    >>> I have recently bought a new video card, the GeForce 5600 Asylum.
    >>>Ever since I installed it, my graphics are a jerky in Morrowind. Its
    >>>like when I turn around it loads the scenery very slowly, the turn of my
    >>>character is very jerky. After I turn 360 degree, the game is smooth
    >>>and fast again, until next scenery load comes along.
    >>
    >>My only suggestion would be to turn off real time shadowing in the
    >>Morrowind graphics options.
    >
    >
    > This was the first thing I tried.
    > I also tried minimizing the "view distance" option.
    >
    > Both helped a little, but not much.
    >

    Recently, I've had similar trouble with some parts of Morrowind. Turn on
    the framerate display with the ini file.

    For me, I found that the herky-jerkiness was caused by the video card
    performing too well!!! Anyplace where the frame rate hits above 200 gets
    sluggish. You may also need to up your max framerate to 480 or something.

    It's a guess. Good luck.

    CH
  6. Archived from groups: alt.games.elder-scrolls (More info?)

    [Thu, 08 Jul 2004 09:09:05 -0400]
    --- Clawhound wrote:
    > Bantari wrote:
    >
    > > [Fri, 2 Jul 2004 13:39:42 +0000 (UTC)]
    > > --- Juris Baidins wrote:
    > >
    > >>In article <MPG.1b4d0f2e325b877f989754@news.qualcomm.com>,
    > >>Bantari <bantari@mynet.com> wrote:
    > >>
    > >>> I have recently bought a new video card, the GeForce 5600 Asylum.
    > >>>Ever since I installed it, my graphics are a jerky in Morrowind. Its
    > >>>like when I turn around it loads the scenery very slowly, the turn of my
    > >>>character is very jerky. After I turn 360 degree, the game is smooth
    > >>>and fast again, until next scenery load comes along.
    > >>
    > >>My only suggestion would be to turn off real time shadowing in the
    > >>Morrowind graphics options.
    > >
    > >
    > > This was the first thing I tried.
    > > I also tried minimizing the "view distance" option.
    > >
    > > Both helped a little, but not much.
    > >
    >
    > Recently, I've had similar trouble with some parts of Morrowind. Turn on
    > the framerate display with the ini file.

    How do I do that?
    Is that just the
    Show FPS = 0
    Max FPS = 240
    lines? What do I test them to? 1 and 480?

    I also have some WaterFPS values in the ini file.
    I am reluctant to just play with that without knowing what I am
    doing.

    > For me, I found that the herky-jerkiness was caused by the video card
    > performing too well!!!

    This might be it then. Does turning on the framerate in the ini
    file fix the problem?

    > Anyplace where the frame rate hits above 200 gets
    > sluggish. You may also need to up your max framerate to 480 or something.
    >
    > It's a guess. Good luck.

    Thanks! :)

    --
    ______________________
    - Bantari
  7. Archived from groups: alt.games.elder-scrolls (More info?)

    On Thu, 8 Jul 2004 13:34:00 -0700, Bantari <bantari@mynet.com> wrote:

    >[Thu, 08 Jul 2004 09:09:05 -0400]
    >--- Clawhound wrote:
    >
    > How do I do that?
    > Is that just the
    > Show FPS = 0
    > Max FPS = 240
    > lines? What do I test them to? 1 and 480?

    To turn on the FPS display, change the Show FPS value to 1.

    > This might be it then. Does turning on the framerate in the ini
    >file fix the problem?

    No, but it lets you get an idea of what the problem might be.

    >> Anyplace where the frame rate hits above 200 gets
    >> sluggish. You may also need to up your max framerate to 480 or something.
    >>
    >> It's a guess. Good luck.

    Increasing your max framerate will usually hurt performance, as your
    graphics card is wasting cycles showing extra frames that your monitor
    isn't capable of displaying to you. Check your monitor's refresh rate -
    it will commonly be in the range 60-85 Hz. Then set the Max FPS to that
    value, as anything higher cannot physically be displayed.

    --
    Greg Johnson
    Give your child mental blocks for Christmas.
  8. Archived from groups: alt.games.elder-scrolls (More info?)

    [Fri, 09 Jul 2004 07:07:36 +1000]
    --- Greg Johnson wrote:
    > On Thu, 8 Jul 2004 13:34:00 -0700, Bantari <bantari@mynet.com> wrote:
    >
    > >[Thu, 08 Jul 2004 09:09:05 -0400]
    > >--- Clawhound wrote:
    > >
    > > How do I do that?
    > > Is that just the
    > > Show FPS = 0
    > > Max FPS = 240
    > > lines? What do I test them to? 1 and 480?
    >
    > To turn on the FPS display, change the Show FPS value to 1.
    >
    > > This might be it then. Does turning on the framerate in the ini
    > >file fix the problem?
    >
    > No, but it lets you get an idea of what the problem might be.
    >
    > >> Anyplace where the frame rate hits above 200 gets
    > >> sluggish. You may also need to up your max framerate to 480 or something.
    > >>
    > >> It's a guess. Good luck.
    >
    > Increasing your max framerate will usually hurt performance, as your
    > graphics card is wasting cycles showing extra frames that your monitor
    > isn't capable of displaying to you. Check your monitor's refresh rate -
    > it will commonly be in the range 60-85 Hz. Then set the Max FPS to that
    > value, as anything higher cannot physically be displayed.

    Thanks. I will try all that this weekend. Hope it works. :)

    --
    ______________________
    - Bantari
  9. Archived from groups: alt.games.elder-scrolls (More info?)

    Greg Johnson wrote:

    >
    >
    > Increasing your max framerate will usually hurt performance, as your
    > graphics card is wasting cycles showing extra frames that your monitor
    > isn't capable of displaying to you. Check your monitor's refresh rate -
    > it will commonly be in the range 60-85 Hz. Then set the Max FPS to that
    > value, as anything higher cannot physically be displayed.
    >

    I had done this and it KILLED my performance. Every time the game pegged
    the display rate, the it went sluggish and controls went weird.

    I've been designing some rooms lately. When they are empty, I max out
    the framerate and the area is a bear to move in. Once I populate it with
    enough cruft, the framerates drop and moving becomes normal.

    For more on the game, go to www.gamefaqs.com and find Elder Scrolls:
    Morrowind. Look for the faq on Technical Tweaking.

    CH
  10. Archived from groups: alt.games.elder-scrolls (More info?)

    On Fri, 09 Jul 2004 10:13:02 -0400, Clawhound <none@nowhere.com> wrote:

    >Greg Johnson wrote:

    >> Increasing your max framerate will usually hurt performance, as your
    >> graphics card is wasting cycles showing extra frames that your monitor
    >> isn't capable of displaying to you. Check your monitor's refresh rate -
    >> it will commonly be in the range 60-85 Hz. Then set the Max FPS to that
    >> value, as anything higher cannot physically be displayed.

    >I had done this and it KILLED my performance. Every time the game pegged
    >the display rate, the it went sluggish and controls went weird.

    That's very peculiar, as I've had my maximum set to 100 (same as my
    refresh rate) for a long time, and it's never given trouble when it hit
    the top. What sort of graphics card and display are you using?

    >I've been designing some rooms lately. When they are empty, I max out
    >the framerate and the area is a bear to move in. Once I populate it with
    >enough cruft, the framerates drop and moving becomes normal.

    I believe the probable cause is that your max framerate is set so high
    that the game engine is wasting too much time on rendering frames, and
    doesn't have enough time for responding to your commands. Your graphics
    card can render an empty room much faster than your CPU can give it the
    information about what to show. Once your field of view contains enough
    complex objects, the graphics card becomes the limiting factor and you
    have more CPU time free for normal use.
    --
    Greg Johnson
    Give your child mental blocks for Christmas.
  11. Archived from groups: alt.games.elder-scrolls (More info?)

    "Greg Johnson" <gsj@labyrinth.net.au> skrev i en meddelelse
    news:3obve05k841n5gc8njle2r3lk5ol0gbnp8@4ax.com...
    > On Fri, 09 Jul 2004 10:13:02 -0400, Clawhound <none@nowhere.com> wrote:
    >
    > >Greg Johnson wrote:
    >
    > >> Increasing your max framerate will usually hurt performance, as your
    > >> graphics card is wasting cycles showing extra frames that your
    monitor
    > >> isn't capable of displaying to you. Check your monitor's refresh
    rate -
    > >> it will commonly be in the range 60-85 Hz. Then set the Max FPS to
    that
    > >> value, as anything higher cannot physically be displayed.
    >
    > >I had done this and it KILLED my performance. Every time the game
    pegged
    > >the display rate, the it went sluggish and controls went weird.
    >
    > That's very peculiar, as I've had my maximum set to 100 (same as my
    > refresh rate) for a long time, and it's never given trouble when it hit
    > the top. What sort of graphics card and display are you using?
    >
    > >I've been designing some rooms lately. When they are empty, I max out
    > >the framerate and the area is a bear to move in. Once I populate it
    with
    > >enough cruft, the framerates drop and moving becomes normal.
    >
    > I believe the probable cause is that your max framerate is set so high
    > that the game engine is wasting too much time on rendering frames, and
    > doesn't have enough time for responding to your commands. Your graphics
    > card can render an empty room much faster than your CPU can give it the
    > information about what to show. Once your field of view contains enough
    > complex objects, the graphics card becomes the limiting factor and you
    > have more CPU time free for normal use.
    > --
    > Greg Johnson
    > Give your child mental blocks for Christmas.

    someone on the daggerfall forum once suggested
    in this case to look down when you just wanted to
    traverse a town and didn't have any business
    except to get to a location in a hurry. That way
    the cpu didn't needed to load any of the town
    maps almost, and the ground tile map was more
    or less a standard file, which already was in the
    cache, and the same, no matter which town

    merlin
Ask a new question

Read More

Games Graphics Video Games