Sign in with
Sign up | Sign in
Your question
Closed

Fallout 3 Windows 7 64bit quad core random freezing???

Last response: in Video Games
Share
June 29, 2011 4:19:15 PM

Hey to all the Fallout 3 PC fans out there :hello:  , I have a problem with this game and require some help please. :bounce: 

So I have recently purchased the Fallout 3 GOTY edition through steam. When I open up the game everything seems fine and i can play it on fullest graphics. After about 5-7 minutes of playtime the game just randomly freezes. I then have to kill it with task manager. I also heard that Fallout 3 can't handle QUAD CORE PROCESSORS :o  since I have a quad core cpu I think that may be the fault but isn't there a fix for this? I can't progress in the game it freezes every damn 5 minutes and then I have to restart the game. I am also running steam as an administrator. People reckon that would fix it but it didn't.

My PC's specs are:
Intel Core i5 750 2,67GHz quad core cpu
Asus Nvidia GTX 470
2x2gb 1333MHz ddr3 corsair ram
Asus p7p55d-le mobo

Thanks, hope you can help me with this. :D 
June 29, 2011 5:53:31 PM

I've play it on my Q9450 quad core CPU without too many issues. It does crash from time to time, but it's likely due to the GameBryo engine. However, I played it in WinXP and not the GOTY version, but the original version with all the DLC installed. It may crash once every few hours. The 1st ever crash I experience probably didn't happen until 3 or 4 weeks into playing the game.

I have tested FO3 on Win 7 6-bit for about 2 hours with no issues, but it was with an E6600 dual core CPU.

The game is just a bit buggy.
June 29, 2011 5:54:30 PM

Okay go to MY DOCUMENTS then MY GAMES then FALLOUT3 edit the FALLOuT.ini file with notepad. Look for a line that says bUseThreadedAI=0. Change that to say bUseThreadedAI=1

Then hit SPACE key and type in iNumHWThreads=2 right below the other line. (if you still get chrashes change the 2 to a 1)

Also uninstall Nero and AVG if you have them.

Also if you have any audio codec, add the games .exe to the exceptions.

Finally if all of that doesn't work, run it in compatibility for windows xp or windows vista.

Cheers!
Related resources
June 29, 2011 7:27:59 PM

shredder777 said:
Okay go to MY DOCUMENTS then MY GAMES then FALLOUT3 edit the FALLOuT.ini file with notepad. Look for a line that says bUseThreadedAI=0. Change that to say bUseThreadedAI=1

Then hit SPACE key and type in iNumHWThreads=2 right below the other line. (if you still get chrashes change the 2 to a 1)

Also uninstall Nero and AVG if you have them.

Also if you have any audio codec, add the games .exe to the exceptions.

Finally if all of that doesn't work, run it in compatibility for windows xp or windows vista.

Cheers!


Thankyou for the quick reply.

Is Realtek an audio codec and if I uninstall AVG free edition what antivirus program do you prefer better than that and free?
There is no .exe file for the steam version of the game only the steam shortcut and that has no compatability tab.
Lastly, when i am in my audio codec, how do i add the game to the exceptions?
The first option with the .ini file you gave me, is that the most likely one to fix the game?

Thanks again
June 29, 2011 7:38:25 PM

Yes, Realtek is audio related. If you are using on-board audio, then chances are it is Realtek.

Avast! is a good, free antivirus program. Also install Malwarebytes' Anti-Malware. The free version does not automatically scan your PC. You'll need to kick it off yourself, but work well in conjunction with antivirus programs.

The Steam shortcut must point to somewhere. Find out which .exe file it points to and from there you should be able to create a shortcut to run it in compatibility mode.
June 29, 2011 10:50:38 PM

To find the game go to programs>steam>steam games> Local> I think thats the path you should end up with folders for all your steam games.
June 30, 2011 12:11:55 AM

C:\Program Files (x86)\Steam\steamapps\common\fallout 3
is normaly where it is on win7 64bit

btw its actualy unsafe to run steam as administrator. it makes it less secure.
August 17, 2011 9:06:12 PM

Hey, ive tried looking for the bUseThreadedAI=0, but i cant find it anywhere, i've looked over about 5 times....could you tell me whereabouts it is in the fallout.ini??
thnx
November 13, 2011 1:37:25 PM

basti511 said:
Hey to all the Fallout 3 PC fans out there :hello:  , I have a problem with this game and require some help please. :bounce: 

So I have recently purchased the Fallout 3 GOTY edition through steam. When I open up the game everything seems fine and i can play it on fullest graphics. After about 5-7 minutes of playtime the game just randomly freezes. I then have to kill it with task manager. I also heard that Fallout 3 can't handle QUAD CORE PROCESSORS :o  since I have a quad core cpu I think that may be the fault but isn't there a fix for this? I can't progress in the game it freezes every damn 5 minutes and then I have to restart the game. I am also running steam as an administrator. People reckon that would fix it but it didn't.

My PC's specs are:
Intel Core i5 750 2,67GHz quad core cpu
Asus Nvidia GTX 470
2x2gb 1333MHz ddr3 corsair ram
Asus p7p55d-le mobo

Thanks, hope you can help me with this. :D 

I have a problem that is highly unusual! I cleaned off Fallout 3 with revo uninstaller and then reinstalled. Then, if I haven't done so I reinstall my video drivers, and start it from the fallout launcher on the disk or from a folder on my desktop. I you shut down, I have to reinstall the drivers again or it will not play. Other than that, I have played it about 20 hours without problems. Remember, reinstall drivers on completer shutdown, not hibernate.
Good luck
Dadd

I am running an AMD 965 with 8 gb of ram on an MSI 785G-E53 motherboard
!