Sign in with
Sign up | Sign in
Your question
Closed

Dirt 3 not launching in Win7 64bit

Last response: in Video Games
Share
July 4, 2011 1:53:28 AM

Hi all,

This is my pc config.

Intel i3 530 2.93Ghz
Intel DH55PJ motherboard
Corsair 4GB 1333Mhz + Kingston 2GB 1333Mhz = Total 6GB
Sapphire HD6670 1GB DDR5 graphics card
Sony DVD writer SATA
Seagate 160GB SATA HDD (OS + programs)
Seagate 1TB SATA HDD (media colln.)
Western Digital 1TB SATA HDD (media colln.)
Corsair VX450 PSU
OS: Win 7 Ultimate 64bit

I try to run the Dirt3 game and I get a prompt asking like

"Do you want to allow the following program to make changes to this computer?"
Program name: SecuLauncher
Verified publisher: Sony DADC Austria AG,
File Origin: Hard drive on this computer"

with "Yes" & "No" buttons.

On clicking "Yes", I see some HDD activity and then it goes off and the game doesn't even start. I tried reinstalling the game and even the ATI catalyst for 64bit but its of no use.

I had initially tried installing in Win7 32bit and played perfectly without any problems. After which I thought of utilsing the full capacity of RAM (6GB) and now ending up with problems of game not even launching.

Should go back to 32bit since its a problem with other games too or is there any fix for this issue.
Can anyone help on this please...
July 4, 2011 5:36:45 AM

Quote:
I'd go into your antivirus and make sure it isn't sand boxing any of your games. Have you tried running your game with admin permission?


Yes, I have tried running as adminstrator, but still no use. I tried installing another game Burnout Paradise Ultimate and it runs perfectly. But, breaking my head why Dirt 3 doesn't in 64bit. I am suprised that it ran perfectly in 32bit Win7 Ultimate without these admin permissions etc. With regard to antivirus, I have Kaspersky Internet Security 2011, should I make Dirt3.exe as trusted under "Threats & Exclusion" option? Will try that option also today evening when I reach home.

Any more thoughts to try pls....
Score
0
July 4, 2011 5:41:13 AM

Just so you know that there should be a solution, I run Dirt 3 on Win 7-64 bit Home Premium. It is the Steam version, if that makes a difference.
Score
0
Related resources

Best solution

July 4, 2011 2:36:14 PM

Did you disabled the GFWL sign in agent or blocked it.Enable it and it will start.
Share
July 4, 2011 4:20:24 PM

Quote:
maybe turn off your antivirus and stuff and give the game a go. All else try defrag lol.

Sorry man...even that option failed. Any more thoughts?
Score
0
July 4, 2011 4:23:01 PM

Mudit Sathe said:
Did you disabled the GFWL sign in agent or blocked it.Enable it and it will start.

How to I disable this? pls guide me step by step process....
Score
0
July 5, 2011 5:53:43 AM

Hi all,

Thank very much for your inputs and suggestions. At last got the game running on 64bit.

This is what I did....
I manually installed "Games for Windows Live" and eurekha the game started, but in window mode (not fullscreen). Then I modified the hardware config file inside the "My Games\Dirt3\" folder where fullscreen mode was "false" and set to "true". I copied my previous saved games which I have been playing in 32bit to the "savegame" folder. And the game worked perfectly. I am very happy to get this game running perfectly on Win7 64bit.

Thank you all once again for your support & guidance...
Score
0
July 5, 2011 2:00:50 PM

next time it goes windowed. just tap alt+return, it will switch back to FS mode.
Score
0
July 6, 2011 12:14:56 AM

HEXiT said:
next time it goes windowed. just tap alt+return, it will switch back to FS mode.


Thank yo very much for the tip, will try this next time when it happens...
Score
0
July 13, 2011 3:44:11 AM

Best answer selected by eummagic.
Score
0
August 29, 2011 11:51:31 AM

This topic has been closed by Mousemonkey
Score
0
!