Sign in with
Sign up | Sign in
Your question

Can't run games on high graphic settings please help

Last response: in Video Games
Share
July 6, 2011 11:26:50 PM

Hello
i got a new gaming laptop about a week ago brand new out of the box. it can run games like crysis and men of war on there highest settings with good frame rates but for the games empire total war napoleon total war it only allows me to run it o medium settings am really confused is this system not good enough for these games -

CPU intel i7 2720q 2.2ghz is also has a turbo boost to 3.3ghz with 6mb cache
RAM 8 gigs at 1600mhz ddr3
GPU nvidia geforce gt555m with 3 gigs of ddr3 ram

any ifo will be deeply appreciated
Thanks
July 7, 2011 12:20:45 AM

Are you getting poor performance in the total war games, or are the high settings simply grayed out?

Check to make sure that the total war games are using the GT555m as the graphics adapter and not the intel integrated graphics. Reinstalling the games in question may also help.
m
0
l
July 7, 2011 3:03:27 AM

thanks for the replay so soon
The high and very high settings are grayed out doesn't let me do anything with it. when i play empire with only medium settings i have aa as high as it can go all the other effects and things on and it runs as smooth as can be so i don't see why it won't let me choose high settings.
This is the same for napoleon total war only every time i try doing a battle it crashes at the loading screen.
Now for the graphics card ive forced to use the high performance nvidia card and not the integrated countless times and same as before, i have directx11 the latest drivers i just don't understand
I havent tried reinstalling so ill give that a try but ounce again thanks so much for the quick reply
m
0
l
Related resources
July 7, 2011 11:37:10 AM

no your laptop isnt meant for gaming. no laptop is.
even 1s that claim they are.
they cant get rid of the heat quick enough.
after a few months of sitting in a dusty room it will start over heating.
not your fault. just laptops are dust magnets.
this will cause parts to heat up quicker and throttle back. reducing performance.
i guarantee you will be back here soon sating why are my games running slowly, they used to play fine.

even with the best mobile gpu your never gonna get comparable to desktop performance coz your always gonna be stuck with a mobility gpu.

as for the game settings dont worry about them. i spend most of the game at birds eye view so it looks the same as if i had it on low settings anyway, even though its maxed.
m
0
l
July 7, 2011 5:26:03 PM

Supernova1138 said:
Are you getting poor performance in the total war games, or are the high settings simply grayed out?

Check to make sure that the total war games are using the GT555m as the graphics adapter and not the intel integrated graphics. Reinstalling the games in question may also help.


So i just tryed installing it again made sure that it was using the high performance nvidia processor and not the integrated but same as before high and very high settings are grayed out does it only read the integrated graphics card or something?
m
0
l
July 7, 2011 7:44:49 PM

Sounds like the game seems to think your GPU doesn't support the high settings. Go into your device manager and see what Windows identifies the nvidia GPU as. If it is picking it up as something lower end, or as a generic adapter that might be the problem. If that is the case try reinstalling your drivers, the driver installer may not have properly detected your graphics hardware.
m
0
l
July 7, 2011 10:26:40 PM

Supernova1138 said:
Sounds like the game seems to think your GPU doesn't support the high settings. Go into your device manager and see what Windows identifies the nvidia GPU as. If it is picking it up as something lower end, or as a generic adapter that might be the problem. If that is the case try reinstalling your drivers, the driver installer may not have properly detected your graphics hardware.


YA something was wierd with the gpu i went to its preferences scripts and apparently it didn't read the caard right after i put in the correct info i can now run the games on high or very high settings empire run very smoothly on very high settings but still everytime i try to start a battle with napoleon it crashes but thanks for all your help
m
0
l
July 7, 2011 10:48:15 PM

HEXiT said:
no your laptop isnt meant for gaming. no laptop is.
even 1s that claim they are.
they cant get rid of the heat quick enough.
after a few months of sitting in a dusty room it will start over heating.
not your fault. just laptops are dust magnets.
this will cause parts to heat up quicker and throttle back. reducing performance.
i guarantee you will be back here soon sating why are my games running slowly, they used to play fine.

even with the best mobile gpu your never gonna get comparable to desktop performance coz your always gonna be stuck with a mobility gpu.

as for the game settings dont worry about them. i spend most of the game at birds eye view so it looks the same as if i had it on low settings anyway, even though its maxed.


that is changing rather quickly. ive had three i7 laptops and none of which got above 80*c and normally stayed below 72-73*c which is way below the 100*c ceiling.

give them a break. some can make the cut.
m
0
l
!