Sign in with
Sign up | Sign in
Your question
Solved

Fallout 3 on AMD 6850 performance issue

Last response: in Video Games
Share
July 7, 2011 11:35:58 PM

So, after getting my 6850 i was expecting things to run great, which they do mosatly. I can max out crysis warhead and get smooth gameplay. Fallout 3 is another story. The fps dips down to 30fps or lower. Turning on/off vsync doesnt affect performance at all, still capped to 60fps. Turning down detail settings doesn't remove this anomoly. Is a 3.2ghz core 2 duo really not enough to run this game at a constant 40fps+? thats what i would like to achieve. The times the FPS dips is really random, like being in an open field looking to the distance its 60fps solid mostly, then duck between some buildings and look at a wall and its 30 fps..... i cant figure this one out. I'll probably look at the fallout 3 tweak guide and try some things in that. And yes i have latest catalyst drivers and all win 7 updates and the game is legit and updated. Would like some input from someone else running the a 6850 and what settings and FPS they are getting.....
July 8, 2011 4:32:41 AM

Bethesda games are like that, you just can't explain their behavior some time. :p 

However, Bethesda games like Fallout 3 and Oblivion also dont seem to like Windows 7 that much.
m
0
l
July 8, 2011 6:53:29 AM

^maxed out with how much AA? i can manage 4xAA with all quality settings on, as soon as i put it to 8x with superdoopersampling i see a fair performance hit. and this is at 1440x900 res. I know i need some more ram that may be the key, also a quad core couldn't hurt.
m
0
l
Related resources
July 8, 2011 6:46:55 PM

iam2thecrowe said:
^maxed out with how much AA? i can manage 4xAA with all quality settings on, as soon as i put it to 8x with superdoopersampling i see a fair performance hit. and this is at 1440x900 res. I know i need some more ram that may be the key, also a quad core couldn't hurt.

Are you setting supersampling in CCC? I have a 6950 and max out every in game setting with the hi res mod and am sitting at 60 fps most of the time. If you are doing your AA through CCC I would suggest only using the setting that are adjustable when you first start the game.
m
0
l
July 9, 2011 4:35:13 PM

yeah, i guess you should try out the tweak guides, they're really helpful. What about no AA ?
m
0
l
July 10, 2011 2:49:05 AM

iam2thecrowe said:
^maxed out with how much AA? i can manage 4xAA with all quality settings on, as soon as i put it to 8x with superdoopersampling i see a fair performance hit. and this is at 1440x900 res. I know i need some more ram that may be the key, also a quad core couldn't hurt.


8x super sampling is simply too much for you graphics card to handle. it is also not really a worthwhile setting considering the huge performance hit.
m
0
l
July 10, 2011 11:06:31 PM

^yeah i dont have a problem with 4xAA, but the issue is im getting low fps where you would not expect, like when looking strait at a wall. what about tripple buffering? When i had my 8800gts that setting worked magic. Only AMD doesnt give me an option to force it (only for opengl). I did a quick search and can only find old threads about this and having trouble finding something compatable with win7. DX overrider....
m
0
l
July 11, 2011 2:55:16 AM

yeah, ive already done a clean install of the amd drivers, used driversweeper to remove old nvidia ones and have only installed cat 11.6. Im going to frig around with the ini file tonight. I had the cpu at 3.4 but had to increase voltage a bit more, its at 1.3v ATM stable, the 200mhz difference isnt noticeable anyway.
m
0
l
July 13, 2011 10:53:43 AM

well have found the issue. Not GPU related at all. Surprisingly a 3.2ghz core 2 duo bottlenecks this game. When in point lookout when you walk between the first buildings you see (where the duck shoot game thingy is), im getting around 38fps. I dropped the speed back to the stock 2.4ghz and the fps dropped to 30fps.
m
0
l
July 13, 2011 11:39:21 PM

iam2thecrowe said:
well have found the issue. Not GPU related at all. Surprisingly a 3.2ghz core 2 duo bottlenecks this game. When in point lookout when you walk between the first buildings you see (where the duck shoot game thingy is), im getting around 38fps. I dropped the speed back to the stock 2.4ghz and the fps dropped to 30fps.

If your changing setting in CCC I would recommend having CCC back off and let the game settings take over. Having CC force things like super sampling and AA hurts FPS much mor than just maxing out whatever settings the game has.
m
0
l
July 14, 2011 3:23:17 AM

no, CCC is at defaults and I am using the game settings. But nevermind, its not that anyway, its the CPU. Doesnt matter if i have 4xAA or 0xAA, FPS in certain parts doesnt change, only CPU clock changes the FPS. Im going to upgrade that pretty soon anyway, i might give the old e6600 one last go and see if i can push it to 3.6ghz.........
m
0
l

Best solution

July 14, 2011 3:55:00 PM

iam2thecrowe said:
no, CCC is at defaults and I am using the game settings. But nevermind, its not that anyway, its the CPU. Doesnt matter if i have 4xAA or 0xAA, FPS in certain parts doesnt change, only CPU clock changes the FPS. Im going to upgrade that pretty soon anyway, i might give the old e6600 one last go and see if i can push it to 3.6ghz.........

going to make the jump to sandy bridge? If so see if you can get it to 4ghz lol. whats the worst that could happen....
Share
July 14, 2011 9:55:43 PM

your right! It is winter here and ambient temps are cold........ i do need it to last a couple more months though.
m
0
l
July 15, 2011 1:55:51 AM

open your ccc panel go to gaming 3d settings and set it to default.
open the settings menu in FO3 and set fsaa to 4 no more.
always run the game at the native rez of the monitor and then reduce gfx settings if you need to. only use the games options not the ccc panel.

1s yor happy with the performance then go into the ccc panel and adjust the quality of the textures but make sure you turn off morphalogical filters.
m
0
l
July 15, 2011 4:11:09 AM

yeah, its actually all sorted, running fine at max details, supersampling and 4xaa turned on in game settings, CCC set to defaults. Just the cpu causing the slowdowns. now....on to 3.6ghz! and maybe more.
m
0
l
July 15, 2011 4:11:28 AM

Best answer selected by iam2thecrowe.
m
0
l
!